SOLVED

Events Webpart - Can't create new events

%3CLINGO-SUB%20id%3D%22lingo-sub-116140%22%20slang%3D%22en-US%22%3EEvents%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116140%22%20slang%3D%22en-US%22%3E%3CP%3ECreated%20a%20new%20modern%20page%20on%20an%20existing%20site%20collection%2C%20added%20the%20Events%20webpart%2C%20and%20attepted%20to%20create%20an%20event.%20The%20link%20for%20'Add%20event'%20was%20https%3A%2F%2F%3CTENANT.%3Esharepoint.com%2Fpd%2F_layouts%2F15%2FEvent.aspx%3FListGuid%3D%3CGUID%3E%26amp%3BMode%3DEdit.%20It%20redirected%20me%20to%26nbsp%3Bhttps%3A%2F%2F%3CTENANT%3E.sharepoint.com%2Fpd%2F_layouts%2F15%2FEvent.aspx%3FListGuid%3D%3CGUID%3E%2C%20which%20is%20a%20read%20only%20event%20for%20today%20from%20now%20until%20an%20hour%20from%20now.%20No%20matter%20what%20browser%20I%20use%20or%20what%20screen%20I%20click%20'Add%20event'%20on%2C%20it%20always%20redirects%20me%20to%20this%20read%20only%20page.%20The%20only%20way%20I've%20managed%20to%20create%20a%20new%20event%20was%20by%20going%20to%20Site%20Contents%20%26gt%3B%20Events%20%26gt%3B%20and%20creating%20the%20new%20event%20on%20the%20(classic)%20calander%20there.%20Anyone%20have%20the%20hard%20link%20for%20creating%20a%20new%20event%20from%20the%20modern%20interface%3F%20%22%26amp%3BMode%3DEdit%22%20doesn't%20seem%20to%20want%20to%20work.%3C%2FGUID%3E%3C%2FTENANT%3E%3C%2FGUID%3E%3C%2FTENANT.%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20deleted%20the%20webpart%20and%20readded%20it%20several%20times%20too%2C%20no%20luck.%20I'm%20logged%20in%20as%20the%20Global%20Admin.%20Anyone%20else%20experiencing%20this%20with%20this%20webpart%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-116140%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECalendar%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-220368%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-220368%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20receiving%20the%20following%20error%20%22%3CEM%3EThis%20link%20is%20not%20valid.%20Check%20the%20link%20and%20try%20again.%3C%2FEM%3E%22%20when%20ever%20I%20attempt%20to%20add%20an%20event%20using%20the%20web%20part%2C%20could%20you%20please%20advise%20what%20and%20how%20I%20resolve%20this%20issue%20please%3F%3C!--%20%20react-text%3A%2015%20%20--%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-206266%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-206266%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Lamia%2C%20would%20you%20please%20repro%20steps%20for%20the%20issue%20on%20your%20tenant%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-205756%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-205756%22%20slang%3D%22en-US%22%3E%3CP%3EHello-%20we%20are%20experiencing%20this%20issue.%20Let%20me%20know%20what%20I%20should%20provide%20to%20get%20this%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-205755%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-205755%22%20slang%3D%22en-US%22%3E%3CP%3EHello-%20We%20are%20getting%20this%20error%20in%20our%20tenant.%20What%20are%20the%20steps%20to%20get%20this%20resolved%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-130868%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-130868%22%20slang%3D%22en-US%22%3E%3CP%3EIs%20this%20problem%20reappearing%2C%20if%20we%20wan't%20to%20add%20an%20event.%3C%2FP%3E%0A%3CP%3EWe%20get%20an%20error%20'This%20link%20is%20not%20valid.%20Check%20the%20link%20and%20try%20again.'%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-124248%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-124248%22%20slang%3D%22en-US%22%3E%3CP%3EGreat!%20It's%20been%20fixed.%20Thanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-123846%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-123846%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20that%20fixed%20it%20for%20me.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-123795%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-123795%22%20slang%3D%22en-US%22%3EYes%20this%20is%20working%20our%20tenant%20as%20well..%20Thanks.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-123777%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-123777%22%20slang%3D%22en-US%22%3E%3CP%3EYep%2C%20it's%20fixed.%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-123772%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-123772%22%20slang%3D%22en-US%22%3E%3CP%3ESome%20of%20you%20might%20have%20had%20issues%20with%20Events%20if%20using%20Firefox.%3CBR%20%2F%3EPlease%20recheck%2C%20the%20problem%20should%20be%20gone%20by%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-121186%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-121186%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20also%20still%20having%20the%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-117743%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-117743%22%20slang%3D%22en-US%22%3E%3CP%3EI%20still%20seem%20to%20be%20having%20the%20problem%20-%20trying%20to%20create%20a%20new%20event%20just%20takes%20me%20to%20a%20page%20with%20an%20event%20running%20for%20an%20hour%20from%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116940%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116940%22%20slang%3D%22en-US%22%3EAwesome!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116889%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116889%22%20slang%3D%22en-US%22%3E%3CP%3EWorks%20great%20for%20us%20now%2C%20no%20tinkering%20was%20required%2C%20thanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F87147%22%20target%3D%22_blank%22%3E%40Evgeniia%20Firsova%3C%2FA%3E!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116457%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116457%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20issue%20was%20fixed%20around%20an%20hour%20ago.%3C%2FP%3E%0A%3CP%3EPlease%20let%20me%20know%20if%20you%20still%20are%20experiencing%20this%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116388%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116388%22%20slang%3D%22en-US%22%3EYep%2C%20seeing%20the%20same%20problem%20here...it%20does%20not%20work%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116384%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116384%22%20slang%3D%22en-US%22%3E%3CP%3EHaving%20the%20same%20issue%20as%20of%20this%20morning.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116355%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116355%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-116145%22%20slang%3D%22en-US%22%3ERe%3A%20Events%20Webpart%20-%20Can't%20create%20new%20events%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-116145%22%20slang%3D%22en-US%22%3E%3CP%3EI%20can%20verify%20that%20I%20am%20experiencing%20the%20same%20issue%20on%20two%20of%20my%20tenants.%2C%20and%20this%20used%20to%20work...%20Something%20must%20happen%20on%20Microsoft's%20end.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

Created a new modern page on an existing site collection, added the Events webpart, and attepted to create an event. The link for 'Add event' was https://<tenant.>sharepoint.com/pd/_layouts/15/Event.aspx?ListGuid=<GUID>&Mode=Edit. It redirected me to https://<tenant>.sharepoint.com/pd/_layouts/15/Event.aspx?ListGuid=<GUID>, which is a read only event for today from now until an hour from now. No matter what browser I use or what screen I click 'Add event' on, it always redirects me to this read only page. The only way I've managed to create a new event was by going to Site Contents > Events > and creating the new event on the (classic) calander there. Anyone have the hard link for creating a new event from the modern interface? "&Mode=Edit" doesn't seem to want to work.

 

I've deleted the webpart and readded it several times too, no luck. I'm logged in as the Global Admin. Anyone else experiencing this with this webpart?

20 Replies

I can verify that I am experiencing the same issue on two of my tenants., and this used to work... Something must happen on Microsoft's end.

I have the same issue

Having the same issue as of this morning.

Yep, seeing the same problem here...it does not work
best response confirmed by Paul Youngberg (Frequent Contributor)
Solution

The issue was fixed around an hour ago.

Please let me know if you still are experiencing this issue.

Works great for us now, no tinkering was required, thanks @Evgeniia Firsova!!

Awesome!

I still seem to be having the problem - trying to create a new event just takes me to a page with an event running for an hour from now.

I am also still having the problem.

Some of you might have had issues with Events if using Firefox.
Please recheck, the problem should be gone by now.

Yep, it's fixed. Thanks.

Yes this is working our tenant as well.. Thanks.

Yes, that fixed it for me.

Great! It's been fixed. Thanks

Is this problem reappearing, if we wan't to add an event.

We get an error 'This link is not valid. Check the link and try again.'

Hello- We are getting this error in our tenant. What are the steps to get this resolved?

 

Hello- we are experiencing this issue. Let me know what I should provide to get this working.

Hi Lamia, would you please repro steps for the issue on your tenant? 

I am receiving the following error "This link is not valid. Check the link and try again." when ever I attempt to add an event using the web part, could you please advise what and how I resolve this issue please?