Error when trying to add a site column for specific sites only

%3CLINGO-SUB%20id%3D%22lingo-sub-2082341%22%20slang%3D%22en-US%22%3EError%20when%20trying%20to%20add%20a%20site%20column%20for%20specific%20sites%20only%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2082341%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20Community%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20facing%20an%20error%20when%20trying%20to%20add%20a%20new%20site%20column%20in%20Doc%20libraries%20for%20specific%20sites%20only%20in%20my%20SharePoint%20server%202013%20farm.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20server%20logs%20shows%3A%26nbsp%3B%20No%20two%20choices%20should%20have%20the%20same%20ID%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20searched%20for%20a%20solution%20on%20the%20web%20and%20found%20the%20same%20proposed%20resolution%20on%20different%20sites%20which%20is%20to%20identify%20duplicates%20with%20the%20help%20of%20a%20Powershell%20script%20and%20then%20delete%20that%20duplicate%20site%20column%20(%3C%2FP%3E%3CP%3ERunning%20the%20script%20did%20not%20show%20any%20duplication%26nbsp%3Bin%20either%20site%20column%20internal%20name%20or%20ID.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20fact%20that%20this%20error%20only%20triggers%20on%20some%20sub-sites%20and%20not%20on%20others%20at%20the%20same%20level%20but%20does%20not%20at%20the%20site%20collection%20level%20suggest%20it's%20not%20coming%20from%20the%20root%20site%20columns%20but%20from%20elsewhere.%20Note%20that%20I%20can%20add%20regular%20columns%20without%20any%20problem%20and%20that%20management%20of%20content%20types%20is%20disabled%3C%2FP%3E%3CP%3EAfter%20spending%20hours%20on%20this%20I%20don't%20know%20what%20else%20I%20can%20do%20and%20therefore%20seeking%20any%20advise%20on%20what%20to%20do%20next.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2082341%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Dear Community,

 

I'm facing an error when trying to add a new site column in Doc libraries for specific sites only in my SharePoint server 2013 farm.

 

The server logs shows:  No two choices should have the same ID

 

I've searched for a solution on the web and found the same proposed resolution on different sites which is to identify duplicates with the help of a Powershell script and then delete that duplicate site column (

Running the script did not show any duplication in either site column internal name or ID.

 

The fact that this error only triggers on some sub-sites and not on others at the same level but does not at the site collection level suggest it's not coming from the root site columns but from elsewhere. Note that I can add regular columns without any problem and that management of content types is disabled

After spending hours on this I don't know what else I can do and therefore seeking any advise on what to do next.

 

Thank you.

 

 

 

0 Replies