Error - We only support linking to files in your organization

Microsoft

Getting this 'We only support linking to files in your organization' when I use any link. Any suggestions on how to fix this?

sai_koduri_0-1662599254161.png

 

5 Replies

@sai_koduri 

 

Where you are trying to add link in the page? 


I have tried in Quick Links web part where I can add external link:

 

kalpeshvaghela_0-1662610301346.png

 

 

 

@kalpeshvaghela I am trying to add it in the hero web part through link

sai_koduri_0-1662616791693.pngsai_koduri_1-1662616835766.png

 

@sai_koduri 

 

I was able to replicate issue and fixed it by adding domain of the link as allowed domain under HTML Field Security settings.


Go to Site Settings and Click on HTML Field Security:

 

kalpeshvaghela_0-1662619738196.png

 

Add your domain of the link as shown in below screen shot:

 

kalpeshvaghela_1-1662619792414.png

 

 


Hope it will helpful to you and if so then Please mark my response as Best Response & Like to help others in this community

 

 

 

 

@kalpeshvaghela 

 

I'm getting the same issue for hero webparts and tried the work around by adding it to HTML Field Security. This was not an issue previously. 

I don't have Site Collection Administration permissions and our IT is contracted that has this level of permission. I hope they change this because it will be a HUGE hinderance to managing our intranet if I can't link the Hero to an external site.