Error connecting to tenant root site with SharePoint Designer

%3CLINGO-SUB%20id%3D%22lingo-sub-199543%22%20slang%3D%22en-US%22%3EError%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199543%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20trying%20to%20connect%20to%20%2F%20open%20anything%20in%20the%20tenant%20root%20site%20collection%2C%20I'm%20getting%20an%20error%20'Microsoft%20SharePoint%20Designer%20does%20not%20support%20editing%20non-SharePoint%20sites'.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20connect%20fine%20to%20other%20site%20collections%20in%20the%20tenant%2C%20and%20I%20can%20connect%20fine%20to%20sub%20sites%20in%20the%20root%20site%20collection.%3C%2FP%3E%3CP%3EI%20can%20reproduce%20the%20error%20on%202%20different%20tenants%2C%20and%20the%20error%20has%20only%20been%20seen%20in%20the%20last%20week%20or%20so.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20anyone%20else%20able%20to%20reproduce%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20all%20the%20usual%20tricks%20-%20clearing%20the%20SP%20Designer%20cache%2C%20repairing%20the%20installation%2C%20opening%20the%20site%20in%20IE%20and%20then%20selecting%20'edit%20in%20SharePoint%20Designer'%2C%20etc.%20-%20nothing%20seems%20to%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-199543%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-199993%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199993%22%20slang%3D%22en-US%22%3Efor%20the%20settings%20page%20-%20first%20box%20is%20tick%2C%20others%20are%20unticked%20-%20as%20I%20would%20expect.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-199991%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199991%22%20slang%3D%22en-US%22%3EHi%20Paul%20-%20it%20now%20works%20fine%20on%20my%20tenant%2C%20but%20not%20on%20the%20customer%20tenant.%3CBR%20%2F%3E%3CBR%20%2F%3EOn%20both%2C%20it%20is%20the%20default%20root%20site%20collection%20-%20so%20effectively%20a%20classic%20teamsite%20-%20but%20in%20both%20tenants%20I%20can%20successfully%20connect%20to%20a%20subsite%20in%20that%20root%20collection%2C%20and%20also%20to%20other%20site%20collections%20(which%20are%20modern%2C%20actually)%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-199695%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199695%22%20slang%3D%22en-US%22%3EI'd%20put%20in%20a%20ticket%2C%20if%20I%20had%20to%20guess%20it%20could%20be%20something%20with%20what%20they%20changed%20with%20the%20NTML%20authentication%20to%20fix%20guest%20access%20issues%20with%20pulling%20photos%2Finfo%20and%20stuff%20from%20root%20collections.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-199694%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199694%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20tried%20in%20my%20tenant%20and%20connecting%20to%20my%20root%20site%20works%20fine.%20What%20type%20of%20site%20is%20created%20at%20your%20tenant's%20root%3F%20SharePoint%20Designer%20is%20not%20supported%20for%20modern%20sites%20because%20of%20the%20NoScript%20setting%20as%20described%20in%20the%20article%20below%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fsolution-guidance%2Fmodern-experience-customizations-customize-sites%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fsolution-guidance%2Fmodern-experience-customizations-customize-sites%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20do%20the%20settings%20look%20like%20if%20you%20browse%20to%26nbsp%3B%2F_layouts%2F15%2FSharePointDesignerSettings.aspx%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1489988%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20connecting%20to%20tenant%20root%20site%20with%20SharePoint%20Designer%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1489988%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F506%22%20target%3D%22_blank%22%3E%40Rob%20Ellis%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20Rob%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20you%20submit%20a%20ticket%20for%20this%20issue%3F%26nbsp%3B%20I%20recently%20starting%20seeing%20this%20the%20same%20behavior%20--%20can%20open%20a%20subsite%20in%20Designer%202013%20but%20not%20the%20root%20site.%26nbsp%3B%20Any%20assistance%20is%20appreciated.%26nbsp%3B%20BTW%2C%20I%20cleared%20Designer%20cache%2C%20uninstalled%2Freinstalled%20Designer%20but%20still%20received%20the%20same%20error%3A%26nbsp%3B%3CBR%20%2F%3EMicrosoft%20SharePoint%20Designer%20does%20not%20support%20editing%20non-SharePoint%20sites.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELouise%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Valued Contributor

When trying to connect to / open anything in the tenant root site collection, I'm getting an error 'Microsoft SharePoint Designer does not support editing non-SharePoint sites'.

 

I can connect fine to other site collections in the tenant, and I can connect fine to sub sites in the root site collection.

I can reproduce the error on 2 different tenants, and the error has only been seen in the last week or so.

 

Is anyone else able to reproduce?

 

I've tried all the usual tricks - clearing the SP Designer cache, repairing the installation, opening the site in IE and then selecting 'edit in SharePoint Designer', etc. - nothing seems to help.

5 Replies
Highlighted

I've tried in my tenant and connecting to my root site works fine. What type of site is created at your tenant's root? SharePoint Designer is not supported for modern sites because of the NoScript setting as described in the article below:

https://docs.microsoft.com/en-us/sharepoint/dev/solution-guidance/modern-experience-customizations-c...

 

What do the settings look like if you browse to /_layouts/15/SharePointDesignerSettings.aspx ?

Highlighted
I'd put in a ticket, if I had to guess it could be something with what they changed with the NTML authentication to fix guest access issues with pulling photos/info and stuff from root collections.
Highlighted
Hi Paul - it now works fine on my tenant, but not on the customer tenant.

On both, it is the default root site collection - so effectively a classic teamsite - but in both tenants I can successfully connect to a subsite in that root collection, and also to other site collections (which are modern, actually)
Highlighted
for the settings page - first box is tick, others are unticked - as I would expect.
Highlighted

@Rob Ellis 

 

Hi Rob,

 

Did you submit a ticket for this issue?  I recently starting seeing this the same behavior -- can open a subsite in Designer 2013 but not the root site.  Any assistance is appreciated.  BTW, I cleared Designer cache, uninstalled/reinstalled Designer but still received the same error: 
Microsoft SharePoint Designer does not support editing non-SharePoint sites. 

 

Thanks!

 

Louise