Enforcing presence of one field based on the contents of another

%3CLINGO-SUB%20id%3D%22lingo-sub-2753611%22%20slang%3D%22en-US%22%3EEnforcing%20presence%20of%20one%20field%20based%20on%20the%20contents%20of%20another%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2753611%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EWhat's%20wrong%20with%20this%20SharePoint%20field%20validation%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22BruceTW_0-1631724046101.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F310622i518DCCAFE5EB246B%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22BruceTW_0-1631724046101.png%22%20alt%3D%22BruceTW_0-1631724046101.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20get%20the%20following%20unhelpful%20error%20message%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22BruceTW_1-1631724104895.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F310623i48A2F25B19131E71%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22BruceTW_1-1631724104895.png%22%20alt%3D%22BruceTW_1-1631724104895.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2753611%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi,

What's wrong with this SharePoint field validation?

BruceTW_0-1631724046101.png

 

I get the following unhelpful error message:

BruceTW_1-1631724104895.png

 

 

2 Replies
Well the first thing that looks wrong is no opening parentheses between IF and ISBLANK.
Thanks Rob, good spot.

That fixed the formula but then I got a different problem "The formula cannot refer to another column. " Which is a bit annoying and I can't se a way around it.

How do you make a column mandatory only when another column has a particular value?