Enabling attachments in a forms library item to open in sharepoint instead of downloading

Copper Contributor

I am working with a list in a forms library within sharepoint. When I open the line item I am able to add attachments. I would like the attachments to be working documents and open and be available for edit within sharepoint rather than downloading and saving to my computer. 

 

The way I currently have it set up is that I uploaded the form I wanted to attach in another folder within the sharepoint. Then when I went to attach it to the forms library item, I put in the path to that sharepoint folder where the form is stored. Regardless, it still downloads the form to my conputer rather than opening it for editing in sharepoint. 

 

ARippy_0-1677682925504.pngARippy_1-1677682988523.png

 

2 Replies

 

  1. Upload the document to a SharePoint document library.

  2. Copy the URL of the document. You can do this by selecting the document in the library and clicking on the "Copy link" option in the "Share" menu.

  3. Open the list item to which you want to attach the document, and click on the "Attach File" button.

  4. In the "Attach File" dialog, paste the URL of the document in the "File name" field.

  5. Remove the beginning of the URL, up to and including the SharePoint domain name. For example, if the URL is "https://contoso.sharepoint.com/sites/TeamSite/Documents/Document1.docx", remove "https://contoso.sharepoint.com".

  6. Add the text "ms-word:ofe|u|" before the remaining part of the URL, like this: "ms-word:ofe|u|/sites/TeamSite/Documents/Document1.docx".

  7. Click "OK" to attach the document to the list item.

@ARippy 

Hi @jaortizgolf78. Thanks for the reply! When I get to step seven and click "open" (There is no okay button) I get an error message saying the path is not valid. 

 

ARippy_0-1678403635299.png

This is the text I entered : ms-word:ofe|u|/sites/esBOPBlueSkyers/Shared%20Documents/03.%20BDX%20Team/04.Property/Form%20Drafts/Test.docx?d=w39bbc6a6d6e640328931833e6d5382ab&csf=1&web=1&e=gT3knt

 

Did I miss something?