Doc ID's suddenly stop working in particular SharePoint Online site collection

%3CLINGO-SUB%20id%3D%22lingo-sub-41218%22%20slang%3D%22en-US%22%3EDoc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41218%22%20slang%3D%22en-US%22%3E%3CP%3EAnyone%20ever%20seen%20DocIDs%20in%20SharePoint%20Online%20(%3CSPAN%3E%2F_layouts%2F15%2FDocIdRedir.aspx%3FID%3D%3C%2FSPAN%3E%3CSPAN%3EDOCIDHERE%3C%2FSPAN%3E%3CSPAN%3E-2101393222-10)%20just%20stop%20working%3C%2FSPAN%3E%3F%20%26nbsp%3BThey%20are%20not%20resolving%20to%20their%20actual%20source%20documents%20and%20instead%20going%20to%20the%20OSSSearchResults.aspx%20search%20page%20instead%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20forced%20a%20re-index%20of%20the%20site%20collections%2C%20so%20hopefully%20that%20will%20fix%20it%20at%20some%20point%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20use%20them%20pretty%20heavily%2C%20so%20definitely%20don't%20want%20to%20regenerate%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20seems%20to%20be%20limited%20to%20a%20particular%20site%20collection%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-41218%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-63236%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-63236%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20%3A)Will%20try%20the%20re-indexing%20of%20the%20library%20first%2C%20then%20will%20poke%20Microsoft%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-63227%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-63227%22%20slang%3D%22en-US%22%3EAfter%20contacting%20premier%20support%2C%20they%20had%20to%20manually%20rebuild%20the%20index%20somehow%2C%20not%20sure%20exactly%20what%20they%20did%20did%20or%20how%20they%20did%20it%2C%20took%20about%20a%20week%20to%20complete%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-63190%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-63190%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Brent%3C%2FP%3E%3CP%3EDid%20you%20find%20a%20solution%20for%20this%20issue%3F%20After%20Easter%20we%20now%20suddenly%20also%20has%20this%20issue!%20Also%20only%20for%20Document%20Sets%2C%20and%20only%20in%20one%20Library!%3C%2FP%3E%3CP%3EKind%20regards%3C%2FP%3E%3CP%3EJohn%20Aage%20Andersen%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41385%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41385%22%20slang%3D%22en-US%22%3EA%20little%20more%20testing%20and%20exploration%2C%20this%20is%20affecting%20Document%20Sets%20ONLY%2C%20and%20it%20is%20tenant%20wide%20for%20us.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41377%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41377%22%20slang%3D%22en-US%22%3EThat%20matches%20it%20exactly.%20On%20the%20search%20results%20page%2C%20it%20does%20show%202%20copies%20of%20the%20same%20file%20(in%20this%20case%20a%20document%20set).%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41339%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41339%22%20slang%3D%22en-US%22%3E%3CP%3ENot%20a%20direct%20solution%2C%20but%20similar%20behavior%20is%20discussed%20in%20this%20thread%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fsharepoint%2Fen-US%2F15b28286-70b7-4640-9fd9-28f1c298ec54%2Fdocidrediraspx-redirect-to-search%3Fforum%3Dsharepointadminprevious%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fsharepoint%2Fen-US%2F15b28286-70b7-4640-9fd9-28f1c298ec54%2Fdocidrediraspx-redirect-to-search%3Fforum%3Dsharepointadminprevious%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-41275%22%20slang%3D%22en-US%22%3ERe%3A%20Doc%20ID's%20suddenly%20stop%20working%20in%20particular%20SharePoint%20Online%20site%20collection%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-41275%22%20slang%3D%22en-US%22%3EBest%20here%20is%20to%20open%20a%20support%20ticket%20so%20they%20can%20review%20if%20something%20is%20wrong%20with%20the%20DocID%20timer%20jobs%3C%2FLINGO-BODY%3E
Valued Contributor

Anyone ever seen DocIDs in SharePoint Online (/_layouts/15/DocIdRedir.aspx?ID=DOCIDHERE-2101393222-10) just stop working?  They are not resolving to their actual source documents and instead going to the OSSSearchResults.aspx search page instead

 

I've forced a re-index of the site collections, so hopefully that will fix it at some point

 

We use them pretty heavily, so definitely don't want to regenerate them.

 

It seems to be limited to a particular site collection

7 Replies
Best here is to open a support ticket so they can review if something is wrong with the DocID timer jobs
That matches it exactly. On the search results page, it does show 2 copies of the same file (in this case a document set).
A little more testing and exploration, this is affecting Document Sets ONLY, and it is tenant wide for us.

Hi Brent

Did you find a solution for this issue? After Easter we now suddenly also has this issue! Also only for Document Sets, and only in one Library!

Kind regards

John Aage Andersen

After contacting premier support, they had to manually rebuild the index somehow, not sure exactly what they did did or how they did it, took about a week to complete

Thanks :) Will try the re-indexing of the library first, then will poke Microsoft :)