Disappearing Hyperlink URL

New Contributor

I created a new sub site in SharePoint 2016. Now I am trying to create hyperlinks to pages in the site on the main page similar to a table of contents. Not all, but some of the hyperlinks when created do not work. After created they show up blue on the page but are not clickable. Then when I re edit the page the URL is gone and has disappeared in the hyperlink area. Any thoughts as to why this may be happening only for certain pages? I have tried inserting the link both from SharePoint and copying and pasting it as an address. 



8 Replies
What browser are you using when editing the page, and have you tried a different browser?

@Amanda_Carpenter I'm actually having this problem. It looks like it's been more than a year since you posted. Did you solve this issue?

@cwills if I remember correctly I was using my Mac, and I ended up using an Incognito Chrome Browser and it worked properly, when I use just a regular Chrome browser on the Mac it didn't work. Are you on a Mac or PC?

@Amanda_Carpenter I'm actually on a PC using Chrome but I should have thought of using a different browser. Unfortunately, now that I've tried several I've removed that theory (FF, Edge, Chrome incognito and as a last resort, IE). I think it's something to with the way the link is formed and I just haven't stumbled on how to resolve that or what part of the link is bad.

I guess I needed a night to think on it and come back and feel... "dumb".

Someone (hopefully not me) cut and pasted the title for the webpage into SharePoint. When this happened, it carried with it a zero width space character (%E2%80%8B), it's a common occurrence on Macs for other reasons. I noted it last night when I was again trying to link up this page to the main page. I thought it was just "something" SharePoint was doing but with @Amanda_Carpenter's post of a Mac having problems, something clicked. I "renamed" the page by deleting the end of the title and then typing in the characters. Now all is right with the world.

If a future someone has this problem, I suggest getting the link for the page that keeps disappearing, paste it into Note Pad and check for this character set. If it exists, it's possible this is what you're banging your head against.
I'm facing a similar issue on an excel file open in Teams (with sharepoint online). The link disappear on click for my users. Did you found any way to solve your problem?

@duCygne I looked at the URL and discovered special characters in it (%E2%80%8B). These special characters showed up because I had copied and pasted titles/headers from word. I'm not sure if the same would happen for the name of an Excel file (or links within) but you could edit the link and see if the same special character set is in place. If it is, you may need to rename the header/section/title to remove the special characters.

Thanks for your answer, I equally found the source of my issue, users were trying to click on link before the file was totally loaded on Teams.