Disable SharePoint List Attachments - Form still showing 'Add attachments' field.

Copper Contributor



I have a modern SharePoint Online list in which I have disabled attachments using the List Settings > Advanced Settings > Attachments = Disabled.  When creating new list items, the form that appears still shows add attachments and it will still allow you to add and then give an error. When you edit and item, no field for adding an attachment to the list item shows.  



When I go back into the advanced list settings, the attachments setting is still disabled but there is a tick in the box 'Add attachments column to default view'.  I have tried unchecking this option, but when I save and go back to this page, the box is still checked.



Help, how can I hide the attachments option from even showing on the form?



19 Replies
Hmm...I'm not sure why the modern UI would still show attachments if advanced settings have been configured to disable them...sounds like a setting that is a leftover from classic lists isn't being respected in modern lists for some reason.

If you want more control over what fields are being displayed, a simple approach would be to customise the form using PowerApps, then you can choose which fields are displayed and explicitly exclude the Attachments field from the form.

You would need to disable Edit in Grid View and Properties Pane from the list advanced settings to make sure that the user always followed the path of editing in the customised form. This approach also gives a lot more flexibility on how you visually present the fields, including being able to group them and create section headings etc.

So in summary, if I was presented with the challenge of disabling attachments, that is probably the approach I would look at first

Thanks @Ben Leach. I know that is an option for a work around, but there are multiple lists similar to this one and trying not to go change all of them. It definitely shouldn't still be showing.

I am experiencing the same issue for several of my SharePoint lists. Is there a possibility that is a temporary bug on Microsoft end? Hopefully we can find a fix soon!

Hey, I'm experiencing the same issue, I cannot use the build an app work-around. Lets hope Microsoft fixes this issue quickly. 


I'm also seeing the same issue, discovered it today.

@Samaki40 @AngelaJ1s I am seeing the exact same behavior in few of my SharePoint tenants from last few days.

@Ben Leach This was working as expected in the past for modern experience as well and customizing the forms for every list in a site using Power Apps is not a proper solution.


@Vesa Juvonen @Mark Kashman Is Microsoft SharePoint team aware of this issue?

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.


I'm also having the same issue. Just saw it today.  It's not happening on all lists, but on a couple that I've seen.  Setting has been set to Disabled for a long time.  Tried enabling and disabling, but the field remains.

I am having the same issue !
Have you find a solution for this already ?

Only a PowerApps work around, have not heard anything on the issue being fixed.
I am also seeing this. Disabling attachments in advanced settings was working fine for the past year, but over the past couple of weeks the lists are no longer hiding the attachments field on the New Item form. I wonder if this has something to do with the new Offline Sync feature. Please fix this ASAP.
I'm also seeing this issue on my forms that used to be okay. Not sure when it started, but I just noticed it today. Please fix it! I don't want to make a bunch of custom forms - I just want it to work the way it used to and honor the disabled attachments setting.
Same Issue. I hope it is fixed soon
Today I've noticed the same issue for our lists :(
I have the same problem on one tenant (another one works fine)...

for now I solved by hiding the attachments with powershell:
$list = Get-PnPList -Identity [listName]
$field = Get-PnPField -List $list -Identity "Attachments"
$field.Hidden = $true
On my end problem seems to be resolved now. Yay! :)
best response confirmed by AngelaJ1s (Copper Contributor)
Thanks, I checked mine and once I unchecked the "Add attachments column to default view" in advanced settings, it removed it from my form!



The attachment option when editing or creating a list item is no longer showing for me when it is disabled in the List's Advanced Settings. I guess Microsoft must have fixed it??

1 best response

Accepted Solutions
best response confirmed by AngelaJ1s (Copper Contributor)
Thanks, I checked mine and once I unchecked the "Add attachments column to default view" in advanced settings, it removed it from my form!

View solution in original post