Deleted files/folders reappear as they are synced back online from client OneDrive

Steel Contributor

We are heading towards the end of a big push to get all files in OneDrive or SharePoint.  The Finance department (VIPs) are getting very frustrated with deleted files/folders reappearing as they are synced back online from other user's sycned client OneDrives (the name of the user and date/time are listed with the file online).  PLEASE HELP.  I am also opening a ticket.


This is what we have tried:

  1. Make sure all sync clients are up to date
  2. Try renaming the folder/file and then deleting it from online SharePoint
    1. This did not work at all.  Both the original and the renamed files/folders reappeared
  3. Checked SharePoint permissions.  There are some unique permissions on a few documents but in general the members have edit permissions.


55 Replies
BTW - also note that I user Dropbox and Google Drive as well. This problem has NEVER occurred with those two cloud systems - I can only assume because their synchronisation algorithms are better. They must keep a much more robust history of deletions so that when you logon to an old computer, it knows that that "Monthly" folder was deleted afterwards and deletes (correctly) the copy on the old computer. It doesn't bring it back from the dead!

I assume that Dropbox and Google Drive maintain some separate tracking system of updates so there is a record that says:

1. 4th Jun 2018 10:20 "Monthly" folder created on computer 1
2. 1st Jul 2018 old computer 1 is logged off
3. 13th Sep 2018 "Monthly" folder deleted on computer 2
4. 12th Dec 2018 00:30, user logs back onto computer 1
5. Ahh ha, "Monthly" folder exists here with timestamp 4th Jun but was deleted 13th Sep, it needs deleting from old computer 1 - NOT RESTORING BACK TO ONEDRIVE

Hi @Rob Nicholson - Can you explain a bit more on the root cause ? I was only temporarily able to solve this issue. 

Hi Arvi10 - my reply above showing guessing how Dropbox or Google Drive handles deletions may give a hint of the root cause but I can confirm without a shadow of a doubt that the following happens on OneDrive:

1. Logon to a computer where you had OneDrive synchronised but haven't logged onto for a while - say a few months
2. OneDrive will restore deleted folders and files back to the last time you logged on

Fortunately, thank goodness, it doesn't overwrite edited versions or delete anything. You do get the horrible "My file - LAPTOP046.ps1" cropping up where I assume it thinks it's got the latest version (it never has!) but there is a file there with a newer timestamp so it renames its (old) copy with the suffix and restores that. The creation of these files is usually my trigger to go into OneDrive and restore it back in time - a feature designed to Wannacry attacks but used because of this bug.

I suspect, but a lot of guessing, that this is because OneDrive doesn't keep a transaction log kind of structure along side the actual folders and files. Therefore when you logon to an old computer, it has no idea that "Monthly" was deleted on another system many days later and merrily brings it back.

Hence my observation that this is a fundamental flaw in the synchronisation algorithm used by OneDrive which Dropbox and Google Drive don't suffer from. They have a transaction log which they can refer to resolve issues like this.

So the Microsoft programmers need to go back to the drawing board IMO... wearing my developer hat. I am flabbergasted that OneDrive has this fundamental flaw and they intend you to use it for business! Thank goodness that my clients only tend to logon to one computer at once!

PS. The magically re-appearing folders just now when I tried to delete those incorrectly restored folders was due to some flaw in OneDrive on my PC and access permissions. Why it got into that state (access denied), I have no idea. But OneDrive has other flaws. For example, if you share out a folder to another user with read-only access (which I do with a set of PowerShell scripts), there have been examples whereby the sync engine thinks it's got a later version of the file and incorrectly creates a "New-User - LAPTOP034.ps1" version in the read-only folder. The problem is that because the folder is shared read-only, it is unable to upload it (too right) but then gets a red cross. And WORSE - because the file has been created in a read-only share, the permissions on that folder are set to DENY and are very difficult to get rid of. Fortunately, 7-ZIP manager when run in admin mode is very good at deleting stuff with bad security settings.

So this bug goes something like this:


OneDrive thinks, for reasons unknown, that it has a locally modified copy of a file in a read-only share. Obviously this can't happen as the folder is read-only with deny access! I suspect it happens when a file is changed rapidly on the host OneDrive - as can happen if you're editing a PowerShell script and hitting Ctrl-S often - and OneDrive gets confused over timestamps, thinking it's got a different copy

OneDrive then renames its local copy as XYZ - LAPTOPNNN.ps1 but this then fails to synchronise as it's read-only


So two bugs here: the first one that triggers the creation of a sync copy IN A READ-ONLY share (can never happen so should be trapped). The second is creating the XYZ - LAPTOPnnn.ps1 file which then fails to synchronise. And maybe a 3rd in that you are then unable to delete the accidental copy because it's created with DENY accesss

Ho hum!
It should be easy to fix as the logic would go like this:

For reasons unknown, OneDrive thinks it needs to create a "My doc - LAPTOPnnn.docx" kind of file due to some kind of version clash
Am I trying to create this in read-only share?
Goodness, I can't do that - forget the duplicate then

Same here in the Free version of onedrive.  This is the first issue I encountered and I resolve it by taking all clients offline, then remove the file/folder from every computer (including the copy on onedrive).  Stupid but it works.


It appears some file has been opened by a computer, therefore it reappears.  I think a "OneDrive reset" on each computer would work?

The problem is more annoying for me: if I go to Onedrive on the web, I delete a file, then Onedrive client on Windows 10 re uploads the file that's just been deleted. And this sync back to all my other devices. So the file remains on the cloud and on each device.

This is happening to a client of ours, have you been able to resolve the issue or did Microsoft shed any light? @David Saber 

@futureproofingit tech support had me completely uninstall then reinstall onedrive and now it works.

Can the reason be this?

  • 10 Persons has synked the files to their desktop. 
  • 8 person are on the net when the files are beeing deleted
  • then  2 persons are logging on to the network and then their local files are beeing uploaded to onedrive/teams/sharepoint? (the files and folders that have already beeing deleted?
  • Then it is beeing distributed to all the other users?


I am here because of the same issue, not sure I can add myself in as I have not seen any replies.


I might have failed to get basic concept of how Onedrive works but same here I am getting deleted files and folder from the app on windows 10 not even been deleted on the portal.


I have created an account to specifically share files within the organization, I believe this is a E1 or E1 Business License.

I am so far testing with a couple of users as a proof of concept to eventually deploy within a small org so they can have a central storage to access, upload and modify and files they need to work on.


When I for example delete some files from one of the test laptop all with the latest version of Onedrive, these files are still present on the main account on the web which is where these are shared from. Is this normal practice and expected behavior? As if this is the way it works, I cannot even consider it anymore other than having to look to some more reliable solution elsewhere.

Please let me know


@Massi . 

Is this normal practice and expected behavior? NO

OneDrive should be syncing so deleted files should delete from everywhere they are synced to.

  • Make sure Windows and OneDrive are up to date
  • Make sure you have a good Internet connection.  Did you delete something really large?  Maybe it is just taking a while to sync
  • Did you refresh the browser?
  • Check the machine that you used to delete from.  Are there sync errors? You would see them by clicking on the OneDrive cloud icon in the task bar.

Hi @ChristineStack 

Thanks for your reply, the problem is not really the web but on the desktop app in windows 10, I have also tried to update it to the latest version but the problem is still there.

On the I can see the folders when I select the "shared with me" but on the deskop app it does not work, I can see no errors in the application, it says "You're all set All files are in Sync" is there another option? It's strange because one of the shared folders of this other user are there but not the last one added. This however is available on the web app when selecting files shared with me.


Basically, I am unable to find an option to see the files that other users shared with me.

I do see these on the Web App of OneDrive but not in the OneDrive Explorer Folder in Windows 10.

On my mobile app signed with the same account I can also see the missing folders so, there's either something I don't know how to configure or something not working. Just reinstalled OneDrive from scratch by the way.

Files that other users shared with you are not supposed to sync with the desktop app. 

If you want a single Onedrive storage for your organisation you should create a Microsoft account for everyone.

This problem is completely different than the one discussed in the thread.




So here we are years later and this is still happening. For example, I have a onedrive personal folder open on the desktop (windows 10-1909) in one window and the company onedrive open in another. If I cut a picture from the personal onedrive folder and paste it into the other, it appears to work as expected, but several seconds (the time depends on the size of the file) later, it reappears in the personal onedrive folder. If I repeat the exact same procedure, and click to overwrite the files that are now in the target folder, the files will stay deleted from the source.  I have several windows 10-1909 clients as well as an iphone all syncing my personal folder. I was organizing files for a couple of hours and it did not start happening until hour two. I am guessing this is some kind of rudimentary problem but the specifics of how to recreate it escape me. Perhaps its time related or perhaps it occurs when the files are enumerated and thumbs created? The sync engine decides if a file is the same somehow, right? perhaps if the time and date is rounded to the nearest minute first it would help? or maybe a hash should be created or a semaphore?


If you are still around, did you ever get MS help or find out how to work around the problem?

Same issue here, very annoying. The library in question uses Document Sets, not sure if that has anything to do with it. I'm going to open a support ticket and go through the hell that is Office 365 support. If I get any resolution I'll post back (I'm not very hopeful here).

@Pawel Kowalski 

I encountered this problem in the last week or so. I was using the WordPress UpdraftPlus plugin to backup my website and selected OneDrive as the backup site. Then due to the small free space allocation for OneDrive I decided to use Google Drive instead. Naturally I wanted to delete the portions of the backup that were put in OneDrive. However, after deletion they got mysteriously replaced. While fumbling around, at one point I got the error code 0x80004005. Don't know what to do about that, since that error seems to be about the WordPress SQL over which I have no control.


Any ideas?



I've solved my problem. The WordPress UpdraftPlus plugin was still listed as an authorized user of my OneDrive folder. This authorization was granted when I designated OneDrive as a backup storage site. Apparently, Updraft didn't (or couldn't?) remove the authorization when I deselected it as a backup site. I'm sorry to say I don't remember the details of how I removed it, but I found the procedure online at a Microsoft site. That was  done yesterday, and the unwanted backup files and the OneDrive subfolder they were in were gone!:smiling_face_with_smiling_eyes:

On June 2021, it is still happening on my Windows 10.  I am having the latest client.  What else should I check to resolve the problem?