Deactivating limited-access lockdown mode still no access to a shared document set/folder

New Contributor



My organisation has an interesting issue. We have multiple (classic) site collections with subsites and libraries which align with the business structure. Sites and libraries (particularly for confidential areas) are locked down to particular users, rather than inheriting permissions from the site collection or subsite where the libraries live. We disallow external sharing, but we want users to be able to share document sets, folders and documents internally, where they might be working in cross-functional teams.


And this works fine for the most part. We found that document set and folder sharing was hampered by the site collection feature "limited access lockdown mode", so we have deactivated that across the board. 


However we have a site collection (for our HR function) where a user A needed to share a document set with a user B in a different department. The user B keeps getting access denied messages when clicking the link to the folder.


I have checked that:

- the site collection feature "limited-access lockdown mode" is deactivated

- there is a limited access link that *should* work for user B under "Manage Access"

- we have even subverted the sharing link and added a SharePoint group with User B as a member, specifically to give her access to the document set. 


I cant stress enough that we cant give her access to the full subsite, or the library in question as the information is confidential.


This works across all of our other site collections and sites - is there anything else other than the deactivation of limited access lockdown mode that we need to consider in order to make sharing folders and document sets work? 



1 Reply
best response confirmed by anewhamlet (New Contributor)



Nothing to do with limited access permissions as such. It was something to do with "a mismatched passport  unique id" or something like that... 


It seems that the user in question had changed from a contractor to a permanent staff member, and our service desk created a new user id somehow? 


To fix it, had to remove her from the "all people" group and then readd her.


Shared the links to her again and they worked perfectly.


Never would have guessed that - Had it saved as a known issue solution from 2017...