CopyTo failing between Office 365 groups


I was building a demo to show a client how the CopyTo functionality would work between site collections to prove that basic metadata such as Modified Date etc is maintained when I hit a bug.


Using 2 new site collections created using the Team Site option from the new (can we still call it new?) SharePoint landing page. Both sites were basic Group sites with nothing added. I uploaded a few files into the document library of the first and then used the CopyTo functionality to try and copy the files to the new destination site collection.


Absolutely nothing happened.. I tried the same files to a different site collection and it was fine. Back to the original destination site.. no luck. I then tried with Fiddler running and I'm seeing a 404 not found when it executes the call to




But if I cut and paste that URL from Fiddler and open it in the browser, I get the expected JSON data response.


I created another site from the same Create Site location and I have the same problem 404 not found when trying to get the target document library. If you create a folder in the target location and then try to target the folder in the copy to pane, you receive the error "Sorry, we couldn't get the list of folders."



Older groups are working fine and I'm testing now with groups created from the Teams interface.

8 Replies
Failing for Team Sites created from the Teams interface too.

Checking the fiddler requests, I can't see any difference between a working and a failing request other than the endpoint is a different site collection (And the working site collection was created previous to this testing.)



POST'https%3A%2F%2Fxxxxxxxxxxxxx%2Esharepoint%2Ecom%2Fsites%2FNewTeam4Copy%2FShared%20Documents'&View=&RootFolder=%2Fsites%2FNewTeam4Copy%2FShared%20Documents%2FGeneral&SortField=LinkFilename&SortDir=Asc&FilterField1=FSObjType&FilterValue1=1 HTTP/1.1Origin: https://xxxxxxxxxxxxx.sharepoint.comReferer:

POST'https%3A%2F%2Fxxxxxxxxxxxxx%2Esharepoint%2Ecom%2Fsites%2FPublicGroupForTeams%2FShared%20Documents'&View=&RootFolder=%2Fsites%2FPublicGroupForTeams%2FShared%20Documents&SortField=LinkFilename&SortDir=Asc&FilterField1=FSObjType&FilterValue1=1 HTTP/1.1Origin: https://xxxxxxxxxxxxx.sharepoint.comReferer:

I have just tested it with a Group site copying a file to a Teams site and it worked as expected

Pre-existing groups or newly created ones? My pre-existing groups are fine.

Destination site is quite new (created last week)

Possibly something that's been rolled out this week then. I've just tested on a completely different tenant with two newly created groups and have the same 404 in Fiddler. Copying from one of the new sites to an existing group works fine.



I've just tested using the groups I created on Thursday and it's still failing to retrieve folders and failing to copy files. Looks like a bug in newly deployed groups.


@Chris McNulty Can you flag this to someone in the relevant team to check? I'm seeing this in 3 first release tenants now. I haven't tested it non first release yet.

Just checked today and it's still failing to the groups that it was failing on before and also failing on groups created today. Interestingly it doesn't fail to sub-sites created under these groups.


@Anne Michels I know you're on Teams now, but this affects them too. Any chance of tagging a relevant person to get some focus on this. I could raise a support ticket but it's affecting multiple tenants from my testing.