Content Type template as a doTx or doCx?

Iron Contributor



I try to setup a content type with a custom template, e.g. a report document.


When I setup advanced settings of the Content Type to use a Word Template (report.doTx) it will accept. But when I try to create a document in the library based on this content type, it will open in Word Online with this error: The document you are trying to open is a template. Would you like to open and edit as a standard document? The same error will occur with the default template.dotx in a library, so it's not my template that has a problem.


When I use a normal document (report.doCx) instead, it will not give me this error. But this seems counterintuitive. The system is asking for a template, but I supply a document? When setting the library to open the Desktop App, there will be no error.


So? What is the expected file type to supply to the template of a Content Type?

3 Replies
Hi Michiel,
I'm hitting the same problem whenever I apply a PnP template.
Did you find a way to overcome this behavior ?
Apparantly you have to choose a word document (doCx) as a template for a custom content type.
(As a friend, who manages SharePoint longer then I do, pointed out has always been the case and doesn't everyone know? :thinking_face:. No, I didn't and it doesn't make sense...)
Thank you, nowhere else have I found this resolution. It was incredibly frustrating but your suggestion finally fixed it for me. Three cheers!!!