Content Type in Details Panel of SharePoint‎

Brass Contributor
It appears that in the last few weeks the abiltiy to change the Content Type of documents in Sharepoint has been removed from the modern Details Panel. 
I am able to switch to classic view and change the Content Type but the ability change is no longer available in the modern view.
Anyone see any mention of this change or have a work around? 
20 Replies
It seems there is an update in the document information panel that has been the cause of not having the Content Type Selecctor in your case. I have just tested that I can see the Content Type selector, so not sure what could be the problem you have here

@Marcus_RowellI have the same problem. 2x tenancies I've checked so far. The new details pane now shows an icon that corresponds to the column type, there's a button to edit the list of columns in the form and Content Type is gone. Also with the Edit all form, it's gone too.


I've noticed for some time that when you click Show/hide columns in the header of a modern library, Content Type is not available as a choice, you have to use the classic Edit view to show it. Now it seems they've extended that to the choice of columns in the details pane.


This is immensely frustrating. I have customers asking me about it and there seems not to be a way to edit the content type of a file in a modern library any more without convoluted workarounds like Power Automate.

Annotation 2020-04-20 092525.png

I've made a workaround by customising the edit form with PowerApps. You still need an extra click to Edit all, and it's a bit of work I didn't really have time for, but at least there's something we can do about it.

Great idea @williampage Good to know that works as a temporary workaround. 


Others are reporting the issue now as well on twitter. 


I also have a support ticket open with MS Support. 

@Juan Carlos González Martín Just confirming you can see the Content Type in the details panel? (sorry it is not clear from your reply). 

@Marcus_Rowell  The library I customised the edit form for now has the Content Type reappear in the details pane, but the other sites (in another tenancy) do not yet have that. I wonder if the process of doing that changed something.

The form was already customised in Power Apps but it didn't have the Content Type data card on the form, so I added that then tested it by changing a file's content type. In the past I have tried editing/viewing content type in PowerApps but it never worked. It does now, so something big has changed on the back-end.

I made successfully made a Power Apps form with the Content Type added, but removing the form doesn't restore the Content Type field.

I had never used Power Apps in this test Tenant.

My Tenants are on targeted release.

@Marcus_Rowell , Same issue here. I've checked 2 tenants on different geo locations (US, Canada).

No content type in the info panel if library support multiple content types.


Probably not much QA testing was done before deploying. I'm really not impressed of QA testing with features deployment in SharePoint online... 

That's correct
best response confirmed by Marcus_Rowell (Brass Contributor)

We are currently investigating this behavior

This should be solved by now.

@Bruno Aleixo Thank you so much for the fast fix. I can confirm the issue is now resolved on all my tenants. 

No idea how you rolled that out to all of production in 6 hours. You surely deserve some kind of super hero of the day award. 

@Bruno Aleixo  I can confirm that the Content Type drop down is back (Australia East). However, I have reports from end users (with Contribute rights) that when they change the content type it's not saving. I need confirm this but I thought I'd mention that here.

@williampage Thanks. I´ve tested and i couldn´t reproduce that second behavior. If you are able to reproduce after validating please let us know.

@Bruno Aleixo  I have a video that exhibits the behaviour but it's not OK to publish publicly because it shows some private customer information. I have confirmed and can replicate the problem myself: In a library with content types enabled and document sets in use, within different document sets various content types can't be selected (technically they can, it saves then quickly changes back to the previous value with no error message).

Not all content types are affected, some will save, some will revert, and in different doc sets of the same type within the same library, different content types are affected. However, within a single doc set, all files will revert when changing to the same set of seemingly random content types.

It's really bizarre, and it only started happening at the time of this update.


@williampage in theory the fix should not had a influence on the behavior you describ on docset given it was a visual issue. My recommendation is to raise a support ticket for that issue so we can further investigate that scenario. 



@Bruno Aleixo 


Content Type is appearing for me but Document ID is missing from the details pane as is only showing in the view. I have checked multiple tenants and found they all have the exact issue.

Doc ID in View.JPG

Missing Document ID in Details.JPG


@Daniel1590  Please raise a support ticket 

HI @Bruno Aleixo, is there any out of the box way we can hide this content type selector. We don't want the users to modify the content type nor the Document ID (you are able to change the Document ID (link to a document) if you choose documents in a bulk) using the details pane. Thanks!

1 best response

Accepted Solutions
best response confirmed by Marcus_Rowell (Brass Contributor)

We are currently investigating this behavior

View solution in original post