content type hub url - SPO admin but "waiting for access permission"

Occasional Contributor

Hi there I became a SPO admin in my organization three days ago, and whenever try to access our URL I get a "you need permission to access this site" and, under, a "waiting for approval" since 12 days.


In SPO Admin Center I checked the active sites' list to find some "contentTypeHub" therein but there's not, neither is in the deleted sites' list as well.


This has impacted me as I set a site as a hub and created some content types but am not able to publish them: whenever I go to a content type I've created (where its columns are defined) and click in the link "Manage content type publishing", comes a 403 Forbidden page.


Where such kind of "approval requests" can be found and verified to allow the access? TIA


Btw I've also checked in our classic SPO admin center and both options about custom scripts are turned on. And since I cannot access the contentTypeHub site, I cannot provide a screenshot of the permission on that site neither its access access permission requests (IF that site still exists, since is not in the active sites' list as I've mentioned)



6 Replies

Hi @mescwbif,


Can you publish content types on Content type gallery on SharePoint admin center?



@Matti Paukkonen nope, it doesn't show any in the list and if a click the + to create it gets stuck in the "waiting" circle as in the ig I've attached here

@mescwbif Hello,

Please try the filter option when you look through sites on SharePoint Admin Center.
Classic sites are not shown by default, you will need to activate that filter.

Yours sincerely,
Aref Halmstrand

@ArefHalmstrand thanks I had already tried that to see if the contentTypeHub site would show up in classic sites' list in SPO classic admin center... and no, it's not listed there, as much as isn't in modern admin center site' lists, even in the deleted sites' list - picure attached.


seems that it's just evaporated


moreover, today so to make a test I tried to manually create a site called contentTypeHub and after I confirm the default address (same as site name) SPO gets stuck forever in the "verifying":



@mescwbif Try solving it with PowerShell,

Add-SPOUser -Site https://<tenant> -LoginName <youradminaccount> -Group "<owners>" 

NOTE! AFAIK the site is based on classic sites so it can be wise to check the permissions group that exists by default on a classic site. Probably something like: "contenttypehub owner".

Yours sincerely,
Aref Halmstrand



Update: any PS get or set stuff I try on contenttypehub site collection returns "server exception", "not supported", for instance:

Set-SPOsite -DenyAddAndCustomizePages 0
Set-SPOsite : The requested operation is not supported for site:
In line:1 character:1
+ Set-SPOsite -De ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Set-SPOSite], ServerException
+ FullyQualifiedErrorId : Microsoft.SharePoint.Client.ServerException,Microsoft.Online.SharePoint.PowerShell.SetSite


regarding add-spouser, I make no idea what the group name would be since it would carry in the contenttypehub site collection title and I don't know how such title would be (I tried to google it to no avail)