Content type hub site: Rename of content types won't work, deletion doesn't seem to work either

%3CLINGO-SUB%20id%3D%22lingo-sub-1040014%22%20slang%3D%22en-US%22%3EContent%20type%20hub%20site%3A%20Rename%20of%20content%20types%20won't%20work%2C%20deletion%20doesn't%20seem%20to%20work%20either%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1040014%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20I%20decided%20to%20go%20to%20the%20default%26nbsp%3B%2Fsites%2Fcontenttypehub%2F%20site%20and%20I%20created%20two%20content%20types%20a%20while%20ago.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EA%20few%20months%20ago%2C%20I%20deleted%20one%20of%20those%20content%20types.%20Today%2C%20I%20decided%20to%20rename%20one%20of%20them.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20my%20surprise%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3EThe%20content%20type%20I%20deleted%20is%20still%20lurking%20around%20all%20of%20my%20sites%2C%20including%20newly%20created%20sites%20that%20I%20created%20after%20I%20deleted%20the%20content%20type%20from%20the%20hub%20site.%3C%2FLI%3E%3CLI%3EThe%20content%20type%20I%20renamed%20has%20been%20renamed%20at%20the%20hub%20site%2C%20but%20changes%20haven't%20been%20replicated%20to%20the%20other%20sites.%3C%2FLI%3E%3C%2FUL%3E%3CP%3EOf%20course%2C%20I%20always%20publish%20the%20changes%20and%20push%20them%20from%20the%20hub%20site.%20This%20is%20how%20I%20got%20them%20pushed%20from%20the%20hub%20site%20to%20all%20other%20sites%20the%20first%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20idea%20what%20is%20going%20on%20here%2C%20though.%20Any%20thoughts%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EEDIT%3A%3C%2FSTRONG%3E%20I%20find%20out%20that%20the%20issue%20with%20the%20deleted%20content%20type%20coming%20back%20is%20that%20it%20was%20deleted%20before%20being%20unpublished.%20Well%2C%20seems%20like%20the%20SharePoint%20dev%20team%20should%20be%20taking%20%3CA%20href%3D%22https%3A%2F%2Fwww.edx.org%2Fcourse%2Fcs50s-introduction-to-computer-science%22%20target%3D%22_self%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3ECS50%3C%2FA%3E%20from%20Harvard%20and%20learn%20how%20to%20code.%20When%20deleting%2C%20IF%20published%2C%20unpublish%20first%2C%20then%20delete.%20%F0%9F%A4%A6%E2%80%8D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1040014%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EContent%20Type%20Hub%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Econtent%20type%20publishing%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Contributor

So I decided to go to the default /sites/contenttypehub/ site and I created two content types a while ago.

 

A few months ago, I deleted one of those content types. Today, I decided to rename one of them.

 

To my surprise:

 

  • The content type I deleted is still lurking around all of my sites, including newly created sites that I created after I deleted the content type from the hub site.
  • The content type I renamed has been renamed at the hub site, but changes haven't been replicated to the other sites.

Of course, I always publish the changes and push them from the hub site. This is how I got them pushed from the hub site to all other sites the first time.

 

No idea what is going on here, though. Any thoughts?

 

EDIT: I find out that the issue with the deleted content type coming back is that it was deleted before being unpublished. Well, seems like the SharePoint dev team should be taking CS50 from Harvard and learn how to code. When deleting, IF published, unpublish first, then delete. 🤦‍

0 Replies