Connect-pnponline : The remote server returned an error: (500) Internal Server Error.

%3CLINGO-SUB%20id%3D%22lingo-sub-225805%22%20slang%3D%22en-US%22%3EConnect-pnponline%20%3A%20The%20remote%20server%20returned%20an%20error%3A%20(500)%20Internal%20Server%20Error.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-225805%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20running%20Connect-pnponline%20against%20GCC%20tenant%2C%20I%20am%20receiving%20500%20internal%20server%20error.%3C%2FP%3E%3CP%3ESame%20command%20works%20fine%20for%20regular%20commercial%20tenant.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EConnect-pnponline%20-url%20%22%3CA%20href%3D%22https%3A%2F%2Fcontoso-admin.sharepoint.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcontoso-admin.sharepoint.com%3C%2FA%3E%22%3C%2FP%3E%3CP%3EI%20have%20tried%20with%20SharePoint%20Admin%20and%20Global%20Admin%20credentials%20but%20still%20get%20same%20error.%3C%2FP%3E%3CP%3EPlease%20let%20me%20know%20if%20you%20have%20any%20suggestions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3ERahul%20Babar%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-225805%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-251013%22%20slang%3D%22en-US%22%3ERe%3A%20Connect-pnponline%20%3A%20The%20remote%20server%20returned%20an%20error%3A%20(500)%20Internal%20Server%20Error.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-251013%22%20slang%3D%22en-US%22%3E%3CP%3EAre%20you%20behind%20a%20proxy%3F%20We%20get%20this%20issue%20when%20connecting%20to%20on-prem%20sites%20when%20the%20proxy%20is%20causing%20issues.%20I%20just%20need%20to%20change%20the%20proxy%20settings%20in%20IE%2C%20in%20internet%20options%2C%20connections%20tab%2C%20LAN%20settings%20then%20set%20the%20proxy%20server.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

 

When running Connect-pnponline against GCC tenant, I am receiving 500 internal server error.

Same command works fine for regular commercial tenant.

 

Connect-pnponline -url "https://contoso-admin.sharepoint.com"

I have tried with SharePoint Admin and Global Admin credentials but still get same error.

Please let me know if you have any suggestions.

 

Thanks,

Rahul Babar

1 Reply

Are you behind a proxy? We get this issue when connecting to on-prem sites when the proxy is causing issues. I just need to change the proxy settings in IE, in internet options, connections tab, LAN settings then set the proxy server.