Comments section and Footer in News articles are not visible

%3CLINGO-SUB%20id%3D%22lingo-sub-2667854%22%20slang%3D%22en-US%22%3EComments%20section%20and%20Footer%20in%20News%20articles%20are%20not%20visible%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2667854%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20facing%20an%20issue%20for%20News%20articles%20where%20it%20doesn't%20render%20Comments%20section%20and%20Footer.%20Following%20are%20the%20details%3A%3C%2FP%3E%3CP%3E%3CSTRONG%3E%3CBR%20%2F%3EIssue%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3ENews%20article%20do%20not%20load%2Frender%20completely.%20Comments%20section%20and%20Footer%20don%E2%80%99t%20show%20up.%20After%20refreshing%20the%20page%2C%20the%20page%20loads%2Frenders%20fine%20i.e.%20Comments%20section%20and%20Footer%20shows%20up%20fine.%3C%2FP%3E%3CP%3E%3CSTRONG%3EEnvironment%3A%3C%2FSTRONG%3E%20SharePoint%20Online.%3C%2FP%3E%3CP%3E%3CSTRONG%3EUser%20role%3A%3C%2FSTRONG%3E%20Any.%3C%2FP%3E%3CP%3E%3CSTRONG%3ESite%3A%3C%2FSTRONG%3E%26nbsp%3BAny%20Communication%20site%20on%20tenant.%3C%2FP%3E%3CP%3E%3CSTRONG%3EBrowsers%3A%3C%2FSTRONG%3E%26nbsp%3BTested%20on%20Chrome%2C%20FireFox%20and%20Edge.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESteps%20to%20reproduce%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CUL%3E%3CLI%3ENavigate%20to%20the%20page%20where%20you%20have%20News%20web%20part%3C%2FLI%3E%3CLI%3EClick%20on%20%E2%80%9C%3CSTRONG%3ESee%20all%3C%2FSTRONG%3E%E2%80%9D%20link%20beside%20the%20News%20web%20part%20(assuming%20you%20have%20enabled%20News%20web%20part%20title%20and%20sufficient%20news%20articles%20are%20available%20for%20this%20link%20to%20show%20up)%3C%2FLI%3E%3CLI%3EClick%20on%20first%20news%20article%E2%80%99s%20title%20to%20navigate%20to%20the%20news%20article%3C%2FLI%3E%3CLI%3ELet%20the%20page%20load%20and%20check%20if%20the%20Comments%20and%2For%20Footer%20are%20visible%3C%2FLI%3E%3CLI%3E%3CFONT%20color%3D%22%23FF0000%22%3EIf%20the%20Comments%20and%2For%20Footer%20%3CU%3Eare%20not%20visible%3C%2FU%3E%2C%20this%20is%20the%20issue.%3C%2FFONT%3E%20It%20would%20show%20blank%20area%20in%20place%20of%20Comments%20section%20and%20Footer.%20With%20such%20state%2C%20most%20of%20the%20times%20the%20images%20on%20the%20news%20page%20don%E2%80%99t%20render%20or%20some%20images%20only%20will%20render.%20Note%20that%20the%20issue%20could%20also%20be%20reproduced%20with%20news%20articles%20having%20only%20text.%20So%2C%20the%20issue%20doesn%E2%80%99t%20seem%20to%20be%20particularly%20related%20to%20news%20posts%20having%20images.%3C%2FLI%3E%3CLI%3EIf%20the%20Comments%20and%2For%20Footer%20%3CU%3Eare%20visible%3C%2FU%3E%2C%20click%20the%20browser%E2%80%99s%20back%20button%20and%20navigate%20to%20check%20any%20other%20news%20article.%3C%2FLI%3E%3CLI%3ERepeat%20above-mentioned%20step%20until%20the%20issue%20is%20reproduced.%3C%2FLI%3E%3CLI%3EFor%20the%20news%20article%20having%20the%20issue%2C%20refresh%20the%20browser%20to%20reload%20the%20news%20article.%20To%20refresh%20the%20page%2C%20you%20can%20click%20Refresh%20icon%20or%20F5%20or%20Ctrl%20%2B%20F5%20or%20press%20Enter%20on%20address%20bar.%20Once%20refresh%20is%20complete%2C%20the%20Comments%20section%20and%20Footer%20would%20start%20showing%20up%20properly.%20Also%2C%20if%20the%20articles%20are%20having%20image%2C%20they%20would%20render%20properly.%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESample%20screenshots%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CEM%3EIssue%20where%20Comments%20section%20and%20Footer%20are%20not%20visible.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22AnwaraliHajwane_2-1629438513687.png%22%20style%3D%22width%3A%20699px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F304585iEA86B66553F82DA4%2Fimage-dimensions%2F699x341%3Fv%3Dv2%22%20width%3D%22699%22%20height%3D%22341%22%20role%3D%22button%22%20title%3D%22AnwaraliHajwane_2-1629438513687.png%22%20alt%3D%22AnwaraliHajwane_2-1629438513687.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EAfter%20page%20refresh%2C%20Comments%20and%20Footer%20are%20visible%20properly.%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22AnwaraliHajwane_3-1629438544110.png%22%20style%3D%22width%3A%20700px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F304586iBFECFEC2018A3DBB%2Fimage-dimensions%2F700x337%3Fv%3Dv2%22%20width%3D%22700%22%20height%3D%22337%22%20role%3D%22button%22%20title%3D%22AnwaraliHajwane_3-1629438544110.png%22%20alt%3D%22AnwaraliHajwane_3-1629438544110.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20help%20resolve%20this%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF6600%22%3E%3CU%3E%3CSTRONG%3ENote%3A%3C%2FSTRONG%3E%3C%2FU%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CSPAN%3EThis%20is%20reproduced%20only%20when%20you%20go%20via%20%22See%20all%22%20link%20beside%20News%20Webpart%20(for%20navigating%20to%20news%20pages).%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3ENote%3A%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3Ea)%20%3CFONT%20color%3D%22%23333333%22%3E%3CFONT%20color%3D%22%23FF6600%22%3EThis%20issue%20is%20reproduced%20in%20multiple%20tenants%3C%2FFONT%3E%20(at%20least%20for%203%20we%20could%20reproduce).%20So%20it%20seems%20it's%20a%20global%20issue%20and%20not%20specific%20to%20a%20site%20or%20a%20tenant.%3C%2FFONT%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3Eb)%20%3CFONT%20color%3D%22%23FF6600%22%3EThis%20issue%20is%20not%20specific%20to%20images%3C%2FFONT%3E%20not%20rendering.%20It%20also%20happens%20for%20news%20posts%20having%20only%20text.%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EYou%20may%20want%20to%20try%20on%20your%20tenant%20with%20some%20sample%20news%20pages%20(around%204%20to%205%20posts)%20and%20try%20to%20reproduce%20the%20issue%20by%20following%20the%20steps%20I%20provided%20earlier.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EAnwar%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2667854%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Senior Member

Hi,

I am facing an issue for News articles where it doesn't render Comments section and Footer. Following are the details:


Issue:

News article do not load/render completely. Comments section and Footer don’t show up. After refreshing the page, the page loads/renders fine i.e. Comments section and Footer shows up fine.

Environment: SharePoint Online.

User role: Any.

Site: Any Communication site on tenant.

Browsers: Tested on Chrome, FireFox and Edge.

 

Steps to reproduce:

  • Navigate to the page where you have News web part
  • Click on “See all” link beside the News web part (assuming you have enabled News web part title and sufficient news articles are available for this link to show up)
  • Click on first news article’s title to navigate to the news article
  • Let the page load and check if the Comments and/or Footer are visible
  • If the Comments and/or Footer are not visible, this is the issue. It would show blank area in place of Comments section and Footer. With such state, most of the times the images on the news page don’t render or some images only will render. Note that the issue could also be reproduced with news articles having only text. So, the issue doesn’t seem to be particularly related to news posts having images.
  • If the Comments and/or Footer are visible, click the browser’s back button and navigate to check any other news article.
  • Repeat above-mentioned step until the issue is reproduced.
  • For the news article having the issue, refresh the browser to reload the news article. To refresh the page, you can click Refresh icon or F5 or Ctrl + F5 or press Enter on address bar. Once refresh is complete, the Comments section and Footer would start showing up properly. Also, if the articles are having image, they would render properly.

 

Sample screenshots:

Issue where Comments section and Footer are not visible.

AnwaraliHajwane_2-1629438513687.png

 

After page refresh, Comments and Footer are visible properly.

AnwaraliHajwane_3-1629438544110.png

 

Please help resolve this issue.

Note:
This is reproduced only when you go via "See all" link beside News Webpart (for navigating to news pages).
Note:
a) This issue is reproduced in multiple tenants (at least for 3 we could reproduce). So it seems it's a global issue and not specific to a site or a tenant.
b) This issue is not specific to images not rendering. It also happens for news posts having only text.

You may want to try on your tenant with some sample news pages (around 4 to 5 posts) and try to reproduce the issue by following the steps I provided earlier.

 

Regards,

Anwar

0 Replies