Column Formatting in List View Web Part

%3CLINGO-SUB%20id%3D%22lingo-sub-227567%22%20slang%3D%22en-US%22%3EColumn%20Formatting%20in%20List%20View%20Web%20Part%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-227567%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20created%20a%20Site%20Page%2C%20where%20I%20added%20a%20List%20View%20Web%20Part%20with%20reference%20to%20a%20list%20which%20has%20JSON-conditional%20formatting%20in%20it.%20For%20myself%20the%20conditional%20formatting%20works%20(doesn't%20exactly%20looks%20the%20same%20but%20hey%2C%20at%20least%20I%20see%20the%20colors.)%2C%20but%20other%20coworkers%20don't%20see%20the%20formatting%20at%20all.%20Those%20coworkers%20have%20the%20same%20(or%20even%20higher)%20permissions%20to%20the%20site%20page%20and%20the%20lists%20themself%2C%20so%20rights%20should%20not%20be%20the%20issue.%3C%2FP%3E%3CP%3EDoes%20this%20feature%20for%20you%20guys%20work%20and%20if%20yes%2C%20whats%20your%20setup%20(rights)%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20my%20coworkers%20go%20to%20the%20list%20them%20self%20they%20see%20the%20formatting.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-227567%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFormatting%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWeb%20Parts%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-240470%22%20slang%3D%22en-US%22%3ERe%3A%20Column%20Formatting%20in%20List%20View%20Web%20Part%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-240470%22%20slang%3D%22en-US%22%3E%3CP%3EThere%20is%20a%20Bug%20Fix%20open%20on%20GitHub%20to%20fix%20this.%20Here%20is%20a%20link%20to%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F15%23issue-282690824%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F15%23issue-282690824%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-227700%22%20slang%3D%22en-US%22%3ERe%3A%20Column%20Formatting%20in%20List%20View%20Web%20Part%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-227700%22%20slang%3D%22en-US%22%3EI%20think%20is%20not%20a%20question%20of%20permissions...the%20modern%20list%20view%20WebPart%20is%20still%20in%20preview%20so%20those%20issues%20can%20happen...indeed%20the%20column%20formatting%20support%20is%20relatively%20new%3C%2FLINGO-BODY%3E
Highlighted
Frequent Visitor

I have created a Site Page, where I added a List View Web Part with reference to a list which has JSON-conditional formatting in it. For myself the conditional formatting works (doesn't exactly looks the same but hey, at least I see the colors.), but other coworkers don't see the formatting at all. Those coworkers have the same (or even higher) permissions to the site page and the lists themself, so rights should not be the issue.

Does this feature for you guys work and if yes, whats your setup (rights) etc.

 

If my coworkers go to the list them self they see the formatting.

2 Replies
Highlighted
I think is not a question of permissions...the modern list view WebPart is still in preview so those issues can happen...indeed the column formatting support is relatively new
Highlighted

There is a Bug Fix open on GitHub to fix this. Here is a link to it.

 

https://github.com/SharePoint/sp-dev-list-formatting/issues/15#issue-282690824