Cannot set SharePoint Home Site using PowerShell

%3CLINGO-SUB%20id%3D%22lingo-sub-1579429%22%20slang%3D%22en-US%22%3ECannot%20set%20SharePoint%20Home%20Site%20using%20PowerShell%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1579429%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Team%2C%3C%2FP%3E%3CP%3EI've%20done%20some%20research%20online%2C%20and%20haven't%20found%20a%20solution%20to%20the%20issue%20I'm%20seeing.%20We%20have%20a%20Targeted%20Release%20tenancy%2C%20and%20wanted%20to%20try%20out%20the%20Home%20Site%20feature%20following%20directions%20from%20Microsoft.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FSharePoint%2Fhome-site%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FSharePoint%2Fhome-site%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20SharePoint%20Online%20Management%20Shell%20already%20installed%2C%20connected%20to%20my%20tenant%2C%20and%20executed%20the%20command%3A%26nbsp%3B%3CSPAN%3ESet-SPOHomeSite%20-HomeSiteUrl%20MYSITEURL%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EUnfortunately%2C%20I%20receive%20the%20following%20error%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ESet-SPOHomeSite%20%3A%20The%20term%20'Set-SPOHomeSite'%20is%20not%20recognized%20as%20the%20name%20of%20a%20cmdlet%2C%20function%2C%20script%20file%2C%20or%20operable%20program.%20Check%20the%20spelling%20of%20the%20name%2C%20or%20if%20a%20path%20was%20included%2C%20verify%20that%20the%20path%20is%20correct%20and%20try%20again.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAny%20ideas%20why%20I%20would%20be%20receiving%20this%20error%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThank%20you%20so%20much%20for%20your%20help!%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EKind%20regards%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAlan%20Bryan%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1579429%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1580281%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20set%20SharePoint%20Home%20Site%20using%20PowerShell%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1580281%22%20slang%3D%22en-US%22%3EAre%20you%20sure%20you%20are%20using%20the%20last%20version%20of%20the%20PowerShell%20Management%20Shell%3F%20If%20you%20try%20any%20other%20SPO%20cmdlet%2C%20does%20it%20work%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1599556%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20set%20SharePoint%20Home%20Site%20using%20PowerShell%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1599556%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20the%20reply.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20uninstalled%20and%20re-installed%20the%20current%20version%20of%20SharePoint%20Online%20Management%20Shell%3A%2016.0.20324.12000.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Alan0618_0-1597861792573.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F213344i2891B105E27CD93F%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Alan0618_0-1597861792573.png%22%20alt%3D%22Alan0618_0-1597861792573.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUnfortunately%2C%20Set-SPOHomeSite%20still%20does%20not%20work.%20I%20tried%20your%20recommendation%20to%20test%20any%20SPO%20cmdlet%2C%20and%20Set-SpoSite%20works%20without%20any%20issues.%20(Please%20see%20below).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20why%20it'd%20be%20doing%20this%3F%20Thanks%20so%20much%20for%20your%20help!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Alan0618_3-1597861988870.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F213347i700D47BE575B13C1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Alan0618_3-1597861988870.png%22%20alt%3D%22Alan0618_3-1597861988870.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi Team,

I've done some research online, and haven't found a solution to the issue I'm seeing. We have a Targeted Release tenancy, and wanted to try out the Home Site feature following directions from Microsoft. 

https://docs.microsoft.com/en-us/SharePoint/home-site

 

I have SharePoint Online Management Shell already installed, connected to my tenant, and executed the command: Set-SPOHomeSite -HomeSiteUrl MYSITEURL

 

Unfortunately, I receive the following error:

Set-SPOHomeSite : The term 'Set-SPOHomeSite' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

 

Any ideas why I would be receiving this error?

 

Thank you so much for your help!

 

Kind regards,

 

Alan Bryan

 

5 Replies
Are you sure you are using the last version of the PowerShell Management Shell? If you try any other SPO cmdlet, does it work?

@Juan Carlos González Martín 

Thank you for the reply. 

I uninstalled and re-installed the current version of SharePoint Online Management Shell: 16.0.20324.12000. 

Alan0618_0-1597861792573.png

 

Unfortunately, Set-SPOHomeSite still does not work. I tried your recommendation to test any SPO cmdlet, and Set-SpoSite works without any issues. (Please see below).

 

Any ideas why it'd be doing this? Thanks so much for your help!

 

Alan0618_3-1597861988870.png

 

Connect SPOService to Admin site URL ; authentication and then run commnad.
Like this: Connect-SPOService -URL https://xxxx-admin.sharepoint.com <Enter> You will then be prompted for a SharePoint Admin or 0365 Global admin Account ID and Password; enter Code. Now type: Set-SPOHomeSite -HomeSiteURL https://(Your Url)

@Alan0618 Try downloading latest version of SharePoint Online Management Shell & then updating SharePoint online PowerShell module using:

 

Update-Module -Name Microsoft.Online.SharePoint.PowerShell

 

Also make sure you are using communication site URL to set it as a home. You can follow below article for detailed steps:

Set up a home site in SharePoint Online 


Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.