Cannot drag web parts




Has anyone else noticed that it is currently not possible to move web parts with drag and drop. I have tested a web part page in Edit mode in multiple tenancies on different devices with IE and Chrome and it just doesn't seem to work. Is this by design or a fault?


Thanks, Laurie

23 Replies
Are you talking about classic or modern SPO sites? In classic SPO pages WebParts moving should just work. In modern SPO pages, it does not work

Drag and drop of web parts works for me in Modern pages.  You have to make sure you grab the "move" icon in the edit panel to the left of the web part (between the edit pencil and the delete trash can).


In classic pages, you need to make sure there is a space to receive the web part.  I usually have to put in a couple of carriage returns where I want to drag a web part to and then remove them after dragging the web part into the spot.




Sorry I should have said I am working with classic sites with a web part page. As you say Juan it should just work but isn't for me. Can anyone please see if it is working for you?

What is the latest on this? One of my customers is reporting the same issue - we can no longer move web parts on SharePoint classic publishing pages in SPO. Any guidance? I am going to ask customer to open a support ticket. 

From what I know it's by design

The WebPart Drag&Drop is not working on the classical pages (Wiki model pages), you can only play with the webpart option to select the WParea to place it and the index to position it (Order like).

Not any other choice as I know



I have opened a support ticket to find out if this is intentional or a bug that is being worked on.  Thanks

best response confirmed by Fabrice Romelard (Regular Contributor)

I've recently faced with this problem. My solution is so;

  1. Open the page in edit mode
  2. Edit the webpart which you want to move
  3. On the webpart properties section (which is on the top right of the page) Expand "Layout" section
  4. On Layout section, there is two option
  5. First one Zone selection. If you want to move the webpart to the different zone, select the desired zone
  6. The second one is Zone Index. Use this if you want to change the order of webpart. For example you have two or more webpart in one zone. So you could change the webpart order

For just another option; you can open the webpart page with SharePoint Designer and edit the page with advanced mode and move the webpart to the desired zone.

Thanks for the workarounds.

Thanks for putting the steps here. 


It's something that we shouldn't have to do though! Why do I get a move crosshairs cursor if it's not going to do anything. 


Microsoft, please fix!

Thanks! This is the only thing that has helped me!

I'm having the same problem and was about to start a conversation about it. Doesn't work in Chrome or Edge, only IE for me. I know that I can change the web part zone and index in the Edit panel, but that takes so, so so so so so much longer. And I don't use IE, so if I want to edit a page and move the web parts around, I need to open it in IE. It's very inconvenient! 

I'm also experiencing this sort of problem, and the zone-related work arounds are not possible.


I'm working with an extensive SharePoint site for a client, using Office 365. 


After moving to 365, i used the Classic view to set up a custom "Default Display Form" in the "Form Web Parts" drop down on the "Customize List" section of the "List" Ribbon.  I currently have nine (9) custom lists displaying as Web Parts, and am trying to add a tenth (10th). 


In this edit mode, there is only one "Zone" ("Main"), so i can't change the zone to rearrange the order.


As others have observed, hovering over the Web Part title changes your cursor to a "move" pointer.  In the past, this has worked for me.  However, today it doesn't work in IE 11, Edge 41, Chrome 69, or Firefox 62 on Windows 10.


Any ideas?

I used to be able to add a content editor to an app - not a page (above a list or a document library) and move the webpart beneath the list or library. In office 365, I can add the content editor above the list or library, but I cannot move it beneath the list or library view anymore. I have tried in Chrome, Edge and Explorer. 

Unfortunately, I can not edit the web part to change the zone index. The zone and index are greyed out. The zone shows an index of 0. I guess i will have to remove web parts from the page and add them in the order that i want them to appear on the page. I tried IE 11, FF 63 ...


I eventually figured out another back door:

1. Edit page

2. Edit source

3. Reorder the web parts <div>...</div>

4. Save page

5. Publish page

Great! Thank you. This had me boggled for an hour, testing with different browser. IE worked occasionally, but very frustrating. This workaround nailed it though.  

I found the cause of the problem... when I created the new page, I did so in a manor that created the page without applying a page layout that had web part zones.


What I should have done was:

1. Login to the site

2. Navigate to the sub site

3. Click the gear and select site contents

4. Navigate to the pages folder

5. Click New and from the sub menu Page

6. Fill out the form for a new page making sure to pick a page layout


Before you create the new page make sure that you have a page layout which contains web part zones. These zones allow the web parts to be rearranged using the web parts layout properties.

@Hasan Köroğlu thanks this worked.

I'm glad this worked for you all. But for me it's never worked and I thought this was a missing feature in SharePoint Online. Maybe it's how we migrated to SP online?


My company had a 2010 on premises site that we migrated to the online cloud using Sharegate. Since all the pages were originally created in 2010, I believe they were created in the cloud as classic pages. They all have layout pages with web parts. I am able to edit webparts and change the index number, but that is such a pain.


As the site is rather large, 100+ pages, is there any way to make this work without recreating all the pages to make sure they are modern pages?