Can't paste mutiple rows into Quick Edit since recent changes

Copper Contributor

Hi all


We are having problems pasting into Quick Edit. It just... doesn't work? If I try to paste more than say 10 rows, the screen whites out with the 'Loading' wheel going and no matter how long we wait, it simply hangs.


This is across two tenants and several users. Anyone got any ideas? It's really getting in the way of things.


I can paste one row at a time, but even that can be patchy, sometimes it only picks up the first one or two fields and then we get the little blue loading wheel in the first cell in the row. 


Whenever either of these things happens, the Exit Quick Edit link is unresponsive and we have to exit all the way out to another page, go back in and try again.


Screen grab:


Loading Hang Snip.PNG




12 Replies

@staregirl I'm experiencing the exact same thing, and it is a major problem for me, too. When I cut and paste rows from Excel into the Quick Edit mode worksheet of a SharePoint list, normally I can do dozens of rows together at a time. As of yesterday, no more than 5 or so rows. I've tried everything to try to coax it back into working - even re-created my list with less fields than desired, and hardly any lookup fields. I sure hope we get some SME attention to this and it gets fixed!


Oh, it's so nice to know we're not alone.

*jumps up and down* Hey! anyone know what's happening? I'm now looking at patching data from PowerApps to SharePoint lists because I can't copy/paste and that's more workaround than I'd like...

@staregirl Sigh, me too. Cant paste any data in. Any ideas?

Tried all the usual suspects, different browsers, new list, simple data etc.


Has a call to Microsoft been logged by any chance?



@staregirl and @Andrew Thornton-Smith - Big news! I submitted a support ticket to Microsoft yesterday. They were unable to replicate the problem in their test env, but had my try the "SharePoint Classic Experience." It took a bit of navigation for me to get the Quick Edit mode worksheet in the SharePoint Classic Experience, but... great news! I was able to copy and paste many rows at a time from Excel to my SharePoint list. Yay! So that is the work-around for now I assume, until it is fixed in the SharePoint modern experience.

@Clodine Ah thats great, I will give that a go tomorrow morning.
Thank you for the info!

@Clodinethat's great, I'll have a go now and hopefully we can stagger on while they look into it. Thanks so much!

I had found that workaround, but not a good option for me.  tried list settings > advanced settings > list experience > classic experience to get closer to a workable option, but doesn't seem to do anything.  has anyone used that? @Clodine 

@D_W-1 No, didn't try that as the basic work-around works well enough for me for now. I just switch over briefly to Classic mode for my "bulk copy-paste" and then go back to modern. Good luck!

@staregirl @Andrew Thornton-Smith @D_W-1 - the fix is on the way; I think my testing helped identify the cause. I'm in a targeted release group for my company, and just tested. I was able to copy-and-paste well over 100 rows from an Excel file into a SharePoint list using Quick Edit Mode in Modern experience. I HAVE NO IDEA THE PUSH/RELEASE SCHEDULE FOR THIS, so the fix may or may not be there for you (and possibly some of my colleagues) for a while. I'd recommend you periodically test, esp. after the next 2-3 SharePoint release updates. Good luck! And bye bye.

This solution of copying from excel to quick edit worked for me, thank you :)

I can only copy 5 or less rows from excel to sharepoint 2019 datasheet without problem.  When I copy 20 rows or more, it replicate twice in the target datasheet.  The browser I use is the latest version of Edge an Chrome.  The turn around is to user the old browser IE11 to do the copy and past.  Not sure what happen?  @Ulhas Morbale 

@staregirl I would also have issues with pasting into the grid view. It would duplicate some of the top records and not complete the full list. I had an ticket open with Microsoft on this - we were able to record it, to show its behavior, but when we turned on the F12 diagnostic window, we could not get it to repeat - so they closed the ticket without resolution. I do find that switching to Classic Sharepoint mode is reliable (and I guess turning on the F12 diagnostic window is a jerry-rig :facepalm:).