Blank fields when editing an existing list element

Copper Contributor

Please, I need someone's help. I have several lists in different sharepoint that worked as expected until a few days ago.


Since then, when I try to edit an existing element in any list (I get the same result regardless I'm just a member or an admin), all the fields appear empty (as you can see in the following image), and if I click save they really update to blank.



Yesterday I ask another member of one of these sharepoint to check if he also gets the same behaviour, but for him it works fine.


Does anyone know what my problem could be?


Thanks in advance.


53 Replies
Hi Marta, I found your first request here. I remember, that if I send a team into archive (which is possible in the Teams Admin Center), my lists and libraries in the Teams SharePoint Base are archived as well. Did somebody archive your Team (private Group) by accident??
Hi Eva. Thanks for answering me.

I don't really understand what you are saying but I have the same problem in a Team where I'm the owner and the only member (is the one that I use to try things before updating the ones with other people), and I haven´t change anything there that I remember
I have just realized one thing, eventhough all the fields seem to be blank when editing, only the ones with date format maintein their value when saving.

I tried creating a new list with 2 columns (number and text) and it worked fine, then I add another column with date format and the same problem appeared.

I really don't understand anything. Is any of this ringing a bell for you?

Thanks again.

best regards, Marta

Hi Marta, pls. check your regional settings, like language and currency settings in your M365 Account.
Here attached 4 you to little films: first to check your permissons level in SharePoint( user15 is a Member, Me=Site Owner) and second film is about your regional settings. That includes keyboard and (!) currency settings. Maybe your Tenant was set only for English settings (reset after update?). Occasionally I have that issue, when I initialize a new Flow with Power Automate and currency Fields, then the flow settings are reset to english. Are you working with Power Automate Flows? That could be a reason.

Please make sure your Account Settings (including the Office Apps!) are in Spanish. If you cannot change these settings, pls. write a ticket to your Teams Admin.

@MartaGM this little tutorial is the stuff about checking your own permission level in a sharepoint site. If it is a standard level "Member" (Mitglied) or "Owner"(Besitzer) you should be able to edit all items in that list. If not, maybe your Owner knows why (this is the user level to control the Members and their access)... ;) 

Try deleting cookies. For me it works

Hi @Eva Vogel !!


We are almost there, but not yet. 


You are completely ritght about using power automate, I use it for creating the elements in those lists. And I also think the problem is in the language, but I can't find where to correct it.


I mean, I asked my colleague to send me a picture of the list he can see on his computer and compare it to mine, and guess what? the dates are different:


Here's what he sees:


and here, what I see:


Mine is a mix between Spanish and English!!


So I checked what you told me, and changed to Spanish the same option you changed to German, but nothing happend :( 


Any idea how to continue?


Thanks in advance for your help.


Regards, Marta


thanks GermanGomez, it was a good idea but it didn't work in this particular case. Somewhere and somehow I have a mix language between Spanish an English, and I think that's the key to solve the problem.
Hi Marta, some power automate ideas for you:
if you are the creator of that List Flow or a Co-Creator / co-Owner, you can add an action to convert field contents, not fields. This goes: a) create a variable with number in it, initalize the variable with your SP Lists Field. then choose a new action called "Number formatting" (Zahlformatierung) and choose the variable to convert the field content into a certain currency.

Or: Maybe the creator of that list did not select you as a User?
If possible it is easier for me to help, as you give me a screenshot of that flow...

@MartaGM the "user-friendly" format in Date/Time Columns can be changed into a user-understandable format. Pls. see my new "greatest hits" Date & Number Formatting blockbuster :) if you want to review the settings on your flows and in happy end you will also see, that "user-friendly" does not correspond in a weird way with that new Date Control. Maybe this is the cause of your column trouble...


Next idea: the regional settings could have something to do with the Tenant Settings. If your company changed the subscribing options, maybe they pay less but now the tenant is located to another country (?)... 


Another idea: If that Version Field in your list only accepts a Number, which deals with "." usually, but the "." is converted to a "," (Comma), it is a clear sign, that your list changed the regional settings for you. I know, this sucks. Pls. try inserting a Version "Number" with Commas instead of Dots. 



Have a good day

Hi again, I'm already desesperated :(
I can't find the error.

I could make the column to display the date just in Spanish (not mix with English) by changing the regional options of my computer, but I see the same whether I choose friendly mode or standard in the list setting. I thought it was supposed to display something different... furthermore, my column is set to date & time format, it force me to add time when I change the value but then it doesn't appear on the list:



Hi again,


I hace confirmed the probelm is my computer (don't know where), because with my user I can edit those lists in my cellphone and in another computer.


By changing regional settings I managed to see the date columns in format date +  time, but I still can't edit.

Any idea?


thanks again.

Hi Martha, if your PC is the problem, you should run a windows 10 update. Maybe this can help. Try this shortcut: WINDOWS Key + X, in this Option Menu click on "settings" - last icon "Update & Security". And pls. check also, if your PC has the latest security update on your Firewall App. And PLEASE: Ask your Admin, tech Admin, whatever Admin on that issue.

Hi. I'm in the same problem. Some of my team members started having that problem, when you enter the list item, the form is empty. Now I have the problem also (I'm the owner and admin rights). If I visualize the list in Sharepoint I don't have that problem. I will continue investigating what it can be. I also have a flow in power automate (to generate an incremental identifier) ​​that may be the cause. I'm also a bit desperate. I'm going to make some changes in the regional settings to test ...




Hi @jsantosmoreno ,


I haven't completely solved the problem (I'm waiting for my tech support to check my computer) but I managed to make the list work in Chrome.


What I did was:

- In my computer selected my regional settings to Spain

- In my microsoft account, I selected my personal settings instead of the ones defined by site admin:


- In chrome I deleted cookies


With those steps the lists work but only with Chrome. I did the same in Edge with no luck, neither on teams.


If I manage to solve the problem I'll put it here.


Good luck.

Hi... It works for me... at least in Chrome. Thanks a lot.
If I find a solution I'll post too.
Glad to help :)

I know how desperate it can be

I posted that it works (on Chorme) but not as I expected ("mi gozo en un pozo" :) ). It only works if the browser doesn't keep cookies, so I have to chech the option "erase cookies and site data after close all windows" in Chrome configuration, otherwise it doesn't work. And when I open another list and open again the previous one the problems show up again....


Anyway it is a solution to keep the tool in use.


Thanks (again) and regards..



You are right, now it doesn't work for me either! I guess I have to delete cookies again :(