Blank and Incorrect Version Control with Power Automate

%3CLINGO-SUB%20id%3D%22lingo-sub-1506263%22%20slang%3D%22en-US%22%3EBlank%20and%20Incorrect%20Version%20Control%20with%20Power%20Automate%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1506263%22%20slang%3D%22en-US%22%3E%3CP%3EI%20created%20a%20basic%20flow%20using%20Power%20Automate%20for%20a%20custom%20SharePoint%20list.%26nbsp%3B%20It%20checks%20a%20few%20fields%20and%20updates%20a%20total%20based%20on%20the%20results.%26nbsp%3B%20It%20is%20set%20to%20run%20when%20an%20item%20is%20created%20or%20modified.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe've%20had%20some%20issues%20with%20fields%20being%20randomly%20updated%20so%20I%20turned%20on%20version%20control%20for%20the%20list.%26nbsp%3B%20The%20fields%20that%20are%20being%20changed%20are%20not%20touched%20by%20the%20Flow.%26nbsp%3B%20I%20also%20turned%20off%20the%20Flow%20for%20the%20time%20being%20so%20I%20could%20troubleshoot.%26nbsp%3B%20I%20can%20confirm%20that%20the%20Flow%20is%20NOT%20running%20and%20hasn't%20for%20at%20least%2024%20hours.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20checked%20version%20control%20on%20the%20affected%20list%20items%20this%20morning%20and%20found%20at%20least%2020%20versions%20had%20been%20created%2C%20with%20all%20but%20two%20blank.%26nbsp%3B%20Every%20single%20version%20update%20shows%20my%20username.%26nbsp%3B%20Obviously%2C%20I%20did%20not%20create%20these%20versions.%26nbsp%3B%20The%20Flow%20I%20built%20did%20not%20run%20so%20it%20didn't%20create%20them.%26nbsp%3B%20I%20can%20even%20confirm%20that%20a%20different%20user%20manually%20updated%20the%20two%20list%20items%20that%20were%20not%20blank.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%26nbsp%3B%20Why%20is%20my%20name%20showing%20up%20for%20every%20change%3F%26nbsp%3B%20I%20realize%20that%20can%20happen%20when%20a%20Flow%20runs%20since%20it's%20running%20under%20my%20name%20but%20there%20was%20no%20Flow%20running.%26nbsp%3B%20The%20two%20manual%20updates%20were%20completed%20by%20another%20user%20using%20the%20standard%20SharePoint%20edit%20form%2C%20yet%20it%20still%20showed%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2.%26nbsp%3B%20What%20is%20causing%20all%20the%20updates%20to%20the%20versions%3F%26nbsp%3B%20Every%20item%20I%20checked%20had%20around%2020%20blank%20versions%20that%20were%20created%20overnight.%26nbsp%3B%20Again%2C%20no%20Flow%20ran.%26nbsp%3B%20Even%20if%20I%20hadn't%20turned%20it%20off%2C%20nothing%20should%20have%20triggered%20since%20most%20list%20items%20I%20reviewed%20were%20not%20new%20or%20recently%20modified.%26nbsp%3B%20I%20did%20notice%20that%20versions%20tended%20to%20be%20in%20pairs%20with%20two%20listed%20at%20the%20exact%20same%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1506263%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPower%20Automate%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Visitor

I created a basic flow using Power Automate for a custom SharePoint list.  It checks a few fields and updates a total based on the results.  It is set to run when an item is created or modified.

 

We've had some issues with fields being randomly updated so I turned on version control for the list.  The fields that are being changed are not touched by the Flow.  I also turned off the Flow for the time being so I could troubleshoot.  I can confirm that the Flow is NOT running and hasn't for at least 24 hours.

I checked version control on the affected list items this morning and found at least 20 versions had been created, with all but two blank.  Every single version update shows my username.  Obviously, I did not create these versions.  The Flow I built did not run so it didn't create them.  I can even confirm that a different user manually updated the two list items that were not blank.  

 

1.  Why is my name showing up for every change?  I realize that can happen when a Flow runs since it's running under my name but there was no Flow running.  The two manual updates were completed by another user using the standard SharePoint edit form, yet it still showed me.

 

2.  What is causing all the updates to the versions?  Every item I checked had around 20 blank versions that were created overnight.  Again, no Flow ran.  Even if I hadn't turned it off, nothing should have triggered since most list items I reviewed were not new or recently modified.  I did notice that versions tended to be in pairs with two listed at the exact same time.

 

Thank you.

0 Replies