Audience Targeting for News not working at Hub Site level

%3CLINGO-SUB%20id%3D%22lingo-sub-1060083%22%20slang%3D%22en-US%22%3EAudience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060083%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20Hub%20site%20and%20are%20pulling%20in%20news%20from%20sites%20associated%20with%20the%20Hub.%26nbsp%3B%20I%20have%20set%20targeted%20audiences%20on%20those%20news%20articles%20and%20have%20tested%20the%20functionality%20on%20the%20sites%20themselves%20-%20the%20audience%20targeting%20seems%20to%20work%20fine.%26nbsp%3B%20However%2C%20at%20the%20hub%20site%20level%2C%20pulling%20the%20news%20from%20those%20sites%20into%20a%20news%20web%20part%2C%20when%20I%20enable%20the%20audience%20targeting%20feature%2C%20no%20action%20is%20taken.%26nbsp%3B%20It%20doesn't%20appear%20the%20audience%20targeting%20functionality%20is%20working%20in%20this%20scenario.%20Is%20this%20expected%20behavior%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1060083%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1060905%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060905%22%20slang%3D%22en-US%22%3EWhen%20you%20enable%20the%20option%20on%20the%20web%20part%2C%20you%20have%20to%20give%20it%2010-15%20minutes%20since%20it%20runs%20off%20search%20to%20update%20the%20search%20index%20for%20the%20users%2C%20but%20that%20is%20all%20there%20is%20too%20it.%20Make%20sure%20the%20audiences%20you%20are%20assigning%2C%20do%20not%20have%20the%20person%20logged%20in%20for%20the%20test%20in%20them%20as%20well%20obviously%20%3Ap%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061027%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061027%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48055%22%20target%3D%22_blank%22%3E%40Pam%20DeLung%3C%2FA%3E%26nbsp%3BI%20am%20having%20this%20issue%20as%20well.%20I%20have%20waited%20as%20long%20as%20a%2024%20hour%20period%20and%20still%20the%20same%20result.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061109%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061109%22%20slang%3D%22en-US%22%3ELaura%20Rogers%20just%20did%20a%20power%20hour%20over%20this%20and%20it%20was%20working.%20I%E2%80%99ll%20need%20to%20go%20test%20it%20out%20and%20see%20if%20something%20has%20broke%20or%20not.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061177%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061177%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F442399%22%20target%3D%22_blank%22%3E%40TrippMD%3C%2FA%3E%26nbsp%3B%20-%20Same%20here.%26nbsp%3B%20We%20put%20this%20in%20place%20over%2024%20hours%20ago%2C%20still%20not%20working.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061186%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061186%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20Yes!%26nbsp%3B%20I%20watched%20Laura's%20Power%20Hour%20on%20the%20audience%20targeting%2C%20but%20I%20can't%20remember%20if%20she%20covered%20this%20scenario.%26nbsp%3B%20It%20works%20perfect%20on%20same%20site%20testing%20for%20us.%26nbsp%3B%20It's%20the%20rolling%20up%20of%20news%20to%20hub%20site%20level%20-%20that's%20where%20we're%20seeing%20the%20issue%20of%20the%20audience%20targeting%20not%20working%20successfully.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061273%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061273%22%20slang%3D%22en-US%22%3EAre%20you%20missing%20news%2C%20or%20is%20it%20just%20showing%20all%20news%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1062215%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1062215%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3BIt%20works%20fine%20for%20same%20site%20but%20it%20shows%20all%20the%20news%20at%20HUB%20site.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1068887%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1068887%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20It's%20showing%20all%20news.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1070959%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1070959%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20Hey%20there.%26nbsp%3B%20Wondering%20if%20you'd%20had%20a%20chance%20to%20test%20this%20in%20your%20tenant%20and%20if%20so%2C%20what%20was%20your%20experience%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1185871%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1185871%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Pam%2C%20having%20the%20same%20experience%2C%20did%20you%20have%20any%20joy%20with%20this%3F%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48055%22%20target%3D%22_blank%22%3E%40Pam%20DeLung%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We have a Hub site and are pulling in news from sites associated with the Hub.  I have set targeted audiences on those news articles and have tested the functionality on the sites themselves - the audience targeting seems to work fine.  However, at the hub site level, pulling the news from those sites into a news web part, when I enable the audience targeting feature, no action is taken.  It doesn't appear the audience targeting functionality is working in this scenario. Is this expected behavior?

10 Replies
When you enable the option on the web part, you have to give it 10-15 minutes since it runs off search to update the search index for the users, but that is all there is too it. Make sure the audiences you are assigning, do not have the person logged in for the test in them as well obviously :p

@Pam DeLung I am having this issue as well. I have waited as long as a 24 hour period and still the same result.

Laura Rogers just did a power hour over this and it was working. I’ll need to go test it out and see if something has broke or not.

@TrippMD  - Same here.  We put this in place over 24 hours ago, still not working. 

@Chris Webb - Yes!  I watched Laura's Power Hour on the audience targeting, but I can't remember if she covered this scenario.  It works perfect on same site testing for us.  It's the rolling up of news to hub site level - that's where we're seeing the issue of the audience targeting not working successfully.

Are you missing news, or is it just showing all news?

@Chris Webb It works fine for same site but it shows all the news at HUB site.

@Chris Webb - It's showing all news.

@Chris Webb - Hey there.  Wondering if you'd had a chance to test this in your tenant and if so, what was your experience?

Hi Pam, having the same experience, did you have any joy with this? @Pam DeLung