Audience Targeting for News not working at Hub Site level

%3CLINGO-SUB%20id%3D%22lingo-sub-1060083%22%20slang%3D%22en-US%22%3EAudience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060083%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20Hub%20site%20and%20are%20pulling%20in%20news%20from%20sites%20associated%20with%20the%20Hub.%26nbsp%3B%20I%20have%20set%20targeted%20audiences%20on%20those%20news%20articles%20and%20have%20tested%20the%20functionality%20on%20the%20sites%20themselves%20-%20the%20audience%20targeting%20seems%20to%20work%20fine.%26nbsp%3B%20However%2C%20at%20the%20hub%20site%20level%2C%20pulling%20the%20news%20from%20those%20sites%20into%20a%20news%20web%20part%2C%20when%20I%20enable%20the%20audience%20targeting%20feature%2C%20no%20action%20is%20taken.%26nbsp%3B%20It%20doesn't%20appear%20the%20audience%20targeting%20functionality%20is%20working%20in%20this%20scenario.%20Is%20this%20expected%20behavior%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1060083%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1060905%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060905%22%20slang%3D%22en-US%22%3EWhen%20you%20enable%20the%20option%20on%20the%20web%20part%2C%20you%20have%20to%20give%20it%2010-15%20minutes%20since%20it%20runs%20off%20search%20to%20update%20the%20search%20index%20for%20the%20users%2C%20but%20that%20is%20all%20there%20is%20too%20it.%20Make%20sure%20the%20audiences%20you%20are%20assigning%2C%20do%20not%20have%20the%20person%20logged%20in%20for%20the%20test%20in%20them%20as%20well%20obviously%20%3Ap%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061027%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061027%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48055%22%20target%3D%22_blank%22%3E%40Pam%20DeLung%3C%2FA%3E%26nbsp%3BI%20am%20having%20this%20issue%20as%20well.%20I%20have%20waited%20as%20long%20as%20a%2024%20hour%20period%20and%20still%20the%20same%20result.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061109%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061109%22%20slang%3D%22en-US%22%3ELaura%20Rogers%20just%20did%20a%20power%20hour%20over%20this%20and%20it%20was%20working.%20I%E2%80%99ll%20need%20to%20go%20test%20it%20out%20and%20see%20if%20something%20has%20broke%20or%20not.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061177%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061177%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F442399%22%20target%3D%22_blank%22%3E%40TrippMD%3C%2FA%3E%26nbsp%3B%20-%20Same%20here.%26nbsp%3B%20We%20put%20this%20in%20place%20over%2024%20hours%20ago%2C%20still%20not%20working.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061186%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061186%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20Yes!%26nbsp%3B%20I%20watched%20Laura's%20Power%20Hour%20on%20the%20audience%20targeting%2C%20but%20I%20can't%20remember%20if%20she%20covered%20this%20scenario.%26nbsp%3B%20It%20works%20perfect%20on%20same%20site%20testing%20for%20us.%26nbsp%3B%20It's%20the%20rolling%20up%20of%20news%20to%20hub%20site%20level%20-%20that's%20where%20we're%20seeing%20the%20issue%20of%20the%20audience%20targeting%20not%20working%20successfully.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1061273%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1061273%22%20slang%3D%22en-US%22%3EAre%20you%20missing%20news%2C%20or%20is%20it%20just%20showing%20all%20news%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1062215%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1062215%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3BIt%20works%20fine%20for%20same%20site%20but%20it%20shows%20all%20the%20news%20at%20HUB%20site.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1068887%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1068887%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20It's%20showing%20all%20news.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1070959%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1070959%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B-%20Hey%20there.%26nbsp%3B%20Wondering%20if%20you'd%20had%20a%20chance%20to%20test%20this%20in%20your%20tenant%20and%20if%20so%2C%20what%20was%20your%20experience%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1185871%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1185871%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Pam%2C%20having%20the%20same%20experience%2C%20did%20you%20have%20any%20joy%20with%20this%3F%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48055%22%20target%3D%22_blank%22%3E%40Pam%20DeLung%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2381485%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2381485%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20the%20same%20issue.%20Has%20anyone%20been%20able%20to%20find%20if%20this%20is%20a%20bug%2C%20or%20just%20not%20supported%20by%20SharePoint%20Online%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2382068%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2382068%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F449041%22%20target%3D%22_blank%22%3E%40AMURDOCK%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20managed%20to%20figure%20out%20the%20issue%2C%20you%20need%20to%20ensure%20the%20following%20for%20it%20to%20work%20correctly.%3C%2FP%3E%3CP%3E1.%20ensure%20you%20have%20audience%20target%20enabled%20on%20sitepages%20of%20the%20actual%20site%2C%20and%20that%20you%20enable%20audience%20targetting%20on%20the%20news%20webpart%2C%20then%20verify%20its%20actually%20working%20correctly.%3C%2FP%3E%3CP%3E2.%20Then%20go%20to%20the%20hub%20site%2C%20and%20do%20the%20same%2C%20enable%20on%20the%20sitepages%20of%20the%20hub%20and%20enable%20on%20the%20news%20webpart.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20short%20you%20need%20to%20have%20audience%20target%20enabled%20on%20hub%20and%20on%20site%20for%20the%20news%20rollup%20to%20work%20not%20just%20on%20the%20hub.%20Hope%20this%20helps.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2387155%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2387155%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F559927%22%20target%3D%22_blank%22%3E%40NightmareRambo77%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20everyone.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22VIiyi%22%3E%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3EOne%20customer%20has%20the%20same%20problem.%3C%2FSPAN%3E%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3EThe%20audience%20is%20set%20in%20the%20Site%20Pages%20and%20in%20News%20webpart%20on%20both%20-%26nbsp%3B%20the%20Hub%20site%20and%20the%20associated%20site.%20Targeting%20works%20fine%20on%20the%20associated%20site.%20No%20news%20that%20has%20a%20target%20audience%20set%20in%20the%20source%20site%20(associated%20with%20the%20hub%20site)%20will%20be%20displayed%20on%20the%20Hub%20site%20News%20web%20part.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22VIiyi%22%3E%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3EDoes%20anyone%20have%20any%20ideas%20what%20this%20could%20be%3F%3C%2FSPAN%3E%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3EI'm%20getting%20frustrated%20with%20that.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22VIiyi%22%3E%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3EThank%20you.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22VIiyi%22%3E%3CSPAN%20class%3D%22JLqJ4b%20ChMk0b%22%3E%3CSPAN%3ELenka%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2387249%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2387249%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F449835%22%20target%3D%22_blank%22%3E%40Lenkaa%3C%2FA%3E%26nbsp%3B-%20Hi%20there!%26nbsp%3B%20Something%20that%20may%20seem%20small%2C%20make%20sure%20the%20news%20article%20that%20you%20added%20the%20target%20audience%20has%20been%20published%20to%20a%20major%20version.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2387317%22%20slang%3D%22en-US%22%3ERe%3A%20Audience%20Targeting%20for%20News%20not%20working%20at%20Hub%20Site%20level%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2387317%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F48055%22%20target%3D%22_blank%22%3E%40Pam%20DeLung%3C%2FA%3E%2C%3CBR%20%2F%3E%3CSPAN%3Ethank%20you%20for%20your%20reply%20and%20help.%20Bu%20y%3C%2FSPAN%3Ees%2C%20they%20are%20all%20in%20the%20major%20version.%20This%20is%20a%20general%20problem%20when%20I%20view%20news%20using%20the%20Select%20site%20or%20All%20sites%20in%20the%20hub%20option.%20When%20I%20turn%20off%20audience%20targeting%20in%20the%20News%20webpart%2C%20I%20see%20all%20the%20news%20from%20other%20sites.%20However%2C%20when%20I%20turn%20on%20this%20feature%2C%20only%20those%20that%20do%20not%20have%20any%20groups%20filled%20in%20the%20Audience%20column%20will%20remain%20displayed.%3CBR%20%2F%3EIt%20looks%20like%20SharePoint%20can't%20tell%20if%20I'm%20a%20member%20of%20an%20embedded%20group%20or%20not.%20But%20the%20This%20site%20option%20works%20with%20targeting%20without%20any%20problems%20and%20displays%20the%20news%20where%20I'm%20a%20member%20of%20the%20group.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

We have a Hub site and are pulling in news from sites associated with the Hub.  I have set targeted audiences on those news articles and have tested the functionality on the sites themselves - the audience targeting seems to work fine.  However, at the hub site level, pulling the news from those sites into a news web part, when I enable the audience targeting feature, no action is taken.  It doesn't appear the audience targeting functionality is working in this scenario. Is this expected behavior?

15 Replies
When you enable the option on the web part, you have to give it 10-15 minutes since it runs off search to update the search index for the users, but that is all there is too it. Make sure the audiences you are assigning, do not have the person logged in for the test in them as well obviously :p

@Pam DeLung I am having this issue as well. I have waited as long as a 24 hour period and still the same result.

Laura Rogers just did a power hour over this and it was working. I’ll need to go test it out and see if something has broke or not.

@TrippMD  - Same here.  We put this in place over 24 hours ago, still not working. 

@Chris Webb - Yes!  I watched Laura's Power Hour on the audience targeting, but I can't remember if she covered this scenario.  It works perfect on same site testing for us.  It's the rolling up of news to hub site level - that's where we're seeing the issue of the audience targeting not working successfully.

Are you missing news, or is it just showing all news?

@Chris Webb It works fine for same site but it shows all the news at HUB site.

@Chris Webb - It's showing all news.

@Chris Webb - Hey there.  Wondering if you'd had a chance to test this in your tenant and if so, what was your experience?

Hi Pam, having the same experience, did you have any joy with this? @Pam DeLung 

We have the same issue. Has anyone been able to find if this is a bug, or just not supported by SharePoint Online?

@AMURDOCK 

Hi,

I managed to figure out the issue, you need to ensure the following for it to work correctly.

1. ensure you have audience target enabled on sitepages of the actual site, and that you enable audience targetting on the news webpart, then verify its actually working correctly.

2. Then go to the hub site, and do the same, enable on the sitepages of the hub and enable on the news webpart.

 

In short you need to have audience target enabled on hub and on site for the news rollup to work not just on the hub. Hope this helps.

@NightmareRambo77 

Hi everyone.

One customer has the same problem. The audience is set in the Site Pages and in News webpart on both -  the Hub site and the associated site. Targeting works fine on the associated site. No news that has a target audience set in the source site (associated with the hub site) will be displayed on the Hub site News web part.

 

Does anyone have any ideas what this could be? I'm getting frustrated with that.

Thank you.

Lenka

@Lenkaa - Hi there!  Something that may seem small, make sure the news article that you added the target audience has been published to a major version.  

Hi @Pam DeLung,
thank you for your reply and help. Bu yes, they are all in the major version. This is a general problem when I view news using the Select site or All sites in the hub option. When I turn off audience targeting in the News webpart, I see all the news from other sites. However, when I turn on this feature, only those that do not have any groups filled in the Audience column will remain displayed.
It looks like SharePoint can't tell if I'm a member of an embedded group or not. But the This site option works with targeting without any problems and displays the news where I'm a member of the group.