SOLVED

Approval Status Column Formatting - gone!

Super Contributor

I may be having a senior moment, but the column formatting on a document library with Approval Status switched on has disappeared. It was there the other day but looking at it now it looks like this
format.jpg

I presume I used the view format, as when I tried to reapply the format using column format the option is not there on this column (it is on all the other columns in the library).  The view format is now empty - really confused - anyone out there experiencing the same problem or can point me in the right direction pretty please?

42 Replies

Hi @Tanya Denton,

 

If you share the JSON I am happy to test for you. I have a number of lists with custom formatting and they are all behaving as expected.

 

Norm

@Norman thanks for such a quick reply. My problem is the JSON has gone (if it was there in the first place) in the Format VIEW, and there is no option on the Approval Status column to add a column format. This is why i am confused!

My custom JSON is working and so are my "Format Status column" settings.

Untitled.png

Did the choice values happen to change?

 

Is there any JSON code listed in the list settings > edit column?

 

 

We have the OOTB Approvals switched on so the [Approval Stauts] column is provisioned automatically. I have just created a brand new view and it still shows the below so this tells me i must have used Column formatting and not View formatting (I think!)
format.jpg








The options I have for that column are
columnoptions.jpg
I have just used the browser developer tools and that shows I used .sp-field-customFormatter

I follow now. You are using the "Content Approval" feature.

Capture.PNG

I don't see the OOTB format column feature, so you must have formatted via the view. I will try to reproduce.

 

Can you send me a screen shot of your document library settings? Specifically the columns. I can't see how you are formatting the view with the Approval Status column when it doesn't show as a column.

 

Capture.PNGCapture1.PNG

Hi Norman, the column is showing fine in the library, it is the option of formatting that column that is not showing.

I have the same experience. If you check the document library settings you won't see the Approval Status column. The formatting must have been through the view. I am trying to reproduce the behavior but cannot reference the Approval Status in the JSON.

Something is not adding up for me.

 

If the column is not visible in the document library settings how were you able to format the column using JSON?

 

I was not able to format the view using the Approval Status (_ModerationStatus is the internal name BTW).

 

I'm happy to help more but I not sure where I can. Did you make any progress?

 

Norm

Hi you can format a column by using the column drop down in the library (you don't have to go to the
settings of the library), Example
FormatColumn.png


 

 

 

 

 

If I had formatted that column using the VIEW formatting, then when I created a new VIEW the formatting would not be there - but it was still there - hence why I am saying I must have formatted that column using COLUMN formatting.

 

 

@Tanya Denton 

We are having a similar issue.   I had a flow button showing based on the approval status, using [$_ModerationStatus] and it is no longer showing appropriately.  This has been working fine since January and broke earlier this week.

 

Definitely appears that ModerationStatus is no longer available to the column formatting JSON.

Below is an example of the column formatting I was doing

{
"$schema": "http://columnformatting.sharepointpnp.com/columnFormattingSchema.json",
"elmType": "div",
"children": [
{
"elmType": "span",
"style": {
"padding-right": "8px"
},
"txtContent": ""
},
{
"elmType": "a",
"attributes": {
"iconName": "previewLink",
"href": {
"operator": "+",
"operands": [
"https://MYSHAREPOINT.sharepoint.com/sites/MYSharePoint/",
"[$FileLeafRef]",
"&parent=%2Fsites%2FMYSharePoint%2FDocuments"
]
},
"target": "_blank"
},
"style": {
"padding-right": "8px",
"text-decoration": "none"
}
},
{
"elmType": "button",
"txtContent": "[$_ModerationStatus]",
"customRowAction": {
"action": "executeFlow",
"actionParams": "{\"id\": \"12345689-abcd-12ab-1234-123456789012\"}"
},
"style": {
"visibility": {
"operator": "?",
"operands": [
{
"operator": "==",
"operands": [
"[$_ModerationStatus]",
"Draft"
]
},
"visible",
"visible"
]
}
}
}
]
}

Thank goodness I am not going mad! How annoying is that. Hopefully it is temporary and will be back soon.

Hi @Tanya Denton 

 

I am having the exact same issue.

 

This was how my Approval Status column was before:

approval-before.JPG

And this is how it is now:

approval-now.JPG

This is very frustrating I hope it gets fixed soon

@nz_archer - exactly the same for me

 

@Tanya Denton Same here. Format column is gone, and just in the Approval Status column. Other columns format fine. Logging a support case.

best response confirmed by Tanya Denton (Super Contributor)
Solution

@Tanya Denton  . We faced the same issue the same day, it seems that Microsoft have removed  that option. I managed to remove JSON format by going to hidden field in this way:  https://yoursite/_layouts/15/FldEdit.aspx?List=ListID&Field=_ModerationStatus.

You can go  to another field's settings  of the same list and replace that field  name for  "_ModerationStatus" in the url. 

@escipion you absolute star!  Thank you so much for the solution. 

@escipion  Works as advertised! Thanks!


@escipion wrote:

@Tanya Denton  . We faced the same issue the same day, it seems that Microsoft have removed  that option. I managed to remove JSON format by going to hidden field in this way:  https://yoursite/_layouts/15/FldEdit.aspx?List=ListID&Field=_ModerationStatus.

You can go  to another field's settings  of the same list and replace that field  name for  "_ModerationStatus" in the url. 


 

@escipion Thanks for the info, works great.

 

I must say that it is very disappointing that this has been removed, it really was helpful when using large libraries.