Apply Sensitivity Label to Site

%3CLINGO-SUB%20id%3D%22lingo-sub-946645%22%20slang%3D%22en-US%22%3EApply%20Sensitivity%20Label%20to%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-946645%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EI%20am%20seeing%20the%20ability%20to%20assign%20a%20Sensitivity%20Label%20to%20a%20SharePoint%20site%20in%20the%20SPO%20Admin%20Center%2C%20on%20the%20Information%20Panel%2C%20but%20none%20of%20my%20labels%20are%20available%20for%20selection.%20Can%20anyone%20tell%20me%20how%20to%20enable%20this%20functionality.%20I%20can't%20find%20anything%20in%20the%20SPO%20or%20AIP%20docs.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-946645%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-988906%22%20slang%3D%22en-US%22%3ERe%3A%20Apply%20Sensitivity%20Label%20to%20Site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-988906%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1096%22%20target%3D%22_blank%22%3E%40Dean%20Gross%3C%2FA%3E%26nbsp%3B-%20Me%20too.%26nbsp%3B%20Came%20here%20looking%20for%20answers.%26nbsp%3B%20Commenting%20to%20follow.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Respected Contributor

I am seeing the ability to assign a Sensitivity Label to a SharePoint site in the SPO Admin Center, on the Information Panel, but none of my labels are available for selection. Can anyone tell me how to enable this functionality. I can't find anything in the SPO or AIP docs.

4 Replies

@Dean Gross - Me too.  Came here looking for answers.  Commenting to follow.

@Sara Fennah@Dean Gross , any luck getting this configured? 

 

Do you need to use PowerShell such as Set-SPOSite -SensitivityLabel <guid> ?

 

Cheers,

Nigel 

It could be due to slow replication between Microsoft 365, AzureAD and SharePoint.

https://github.com/MicrosoftDocs/microsoft-365-docs/issues/4611

You can configure Labels on Teams / Office365 groups from the AzureAD Portal once the environment has been set up correctly.

 

Import-Module ExchangeOnlineManagement
Connect-ExchangeOnline -UserPrincipalName <upn>
Test-IRMConfiguration -Sender <email> -Recipient <email>

Import-Module AIPService
Connect-AIPService
Set-AipServiceOnboardingControlPolicy -UseRmsUserLicense $True
Enable-AipService
Get-AipService

Import-Module ExchangeOnlineManagement
Connect-IPPSSession -UserPrincipalName <upn>
Get-Label | Select-Object -Property Name,GUID
Disconnect-ExchangeOnline

Import-Module AzureADPreview
Connect-AzureAD

$setting = (Get-AzureADDirectorySetting | where -Property DisplayName -Value "Group.Unified" -EQ)
$template = Get-AzureADDirectorySettingTemplate -Id 62375ab9-6b52-47ed-826b-58e47e0e304b
$setting = $template.CreateDirectorySetting()
$Setting["EnableMIPLabels"] = "True"
New-AzureADDirectorySetting -DirectorySetting $setting

Execute-AzureAdLabelSync

Import-Module -Name Microsoft.Online.SharePoint.PowerShell
Connect-SPOService -Url https://<site>-admin.sharepoint.com -Credential <upn>
Set-SPOTenant -EnableAIPIntegration $true

 

You also need to configure the Sensitivity Labels to be used in Groups/Teams, publish those labels, sync those labels, and potentially wait up for 24 hours for them to appear in AzureAD.

 

Cheers,

Nigel 

Working for me now. As you commented. you do need to enable labels for groups & sites (lines 16-23 of the quoted script) and then sync them across Azure AD & Exchange with line 25 of the quoted script. Also make sure you have published the labels to the user accounts who are applying them