Apply fonts from Sharepoint Management Shell

Copper Contributor

I want my users to use company fonts in their 'Powerpoint on the Web' throughout the organization. Currently they can only use these company fonts in their Powepoint app on Windows when they individually install them. 

I have followed a guide by Microsoft to create a ' font library' on a sharepoint site with permissions for 'everyone except external users' , added this as an asset library on SP Management Shell with success, uploaded the fonts in this library  and allowed 24 hrs to pass but still I cannot see those fonts in 'Powerpoint Web'. 

Do I have to upload the fonts through SP Man Shell? If yes, how do I do that? Currently I see a font library in PowerpointWeb (see below) without anything in it as well as searching for the font in a powerpoint presentation which doesn't show , please help. 








14 Replies
Hello George
Is this the guide you have followed?

How did you upload the fonts? Manually or as the guide says? (Set-SPOCustomFontCatalog)

@Andres Gorzelany Hi Andres, yes followed the article that you mentioned. I uploaded it manually as the commend to upload within SP Man Shell is giving me errors 


See attached files for errors its giving me in SP Shell even though my SP management Shell is the latest version. 


Should I be using SP Shell or latest Powershell as the command 'Set-SPOCustomFontCatalog' is not being recognized? Please guide me in the right direction, Thank you. 

Be sure to be running only one version of the module

get-module -ListAvailable Microsoft.Online.SharePoint.PowerShell

If you find more than one remove them all and start over installing the last one. (16.0.22713.12000)

If my memory doesn't fail, last time I tried org fonts I had to run the shell as an administrator

@Andres Gorzelany hi I have run that command in Powershell and not SP Man Shell , is that correct? It is running the latest version and only one version and run as administrator and the same error comes up (attached)


I am beginning to think this feature is not working worldwide fully yet. 

Did you connect to the SharePoint Online tenant using the SharePoint Management Shell before running that cmdlet?

@Andres Gorzelany I do connect successfully to SP tenant with my creds in SP Man Shell


I reinstalled the latest SP Man Shell module and it successfully knows the command but now when I run the command it results in another strange error , see attached. 

It is already a document library called FontLibrary. 


best response confirmed by george_71239 (Copper Contributor)
Couple of things:

Surround c:\Fonts using double quotes "C:\Fonts"

run the PowerShell window as administrator

Also, to specify the -libraryUrl, remove Forms/AllItems.aspx from the url in the parameter.

as the example in Docs.

Thanks, the double quotes helped but I had to recreate the document library as it wasn't applying, thank you for your help.

Do image libraries work the same way? Thanks again.
Glad to hear.

Image libraries work slightly different, they will be available only on SharePoint Online

@Andres Gorzelany Thanks Andres.


I see another problem, as I created a new doc library for the fonts , Powerpoint is still showing the old library (see attached). If I designate the new library do I have to do this whole process again?

What's the output for


@Andres Gorzelany Hi Andres


It is showing the old font library that it had a problem with (see attached).


It's been 2 days and the fonts are not showing up in Powerpoint web maybe because its showing the old font library which was problematic?  

If it is showing the old library and I see in the screenshot it is set as OfficeTemplateLibrary (For PowerPoint, Word, Excel templates) instead of OfficeFontLibrary

I recommend you to start over, first with the Font Library, then with other libraries that you need (ImageDocumentLibrary or OfficeTemplateLibrary)

@Andres Gorzelany thanks Andres. I successfully removed that library and added the 'true' library as public, will wait a couple of days to see if fonts that I already uploaded in 'shell' to be in Powerpoint. Will keep you posted, thanks.