SOLVED

Adding Custom Columns to List

%3CLINGO-SUB%20id%3D%22lingo-sub-917682%22%20slang%3D%22en-US%22%3EAdding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917682%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%20I'm%20trying%20to%20do%20something%20basic%20in%20Sharepoint%20Online%20by%20adding%20columns%20to%20a%20list.%20I've%20run%20into%20several%20problems.%20The%20columns%20I'm%20trying%20to%20add%20are%20standard%20single%20line%20of%20text%20for%20things%20like%20name%2C%20title%2C%20address%2C%20etc.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Columns%20disappear%20but%20still%20exist.%20Let's%20say%20I%20add%20two%20columns%20for%20Address%20Line%201%20and%20Address%20Line%202.%20When%20I%20reload%20the%20page%2C%20Address%20Line%201%20might%20have%20disappeared.%20However%2C%20if%20I%20try%20to%20add%20it%20again%2C%20it%20says%20that%20it%20already%20exists%20and%2C%20indeed%2C%20I%20can%20see%20it%20on%20the%20list%20when%20I%20go%20to%20List%20Settings.%20If%20I%20try%20to%20do%20Quick%20Edit%2C%20the%20disappearing%20columns%20are%20not%20included.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B2.%20It's%20not%20saving%20column%20order%20changes.%20Let's%20say%20I%20accidentally%20add%20Address%20Line%202%20first%20and%20then%20Address%20Line%201.%20I%20use%20the%20%22Move%20Left%22%20option%20to%20put%20Address%20Line%201%20first.%20However%2C%20when%20I%20reload%20the%20list%2C%20Address%20Line%201%20is%20back%20to%20the%20right%20of%20Address%20Line%202.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E3.%20Renaming%20columns.%20I%20used%20the%20%22Rename%22%20option%20to%20change%20%22Title%22%20to%20%22Funder%20Name.%22%20When%20I%20do%20Quick%20Edit%2C%20it%20has%20reverted%20back%20to%20Title.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20almost%20feel%20like%20I'm%20missing%20some%20kind%20of%20save%20or%20apply%20changes%20button%20but%20those%20don't%20exist%20as%20far%20as%20I%20can%20tell.%20Appreciate%20any%20help%20you%20can%20provide.%20I've%20tried%20watching%20various%20videos%20and%20reading%20blogs%20but%20have%20not%20found%20any%20info%20on%20this%20subject.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-917682%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917701%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917701%22%20slang%3D%22en-US%22%3EHi%20Brad1974%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI%20think%20you%20are%20not%20modifying%20the%20views%20based%20on%20your%20requirement%2C%20Go%20to%20List%20settings%20-%26gt%3B%20scroll%20all%20the%20way%20down%20and%20under%20views%20click%20%22all%20items%22%20-%26gt%3B%20then%20sort%20the%20column%20by%20enabling%20check%20box%20and%20sort%20order.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-918443%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-918443%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F270484%22%20target%3D%22_blank%22%3E%40Thivagar_Segar%3C%2FA%3E%26nbsp%3BThank%20you!%20The%20missing%20columns%20were%20not%20checked.%20It%20seems%20strange%20that%20it%20allows%20you%20to%20add%20new%20columns%20but%20doesn't%20automatically%20make%20those%20visible.%20Or%20maybe%20it%20only%20shows%20so%20many%20columns.%20Anyway%20I%20clearly%20need%20to%20do%20some%20more%20reading%20about%20how%20views%20work%20but%20thank%20you%20for%20helping%20me%20solve%20my%20immediate%20need.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-918459%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-918459%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F428160%22%20target%3D%22_blank%22%3E%40Brad1974%3C%2FA%3E%26nbsp%3Bin%20the%20modern%20view%20you%20can%20add%20new%20columns%20to%20the%20List%2C%20and%20they%20will%20show%20up%20in%20the%20view.%20But%20thats%20not%20permanent.%20If%20you%20look%20at%20the%20view%20name%20it%20shows%20an%20asterisk%20meaning%20changes%20havent%20been%20saved.%20Click%20on%20the%20view%20name%20and%20%E2%80%98save%20view%E2%80%99%20-%20use%20the%20same%20name%20to%20update%20the%20current.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-919312%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-919312%22%20slang%3D%22en-US%22%3EYeah%2C%20as%20both%20said%20here%20it's%20the%20view%20that%20needs%20saved%20first%20for%20it%20to%20show%20on%20a%20refresh.%20%3CBR%20%2F%3E%3CBR%20%2F%3ECreating%20columns%20happens%20when%20you%20create%20them%2C%20and%20they%20do%20infact%20stay%20in%20the%20list%2C%20but%20will%20not%20show%20on%20the%20current%20view%20unless%20you%20save%20the%20view%20after%20adding%20the%20columns.%20Kind%20of%20a%20weird%20UI%20think%20that%20might%20need%20to%20be%20tweaked%20if%20you%20are%20editing%20direct%20in%20that%20view%20it%20should%20probably%20save%20at%20least%20when%20creating%20columns.%20%3CBR%20%2F%3E%3CBR%20%2F%3EUsually%20checking%20the%20%22Add%20to%20default%20view%22%20will%20basically%20add%20it%20to%20the%20saved%20version%20automatically%20assuming%20you%20are%20working%20in%20the%20default%20view%20at%20the%20time%20as%20well.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-919864%22%20slang%3D%22en-US%22%3ERe%3A%20Adding%20Custom%20Columns%20to%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-919864%22%20slang%3D%22en-US%22%3EThanks!%3C%2FLINGO-BODY%3E
New Contributor

Hi. I'm trying to do something basic in Sharepoint Online by adding columns to a list. I've run into several problems. The columns I'm trying to add are standard single line of text for things like name, title, address, etc. 

 

1. Columns disappear but still exist. Let's say I add two columns for Address Line 1 and Address Line 2. When I reload the page, Address Line 1 might have disappeared. However, if I try to add it again, it says that it already exists and, indeed, I can see it on the list when I go to List Settings. If I try to do Quick Edit, the disappearing columns are not included. 

 

 2. It's not saving column order changes. Let's say I accidentally add Address Line 2 first and then Address Line 1. I use the "Move Left" option to put Address Line 1 first. However, when I reload the list, Address Line 1 is back to the right of Address Line 2. 

 

3. Renaming columns. I used the "Rename" option to change "Title" to "Funder Name." When I do Quick Edit, it has reverted back to Title. 

 

I almost feel like I'm missing some kind of save or apply changes button but those don't exist as far as I can tell. Appreciate any help you can provide. I've tried watching various videos and reading blogs but have not found any info on this subject. 

5 Replies
Hi Brad1974,

I think you are not modifying the views based on your requirement, Go to List settings -> scroll all the way down and under views click "all items" -> then sort the column by enabling check box and sort order.

@Thivagar_Segar Thank you! The missing columns were not checked. It seems strange that it allows you to add new columns but doesn't automatically make those visible. Or maybe it only shows so many columns. Anyway I clearly need to do some more reading about how views work but thank you for helping me solve my immediate need. 

Best Response confirmed by Chris Webb (MVP)
Solution

@Brad1974 in the modern view you can add new columns to the List, and they will show up in the view. But thats not permanent. If you look at the view name it shows an asterisk meaning changes havent been saved. Click on the view name and ‘save view’ - use the same name to update the current. 

Yeah, as both said here it's the view that needs saved first for it to show on a refresh.

Creating columns happens when you create them, and they do infact stay in the list, but will not show on the current view unless you save the view after adding the columns. Kind of a weird UI think that might need to be tweaked if you are editing direct in that view it should probably save at least when creating columns.

Usually checking the "Add to default view" will basically add it to the saved version automatically assuming you are working in the default view at the time as well.
Thanks!