Add -SPOTheme not using colours (Help!!!)

%3CLINGO-SUB%20id%3D%22lingo-sub-1879075%22%20slang%3D%22en-US%22%3EAdd%20-SPOTheme%20not%20using%20colours%20(Help!!!)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1879075%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eusing%20the%20SharePoint%20Online%20Management%20Tool%20I'm%20trying%20to%20add%20a%20theme%20as%20below.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%40%7B%3CBR%20%2F%3E%22themePrimary%22%20%3D%20%22%238ec63f%22%3B%3CBR%20%2F%3E%22themeLighterAlt%22%20%3D%20%22%23fafdf6%22%3B%3CBR%20%2F%3E%22themeLighter%22%20%3D%20%22%23ebf6db%22%3B%3CBR%20%2F%3E%22themeLight%22%20%3D%20%22%23daeebe%22%3B%3CBR%20%2F%3E%22themeTertiary%22%20%3D%20%22%23b8dd83%22%3B%3CBR%20%2F%3E%22themeSecondary%22%20%3D%20%22%239ace53%22%3B%3CBR%20%2F%3E%22themeDarkAlt%22%20%3D%20%22%2380b339%22%3B%3CBR%20%2F%3E%22themeDark%22%20%3D%20%22%236c9730%22%3B%3CBR%20%2F%3E%22themeDarker%22%20%3D%20%22%23506f24%22%3B%3CBR%20%2F%3E%22neutralLighterAlt%22%20%3D%20%22%23f8f8f8%22%3B%3CBR%20%2F%3E%22neutralLighter%22%20%3D%20%22%23f4f4f4%22%3B%3CBR%20%2F%3E%22neutralLight%22%20%3D%20%22%23eaeaea%22%3B%3CBR%20%2F%3E%22neutralQuaternaryAlt%22%20%3D%20%22%23dadada%22%3B%3CBR%20%2F%3E%22neutralQuaternary%22%20%3D%20%22%23d0d0d0%22%3B%3CBR%20%2F%3E%22neutralTertiaryAlt%22%20%3D%20%22%23c8c8c8%22%3B%3CBR%20%2F%3E%22neutralTertiary%22%20%3D%20%22%23c2c2c2%22%3B%3CBR%20%2F%3E%22neutralSecondary%22%20%3D%20%22%23858585%22%3B%3CBR%20%2F%3E%22neutralPrimaryAlt%22%20%3D%20%22%234b4b4b%22%3B%3CBR%20%2F%3E%22neutralPrimary%22%20%3D%20%22%23333333%22%3B%3CBR%20%2F%3E%22neutralDark%22%20%3D%20%22%23272727%22%3B%3CBR%20%2F%3E%22black%22%20%3D%20%22%231d1d1d%22%3B%3CBR%20%2F%3E%22white%22%20%3D%20%22%23ffffff%22%3B%3CBR%20%2F%3E%22primaryBackground%22%20%3D%20%22%23ffffff%22%3B%3CBR%20%2F%3E%22primaryText%22%20%3D%20%22%23333333%22%3B%3CBR%20%2F%3E%22bodyBackground%22%20%3D%20%22%23ffffff%22%3B%3CBR%20%2F%3E%22bodyText%22%20%3D%20%22%23333333%22%3B%3CBR%20%2F%3E%22disabledBackground%22%20%3D%20%22%23f4f4f4%22%3B%3CBR%20%2F%3E%22disabledText%22%20%3D%20%22%23c8c8c8%22%3B%3CBR%20%2F%3E%7D%3CBR%20%2F%3EAdd-SPOTheme%20-Identity%20%22Green%22%20-Palette%20%24themepalette%20-IsInverted%20%24false%20-Overwrite%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhile%20the%20process%20itself%20works%20and%20I%20can%20add%20a%20theme%20it%20isn't%20using%20the%20correct%20colors.%26nbsp%3B%20Once%20the%20theme%20is%20added%20and%20I%20do%20a%20%3CSPAN%20class%3D%22hljs-pscommand%22%3EGet-SPOTheme%3C%2FSPAN%3E%3CSPAN%20class%3D%22hljs-parameter%22%3E%20-Name%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22hljs-string%22%3E%22Green%22%3C%2FSPAN%3E%3CSPAN%3E%20%7C%20%3C%2FSPAN%3E%3CSPAN%20class%3D%22hljs-pscommand%22%3EConvertTo-Json%20it%20comes%20back%20as%20below.%26nbsp%3B%20For%20some%20reason%20its%20using%20different%20colours...%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20Get-SPOTheme%20-Name%20%22Green%22%20%7C%20ConvertTo-Json%3CBR%20%2F%3E%7B%3CBR%20%2F%3E%22Name%22%3A%20%22Green%22%2C%3CBR%20%2F%3E%22Palette%22%3A%20%7B%3CBR%20%2F%3E%22themeLight%22%3A%20%22%23affefe%22%2C%3CBR%20%2F%3E%22themeTertiary%22%3A%20%22%2376ffff%22%2C%3CBR%20%2F%3E%22black%22%3A%20%22%23000000%22%2C%3CBR%20%2F%3E%22neutralSecondary%22%3A%20%22%23666666%22%2C%3CBR%20%2F%3E%22neutralTertiaryAlt%22%3A%20%22%23c8c8c8%22%2C%3CBR%20%2F%3E%22themeSecondary%22%3A%20%22%2339ffff%22%2C%3CBR%20%2F%3E%22themeDarker%22%3A%20%22%23005252%22%2C%3CBR%20%2F%3E%22primaryBackground%22%3A%20%22%23fff%22%2C%3CBR%20%2F%3E%22neutralQuaternary%22%3A%20%22%23d0d0d0%22%2C%3CBR%20%2F%3E%22neutralPrimaryAlt%22%3A%20%22%233c3c3c%22%2C%3CBR%20%2F%3E%22neutralPrimary%22%3A%20%22%23333%22%2C%3CBR%20%2F%3E%22themeDark%22%3A%20%22%23009090%22%2C%3CBR%20%2F%3E%22themeLighter%22%3A%20%22%23daffff%22%2C%3CBR%20%2F%3E%22neutralTertiary%22%3A%20%22%23a6a6a6%22%2C%3CBR%20%2F%3E%22neutralQuaternaryAlt%22%3A%20%22%23dadada%22%2C%3CBR%20%2F%3E%22themeLighterAlt%22%3A%20%22%23f3fcfc%22%2C%3CBR%20%2F%3E%22white%22%3A%20%22%23fff%22%2C%3CBR%20%2F%3E%22neutralSecondaryAlt%22%3A%20%22%23767676%22%2C%3CBR%20%2F%3E%22neutralLighter%22%3A%20%22%23f4f4f4%22%2C%3CBR%20%2F%3E%22neutralLight%22%3A%20%22%23eaeaea%22%2C%3CBR%20%2F%3E%22neutralDark%22%3A%20%22%23212121%22%2C%3CBR%20%2F%3E%22themeDarkAlt%22%3A%20%22%2300c4c4%22%2C%3CBR%20%2F%3E%22neutralLighterAlt%22%3A%20%22%23f8f8f8%22%2C%3CBR%20%2F%3E%22primaryText%22%3A%20%22%23333%22%2C%3CBR%20%2F%3E%22themePrimary%22%3A%20%22%2300ffff%22%3CBR%20%2F%3E%7D%2C%3CBR%20%2F%3E%22IsInverted%22%3A%20false%3CBR%20%2F%3E%7D%3CBR%20%2F%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1879075%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPowerShell%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1892673%22%20slang%3D%22en-US%22%3ERe%3A%20Add%20-SPOTheme%20not%20using%20colours%20(Help!!!)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1892673%22%20slang%3D%22en-US%22%3E%3CP%3EHelp!!!!!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hello,

 

using the SharePoint Online Management Tool I'm trying to add a theme as below.

 

@{
"themePrimary" = "#8ec63f";
"themeLighterAlt" = "#fafdf6";
"themeLighter" = "#ebf6db";
"themeLight" = "#daeebe";
"themeTertiary" = "#b8dd83";
"themeSecondary" = "#9ace53";
"themeDarkAlt" = "#80b339";
"themeDark" = "#6c9730";
"themeDarker" = "#506f24";
"neutralLighterAlt" = "#f8f8f8";
"neutralLighter" = "#f4f4f4";
"neutralLight" = "#eaeaea";
"neutralQuaternaryAlt" = "#dadada";
"neutralQuaternary" = "#d0d0d0";
"neutralTertiaryAlt" = "#c8c8c8";
"neutralTertiary" = "#c2c2c2";
"neutralSecondary" = "#858585";
"neutralPrimaryAlt" = "#4b4b4b";
"neutralPrimary" = "#333333";
"neutralDark" = "#272727";
"black" = "#1d1d1d";
"white" = "#ffffff";
"primaryBackground" = "#ffffff";
"primaryText" = "#333333";
"bodyBackground" = "#ffffff";
"bodyText" = "#333333";
"disabledBackground" = "#f4f4f4";
"disabledText" = "#c8c8c8";
}
Add-SPOTheme -Identity "Green" -Palette $themepalette -IsInverted $false -Overwrite

 

While the process itself works and I can add a theme it isn't using the correct colors.  Once the theme is added and I do a Get-SPOTheme -Name "Green" | ConvertTo-Json it comes back as below.  For some reason its using different colours...

 

PS C:\WINDOWS\system32> Get-SPOTheme -Name "Green" | ConvertTo-Json
{
"Name": "Green",
"Palette": {
"themeLight": "#affefe",
"themeTertiary": "#76ffff",
"black": "#000000",
"neutralSecondary": "#666666",
"neutralTertiaryAlt": "#c8c8c8",
"themeSecondary": "#39ffff",
"themeDarker": "#005252",
"primaryBackground": "#fff",
"neutralQuaternary": "#d0d0d0",
"neutralPrimaryAlt": "#3c3c3c",
"neutralPrimary": "#333",
"themeDark": "#009090",
"themeLighter": "#daffff",
"neutralTertiary": "#a6a6a6",
"neutralQuaternaryAlt": "#dadada",
"themeLighterAlt": "#f3fcfc",
"white": "#fff",
"neutralSecondaryAlt": "#767676",
"neutralLighter": "#f4f4f4",
"neutralLight": "#eaeaea",
"neutralDark": "#212121",
"themeDarkAlt": "#00c4c4",
"neutralLighterAlt": "#f8f8f8",
"primaryText": "#333",
"themePrimary": "#00ffff"
},
"IsInverted": false
}
PS C:\WINDOWS\system32>

 

 

Thanks

1 Reply

Help!!!!!

 

:)