4 issues are found for Bulk Edit in Modern Panel (Document Library)

Frequent Contributor

Dear All,

I am using Modern Team Site template as below.

Currently I face 4 issues during editing the document metadata in document library.

1. Tough to click Save button. Need to ensure the icon is showing the 'Finger Pointer' icon.

Could MS make Save button location to be centered and easier to be clicked? Not only me to feel tough to click and some end users voice out about this.Click Save Button Problem.png

2.  Click Select All on page and update metadata. Click Save button and keep loading.

     None of the selected items are updated. If I manual mutiple select items, then those selected items' metadata are able to be updated. Not sure why. Does it a bug?Click Select All and Can't Save Problem.png


3.  Manual select 60 items, insert metadata and click Save. The message showed: 30 items selected in the modern panel. Does it a bug? The message is quite confuse.

30 items selected confuse message.png


4. Not matching metadata info with the properties in modern panel.

For example, category column for those document have been updated: ASTM.

However the category properties in modern panel is still showing 'Select an option'. Any idea?Not Match to Metadata Properties Info.png












4 Replies

I can confirm issue #4. Also, if I have multiple content types in the same library and select, let say, 2 documents with different content types that have a common attribute, if I only update the common attribute value, the content type of the first selected document will be applied to the other ones… Very bad. This was not happening before. Another update not being tested by Microsoft… and making loose time and money to their customer….


@Wee Teck Tan 

Experimenting with Sharepoint properties/meta data and, if it worked smoothly, it would be the answer to many problems, but I see the same 4 issues and this makes it almost unusable


Can someone at Microsoft feedback - am I doing something wrong or does the application have bugs?



Please fix this, its annoying. Bulk edit fails to update all files sometimes, sometimes only updating a handful of files... other times no metadata updates.




Actually I did stumble on a partial fix...

...I was using Chrome and switched to Edge - for editing properties it seems more predictable. I als found that being patient for bulk changes (eg 30 files/property changes) and avoiding really big edits (eg >100 files) gets to something like 95% success and just about useable. I still get the 5% where bulk edit properties just do not 'take', even if I hit save again. I have that the best thing is to keep the edits to <1 page full and check he page afterwards...

...but Microsoft, please would you fix this, it is just frustrating. I am amazed that this software passed quality control.