Unable to use new-pnpsite

Silver Contributor

I have been using this cmdlet for a few weeks and it worked fine. I updated the SharePointPnPPowerShellOnline module to 2.21.1712.1 and now I'm getting the following error. 


Can anyone tell me how to fix this?


New-PnPSite : Could not load file or assembly 'System.IdentityModel.Tokens.Jwt, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
At line:1 char:1
+ New-PnPSite -Type TeamSite -Title aco-bcp -Alias aco-bcp
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : WriteError: (:) [New-PnPSite], FileNotFoundException
+ FullyQualifiedErrorId : EXCEPTION,SharePointPnP.PowerShell.Commands.NewSite


@Erwin van Hunen

5 Replies
For now revert to the previous version while we investigate this.
thanks I have done that and it is working again. Good luck finding the problem.
Should I have opened an issue in GitHub for this?

Same error same call for 3.0.1808.0. I had to roll back and it worked.

We found the issue and we're currently working on a 3.0.1808.1 release.

We release 3.0.1808.1 now which fixes the issue. Please try again with the latest version.