Unable to install Microsoft Graph API

%3CLINGO-SUB%20id%3D%22lingo-sub-1388066%22%20slang%3D%22en-US%22%3EUnable%20to%20install%20Microsoft%20Graph%20API%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1388066%22%20slang%3D%22en-US%22%3E%3CP%3EI%20tried%20to%20run%20the%20command%26nbsp%3B%20in%20poweshell%20for%20SPFx%3A%3C%2FP%3E%3CP%3Enpm%20install%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41501%22%20target%3D%22_blank%22%3E%40microsoft%3C%2FA%3E%2Fmicrosoft-graph-types%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23FF0000%22%3Enpm%20WARN%20optional%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20fsevents%401.2.13%20(node_modules%5Cfsevents)%3A%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF0000%22%3Enpm%20WARN%20notsup%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20Unsupported%20platform%20for%20fsevents%401.2.13%3A%20wanted%20%7B%22os%22%3A%22darwin%22%2C%22arch%22%3A%22any%22%7D%20(current%3A%20%7B%22os%22%3A%22win32%22%2C%22arch%22%3A%22x64%22%7D)%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23FF0000%22%3E%2B%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41501%22%20target%3D%22_blank%22%3E%40microsoft%3C%2FA%3E%2Fmicrosoft-graph-types%401.12.0%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF0000%22%3Eremoved%2011%20packages%2C%20updated%201%20package%20and%20audited%201858%20packages%20in%2032.15s%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF0000%22%3Efound%202718%20vulnerabilities%20(2291%20low%2C%2034%20moderate%2C%20386%20high%2C%207%20critical)%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20color%3D%22%23FF0000%22%3Erun%20%60npm%20audit%20fix%60%20to%20fix%20them%2C%20or%20%60npm%20audit%60%20for%20details%3C%2FFONT%3E%3C%2FP%3E%3CP%3EBelow%20are%20the%20versions%20in%20my%20system%3A%3C%2FP%3E%3CP%3E%2B--%20%40angular%2Fcli%406.1.1%3CBR%20%2F%3E%2B--%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41501%22%20target%3D%22_blank%22%3E%40microsoft%3C%2FA%3E%2Fgenerator-sharepoint%401.9.1%3CBR%20%2F%3E%2B--%20gulp%404.0.2%3CBR%20%2F%3E%2B--%20install%400.13.0%3CBR%20%2F%3E%2B--%20json-server%400.14.0%3CBR%20%2F%3E%2B--%20minimatch%403.0.2%3CBR%20%2F%3E%2B--%20npm%406.12.0%3CBR%20%2F%3E%2B--%20typescript%402.9.2%3CBR%20%2F%3E%60--%20yo%403.1.0%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I tried to run the command  in poweshell for SPFx:

npm install @microsoft/microsoft-graph-types

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ @microsoft/microsoft-graph-types@1.12.0
removed 11 packages, updated 1 package and audited 1858 packages in 32.15s
found 2718 vulnerabilities (2291 low, 34 moderate, 386 high, 7 critical)
run `npm audit fix` to fix them, or `npm audit` for details

Below are the versions in my system:

+-- @angular/cli@6.1.1
+-- @microsoft/generator-sharepoint@1.9.1
+-- gulp@4.0.2
+-- install@0.13.0
+-- json-server@0.14.0
+-- minimatch@3.0.2
+-- npm@6.12.0
+-- typescript@2.9.2
`-- yo@3.1.0

0 Replies