Unable to disable NoScript on new communication sites

New Contributor

As of yesterday, I noticed that new communication sites I created had NoScript enabled by default. This was not the case a few weeks ago when I wrote this post:

 

https://dannyjessee.com/blog/index.php/2017/07/sharepoint-online-modern-team-sites-are-noscript-site...

 

Furthermore, I was not able to disable NoScript on new communication sites by running this cmdlet, the way I would disable NoScript on a modern team site:

 

Set-SPOSite https://djsp.sharepoint.com/sites/comm -DenyAddAndCustomizePages 0

 

I confirmed this cmdlet still works for newly created modern team sites, but on communication sites I get the following error:

 

Set-SPOSite : SPOTenantSiteCollectionProvider::SetSiteProperties - Site https://djsp.sharepoint.com/sites/comm not found in Grid, but TAPS_Sites_UseSharePoint flight in ONReverting to GM-based set-sposite (old) behavior for now
At line:1 char:1
+ Set-SPOSite https://djsp.sharepoint.com/sites/comm -DenyAddAndCustomi ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Set-SPOSite], ServerException
+ FullyQualifiedErrorId : Microsoft.SharePoint.Client.ServerException,Microsoft.Online.SharePoint.PowerShell.SetSite

 

Thanks in advance for any insight you can provide!

8 Replies

I got the same issue when running this command: https://techcommunity.microsoft.com/t5/SharePoint/Error-when-running-Set-SPOSite-for-new-Community-s...


In general Set-SPOSite doesn't seem to work with the new Communication site.

 

In another thread on the Tech Community I saw an Microsoft employee was investigating this behaviour:
https://techcommunity.microsoft.com/t5/SharePoint/Anonymous-Sharing-not-working-with-Communication-s...

 

Thanks for shedding some light on this! It definitely appears to be a larger issue than the singular problem I had encountered. Will keep an eye on those other threads as well. Thanks again!

I am also keeping an eye on those threads. So I will post an update if I come across a solution.

Thanks Danny, good to hear they have created a fix.

Still having this issue with Communication sites, did some of you saw it rolled out? 

@Sebastien Gagne, just tried the Set-SPOSite cmdlet with version 16.0.7723.0 of SharePoint Online Management Shell and I am not getting an error anymore when using the -DenyAddAndCustomizePages parameter. So it should be fixed now.

 

Have you tried downloading the latest SharePoint PowerShell module?
https://www.microsoft.com/en-us/download/details.aspx?id=35588

This seems to have done it :) thanks for the quick reply Dennis!

I know it's not related but I havent found a way to enable the possibility to have Planner Web Part into a Communication site. Do you know a work around?