.sppkg file deployment error in app catalog

%3CLINGO-SUB%20id%3D%22lingo-sub-314372%22%20slang%3D%22en-US%22%3E.sppkg%20file%20deployment%20error%20in%20app%20catalog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-314372%22%20slang%3D%22en-US%22%3EFacing%20%22Deployment%20failed.%20Correlation%20ID%3A%20%22%20while%20deploying%20.sppkg%20file%20in%20appcatalog.%20It%20was%20successful%20for%201st%20deployment.%20The%20same%20file%20is%20successfully%20deployed%20on%20other%20tenent.%20Please%20help.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-314692%22%20slang%3D%22en-US%22%3ERe%3A%20.sppkg%20file%20deployment%20error%20in%20app%20catalog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-314692%22%20slang%3D%22en-US%22%3E%3CP%3EAre%20your%20permissions%20the%20same%20on%20both%20tenants%3F%20Is%20it%20possible%20you%20don't%20have%20permissions%20to%20deploy%20the%20sppkg%20file%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-766156%22%20slang%3D%22en-US%22%3ERe%3A%20.sppkg%20file%20deployment%20error%20in%20app%20catalog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-766156%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20getting%20the%20same%20error%20when%20deploying%20the%20package%20to%20the%20app%20catalog.%20I'm%20using%20the%20HelloWorld-Webpart%20sample%20from%20Microsoft.%20I'm%20logged%20in%20as%20a%20global%20admin%20to%20a%20developer%20tenant.%20I've%20been%20able%20to%20deploy%20the%20package%20to%20our%20production%20tenant.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-766706%22%20slang%3D%22en-US%22%3ERe%3A%20.sppkg%20file%20deployment%20error%20in%20app%20catalog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-766706%22%20slang%3D%22en-US%22%3E%3CP%3EOK%2C%20I%20found%20a%20fix%20that%20has%20worked%20for%20me.%20I%20needed%20to%20add%20the%20account%20as%20a%20Site%20Collection%20administrator%20to%20the%20app%20catalog%20site%20collection.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20using%20a%20global%20admin%20account%2C%20but%20the%20deployments%20still%20failed%20until%20I%20updated%20the%20site%20collection%20administrators%20for%20the%20app%20catalog%20site%20collection%20via%20the%20SharePoint%20Admin%20site.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-766710%22%20slang%3D%22en-US%22%3ERe%3A%20.sppkg%20file%20deployment%20error%20in%20app%20catalog%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-766710%22%20slang%3D%22en-US%22%3E%3CP%3EOK%2C%20I%20found%20a%20fix%20that%20has%20worked%20for%20me.%20I%20needed%20to%20add%20the%20account%20as%20a%20Site%20Collection%20administrator%20to%20the%20app%20catalog%20site%20collection.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20using%20a%20global%20admin%20account%2C%20but%20the%20deployments%20still%20failed%20until%20I%20updated%20the%20site%20collection%20administrators%20for%20the%20app%20catalog%20site%20collection%20via%20the%20SharePoint%20Admin%20site.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor
Facing "Deployment failed. Correlation ID: " while deploying .sppkg file in appcatalog. It was successful for 1st deployment. The same file is successfully deployed on other tenent. Please help.
4 Replies
Highlighted

Are your permissions the same on both tenants? Is it possible you don't have permissions to deploy the sppkg file?

Highlighted

I'm getting the same error when deploying the package to the app catalog. I'm using the HelloWorld-Webpart sample from Microsoft. I'm logged in as a global admin to a developer tenant. I've been able to deploy the package to our production tenant.

Highlighted

OK, I found a fix that has worked for me. I needed to add the account as a Site Collection administrator to the app catalog site collection.

 

I was using a global admin account, but the deployments still failed until I updated the site collection administrators for the app catalog site collection via the SharePoint Admin site.

Highlighted

OK, I found a fix that has worked for me. I needed to add the account as a Site Collection administrator to the app catalog site collection.

 

I was using a global admin account, but the deployments still failed until I updated the site collection administrators for the app catalog site collection via the SharePoint Admin site.