Home

SPO list jumps to top when loading new items

%3CLINGO-SUB%20id%3D%22lingo-sub-701750%22%20slang%3D%22en-US%22%3ESPO%20list%20jumps%20to%20top%20when%20loading%20new%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-701750%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20seeing%20an%20issue%20with%20an%20SPO%20list%2C%20where%20the%20page%20jumps%20back%20to%20the%20top%20when%20attempting%20to%20scroll%20down.%20You%20can%20see%20a%20video%20of%20what%20occurs%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D_lx30TvRfqs%26amp%3Bfeature%3Dyoutu.be%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3D_lx30TvRfqs%26amp%3Bfeature%3Dyoutu.be%3C%2FA%3E%26nbsp%3B%3CSPAN%3E(note%20in%20this%20video%2C%20I%20have%20only%20scrolled%20down).%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20replicated%20this%20issue%20across%20multiple%20browsers%20(chrome%2C%20IE%20and%20Edge)%20on%20several%20machines.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%20only%20seems%20to%20occur%20after%20the%20list%20reaches%20a%20certain%20length.%20I%20am%20using%20custom%20JSON%20view%20formatting%2C%20the%20code%20for%20which%20can%20be%20seen%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fpastebin.com%2F8VYtvFiD%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehere%3C%2FA%3E.%20Though%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fall%2Flist-page-in-sharepoint-keeps-jumping-to-the-top%2Fa493ecaf-676b-4bf9-8877-c80a8d1834f8%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eanother%20user%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Eappears%20to%20have%20run%20into%20the%20same%20issue%2C%20and%20did%20not%20mention%20using%20view%20formatting.%20If%20I%20alter%20my%20formatting%20to%20be%20more%20dense%20(to%20show%20more%20items%20per%20line%2C%20thus%20reducing%20the%20height%20of%20the%20page)%2C%20the%20issue%20does%20not%20occur.%20The%20issue%20also%20does%20not%20occur%20in%20folders%20with%20fewer%20items.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20you%20can%20see%20from%20the%20video%2C%20the%20problem%20happens%20as%20the%20page%20reaches%20the%20bottom%20of%20the%20currently%20loaded%20items.%20Hence%20why%20reducing%20the%20number%20of%20items%20or%20fitting%20more%20onto%20the%20screen%20prevents%20the%20issue%20(as%20all%20the%20items%20are%20loaded%20with%20the%20page).%20However%20this%20is%20not%20a%20solution%20as%20we%20require%20more%20than%20the%20~50%20items%20we%20can%20currently%20show%2C%20before%20the%20bug%20appears.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22%22%3E%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fmsoffice_sharepoint-mso_winother-mso_o365b%2Fsharepoint-online-list-jumps-to-top-when-scrolling%2Fd8d47c77-7115-418a-91b3-f98e56943b3b%3FmessageId%3Dc3649023-1a80-4a66-8c06-02a1dd08042f%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EI%20have%20posted%3C%2FA%3E%20this%20to%20MS%20Answers%2C%20and%20an%20MS%20agent%20directed%20me%20here.%20He%20seemed%20to%20think%20the%20issue%20was%20related%20to%20my%20JSON%20code.%3C%2FP%3E%3CDIV%20class%3D%22AnswersExternalContent%22%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-701750%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EJson%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Elist%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1019699%22%20slang%3D%22en-US%22%3ERe%3A%20SPO%20list%20jumps%20to%20top%20when%20loading%20new%20items%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1019699%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362533%22%20target%3D%22_blank%22%3E%40ABehrens%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20confirm.%20Happens%20also%20with%20the%20samples%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F194%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-list-formatting%2Fissues%2F194%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoesn't%20happen%20when%20using%20tileProps%2C%20but%20for%20using%20the%20Tiles%20view%20the%20use%20has%20to%20manually%20switch%20to%20the%20Tiles.%20See%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fsharepoint.uservoice.com%2Fforums%2F329214-sites-and-collaboration%2Fsuggestions%2F17365024-ability-to-set-tile-or-list-as-a-default-view%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsharepoint.uservoice.com%2Fforums%2F329214-sites-and-collaboration%2Fsuggestions%2F17365024-ability-to-set-tile-or-list-as-a-default-view%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

I am seeing an issue with an SPO list, where the page jumps back to the top when attempting to scroll down. You can see a video of what occurs here: https://www.youtube.com/watch?v=_lx30TvRfqs&feature=youtu.be (note in this video, I have only scrolled down).

 

I have replicated this issue across multiple browsers (chrome, IE and Edge) on several machines. 

 

The issue only seems to occur after the list reaches a certain length. I am using custom JSON view formatting, the code for which can be seen here. Though another user appears to have run into the same issue, and did not mention using view formatting. If I alter my formatting to be more dense (to show more items per line, thus reducing the height of the page), the issue does not occur. The issue also does not occur in folders with fewer items.

 

As you can see from the video, the problem happens as the page reaches the bottom of the currently loaded items. Hence why reducing the number of items or fitting more onto the screen prevents the issue (as all the items are loaded with the page). However this is not a solution as we require more than the ~50 items we can currently show, before the bug appears.

 

I have posted this to MS Answers, and an MS agent directed me here. He seemed to think the issue was related to my JSON code.

 
1 Reply
Highlighted

@ABehrens 

 

Can confirm. Happens also with the samples; https://github.com/SharePoint/sp-dev-list-formatting/issues/194

 

Doesn't happen when using tileProps, but for using the Tiles view the use has to manually switch to the Tiles. See: https://sharepoint.uservoice.com/forums/329214-sites-and-collaboration/suggestions/17365024-ability-...