SPFx on a Team Site Homepage Cannot Get Taxonomy Data

%3CLINGO-SUB%20id%3D%22lingo-sub-199637%22%20slang%3D%22en-US%22%3ESPFx%20on%20a%20Team%20Site%20Homepage%20Cannot%20Get%20Taxonomy%20Data%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-199637%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20have%20an%20SPFx%20webpart%20and%20an%20SPFx%20extensions%20that%20getting%20data%20from%20Taxonomy%20Term%20Store.%3C%2FP%3E%3CP%3EBoth%20of%20them%20are%20working%20well%20on%20all%20pages%20(Site%20Content%20page%2C%20Library%20page%2C%20Site%20page%2C%20etc.)%20%3CSTRONG%3Eexcept%20%3C%2FSTRONG%3Eon%20a%20%3CSTRONG%3ETeam%20Site%20Homepage%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20several%20approaches%20to%20get%20the%20Taxonomy%20data%20in%20the%20SPFx%20code%3A%3C%2FP%3E%3CUL%3E%3CLI%3EAdd%20the%20references%20to%20the%20SharePoint%20JSOM%20in%20the%20config.json%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fweb-parts%2Fbasics%2Fadd-an-external-library%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fweb-parts%2Fbasics%2Fadd-an-external-library%3C%2FA%3E)%3C%2FLI%3E%3CLI%3ELoad%20SharePoint%20JSOM%20in%20the%20code%20(following%20example%20from%20Microsoft's%20repo%3A%20%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-fx-webparts%2Fblob%2Fdev%2Fsamples%2Fknockout-taxonomy%2Fsrc%2Fwebparts%2FtermSetRequester%2Fdata-helpers%2FDataHelperSP.ts%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2Fsp-dev-fx-webparts%2Fblob%2Fdev%2Fsamples%2Fknockout-taxonomy%2Fsrc%2Fwebparts%2FtermSetRequester%2Fdata-helpers%2FDataHelperSP.ts%3C%2FA%3E%2C%20even%20the%20webpart%20example%20doesn't%20work%20on%20a%20Team%20Site%20Homepage)%3C%2FLI%3E%3C%2FUL%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBoth%20of%20them%20couldn't%20get%20taxonomy%20data%20on%20a%20Team%20Site%20homepage.%3C%2FP%3E%3CP%3EIt's%20failed%20on%20context.executeQueryAsync(...).%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F35204i9D064DF3CB8803CD%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222018-05-31%2022_40_10-Developer%20Tools%20-%20https___devlopment365.sharepoint.com_sites_TestNav3.png%22%20title%3D%222018-05-31%2022_40_10-Developer%20Tools%20-%20https___devlopment365.sharepoint.com_sites_TestNav3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20anyone%20that%20has%20done%20this%20before%3F%20Or%20has%20any%20workaround%20idea%20for%20this%20situation%3F%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-199637%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExtension%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EJSOM%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESPFx%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETaxonomy%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeam%20Site%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWebPart%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

Hi,

I have an SPFx webpart and an SPFx extensions that getting data from Taxonomy Term Store.

Both of them are working well on all pages (Site Content page, Library page, Site page, etc.) except on a Team Site Homepage.

 

I've tried several approaches to get the Taxonomy data in the SPFx code:

 

Both of them couldn't get taxonomy data on a Team Site homepage.

It's failed on context.executeQueryAsync(...).

2018-05-31 22_40_10-Developer Tools - https___devlopment365.sharepoint.com_sites_TestNav3.png

 

Is there anyone that has done this before? Or has any workaround idea for this situation?

Thanks

 

0 Replies