SpFx Helloworld webpart does not show up under modern Page toolbox

Copper Contributor

Expected or Desired Behavior

Upon installation of the app, i can add the webpart to the pages as well

Observed Behavior

After adding app ,i try to add the app to my page, the app is not showing up in the list of the available apps.

Steps to reproduce

Follow the steps mention in https://docs.microsoft.com/en-us/sharepoint/dev/spfx/web-parts/get-started/build-a-hello-world-web-p... and created simple helloworld web part

Add the .sppkg file in appcatalog and add the app in site

Expected behavior

After adding app in site, I should able to add the web part on page.

Environment details

I have two tenants, on test tenant I don't face any issue it is working perfectly fine. But on Production tenant I am facing this issue

  • Your Developer Environment: - Windows 10
  • Target Environment: SharePoint Online
  • Framework: Node.js v10
  • Browser(s): Chrome v79
  • Tooling: VS Code

Additional context

I am trying to add Modern Script Editor web part from this blog but I cant add it on production as I can not see it in web part list after deployment,so I am trying to deploy the simple Helloworld WebPart but I cannot see it as well in web part list on Production Tenant. On Test tenant everything is working fine.
Note : I have admin account with admin access. In Past I have deployed SPFX Extension and it worked very well

Thanks for your contribution! Sharing is caring.

5 Replies

@KanchanKumbhar Have you selected the Make this solution available to all sites in the organization checkbox while uploading your solution to app catalog?


If No, then first you need to install the App from Site Contents and then try to add webpart to SharePoint page.

Please click Mark as Best Response if my post helped you solve your issue. This will help others find the correct solution easily. It also closes the item. If the content was useful in other ways, please consider giving it Like.


Yes @ganeshsanap I have make this solution available to all sites in the organization, but still not available

@KanchanKumbhar :Just one update I can see the web part in web part list on classic site.It is not visible on Modern Page toolbox

Hi @KanchanKumbhar - i have been tries same thing implementing CEditor webpart using SPFX & @pnp, locally working find while debugging but after deployment process. the webpart does not appear in my modern team site toolbox. Any though?

@BrajendraRathour ,

I was also facing this issue, followed below steps & resolved issue. Might be it will helpful.

Removed your existing package from tenant catalog or app catalog.
Delete the same SPFx package from Site Collection level (first and second) recycle bin.
Re-deploy the package and it start appearing to all site collection as well as to pages.