SPFx App Deployed to On Prem SP 2016 (Feature Pack 2) but not visible when adding to pages

%3CLINGO-SUB%20id%3D%22lingo-sub-118521%22%20slang%3D%22en-US%22%3ESPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-118521%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20followed%20the%20videos%20to%20create%20the%20hello-world%20SharePoint%20Framework%20app%20using%20NPM%2C%20YO%2C%20Gulp%2C%20etc%2C%20and%20have%20successfully%20uploaded%20the%20solution%20to%20our%20app%20catalog.%26nbsp%3B%20The%20property%20fields%20show%20it%20is%20enabled%20and%20deployed%20in%20the%20catalog.%26nbsp%3B%20However%2C%20when%20I%20try%20and%20add%20an%20app%20from%20anywhere%20(same%20site%2C%20subsites)%2C%20the%20app%20is%20not%20listed%20anywhere%20(the%20out-of-the%20box%20apps%20are%20listed).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThings%20to%20note%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20running%20on%20premise%20SharePoint%202016%20Feature%20Pack%202%3C%2FP%3E%3CP%3EWe%20don't%20have%20a%20dedicate%20app%20store%2C%20but%20did%20create%20an%20app%20catalog%20where%20our%20SPFx%20solution%20was%20deployed%20to%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20will%20be%20greatly%20appreciated%20as%20we%20want%20to%20rely%20on%20SPFx%20to%20port%20our%20intranet%20to%20SharePoint.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20so%20much%3C%2FP%3E%3CP%3EFrederik%20K.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-313979%22%20slang%3D%22en-US%22%3ERe%3A%20SPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-313979%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20heard%20that%20sometimes%20the%20app%20will%20not%20show%20up%2C%20if%20you%20don't%20have%20appropriate%20language%20packs%20installed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-310135%22%20slang%3D%22en-US%22%3ERe%3A%20SPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-310135%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%2C%26nbsp%3B%3C%2FP%3E%3CP%3ERecently%20we%20have%20updated%20with%20Dec%202018%20Cu%20Updates%2C%20but%20still%20i%20am%20facing%20same%20issue%20not%20able%20to%20see%20the%20webpart%20in%20%22Add%20an%20App%22%20page.%26nbsp%3B%20the%20same%20i%20have%20posted%20in%20(%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2F4fe9c678-908b-4668-99f1-41877161d42a%2Fsharepoint2016-on-prem-spfx-helloworld-app-deployed-to-app-catalog-but-not-appearing-under-apps%3Fforum%3DSP2016%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2F4fe9c678-908b-4668-99f1-41877161d42a%2Fsharepoint2016-on-prem-spfx-helloworld-app-deployed-to-app-catalog-but-not-appearing-under-apps%3Fforum%3DSP2016%3C%2FA%3E)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20share%20if%20you%20have%20any%20updates%20on%20this%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-135636%22%20slang%3D%22en-US%22%3ERe%3A%20SPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-135636%22%20slang%3D%22en-US%22%3EHello%2C%3CBR%20%2F%3ECheck%20your%20SP%20logs.%20You%20might%20see%20this%20exception%3A%3CBR%20%2F%3EAn%20exception%20was%20thrown%20while%20retrieving%20Apps%20from%20Corporate%20Catalog.%20Microsoft.SharePoint.SPException%3A%20One%20or%20more%20field%20types%20are%20not%20installed%20properly.%20Go%20to%20the%20list%20settings%20page%20to%20delete%20these%20fields.%20---%26gt%3B%20System.Runtime.InteropServices.COMException%3A%20One%20or%20more%20field%20types%20are%20not%20installed%20properly.%20Go%20to%20the%20list%20settings%20page%20to%20delete%20these%20fields.%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20this%20is%20the%20case%20then%20this%20issue%20is%20similar%20to%20SharePoint%2Fsp-dev-docs%231016%3CBR%20%2F%3E%3CBR%20%2F%3EAnd%20you%20should%20then%20apply%20the%20language%20dependent%20fix%20as%20well.%3CBR%20%2F%3ERead%20%3CA%20href%3D%22https%3A%2F%2Fblogs.technet.microsoft.com%2Fstefan_gossner%2F2017%2F11%2F14%2Fnovember-2017-cu-for-sharepoint-server-2016-is-available-for-download%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fblogs.technet.microsoft.com%2Fstefan_gossner%2F2017%2F11%2F14%2Fnovember-2017-cu-for-sharepoint-server-2016-is-available-for-download%2F%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20short%2C%20install%20the%20language%20%22dependent%22%20update%20that%20comes%20with%20the%20CU%2C%20then%20delete%20the%20App%20Catalog%2C%20create%20the%20App%20Catalog%20again%2C%20upload%20your%20app%2C%20give%20permissions%20on%20the%20app%20catalog%20to%20the%20user%20who%20is%20adding%20the%20app.%20And%20then%20finally%20you%20will%20see%20your%20spfx%20app%20in%20%22Add%20an%20app%22%20section.%3CBR%20%2F%3E%3CBR%20%2F%3EBye%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-121178%22%20slang%3D%22en-US%22%3ERe%3A%20SPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-121178%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20glad%20I%20am%20not%20alone%20with%20this%20problem%3A)%3C%2FP%3E%3CP%3EI%20did%20read%20somewhere%20that%20I%20need%20to%20set%20up%20an%20app%20store%20(in%20addition%20to%20the%20app%20catalog)%26nbsp%3Bto%20be%20able%20to%20use%20SPFx%20apps.%26nbsp%3B%20I%20am%20not%20sure%20if%20that%20will%20fix%20the%20issue%20but%20I%20am%20going%20to%20give%20that%20a%20try.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-120672%22%20slang%3D%22en-US%22%3ERe%3A%20SPFx%20App%20Deployed%20to%20On%20Prem%20SP%202016%20(Feature%20Pack%202)%20but%20not%20visible%20when%20adding%20to%20pages%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-120672%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20tried%20same%20steps%20and%20could%20not%20find%20webpart%20in%20either%20add%20an%20app%20page%20or%20in%20web%20part%20gallery.%20Published%20components%20manually%20to%20Document%20library%20as%20well%20after%20modifying%20the%20CDN%20path%20but%20no%20results.%20Hope%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F41501%22%20target%3D%22_blank%22%3E%40microsoft%3C%2FA%3E%26nbsp%3Breleases%20fix%20for%20this%20in%20next%20upgrade%20patch.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I have followed the videos to create the hello-world SharePoint Framework app using NPM, YO, Gulp, etc, and have successfully uploaded the solution to our app catalog.  The property fields show it is enabled and deployed in the catalog.  However, when I try and add an app from anywhere (same site, subsites), the app is not listed anywhere (the out-of-the box apps are listed).

 

Things to note:

 

We are running on premise SharePoint 2016 Feature Pack 2

We don't have a dedicate app store, but did create an app catalog where our SPFx solution was deployed to

 

Any help will be greatly appreciated as we want to rely on SPFx to port our intranet to SharePoint.

 

Thank you so much

Frederik K.

5 Replies
Highlighted

I have tried same steps and could not find webpart in either add an app page or in web part gallery. Published components manually to Document library as well after modifying the CDN path but no results. Hope @microsoft releases fix for this in next upgrade patch.

Highlighted

I am glad I am not alone with this problem:)

I did read somewhere that I need to set up an app store (in addition to the app catalog) to be able to use SPFx apps.  I am not sure if that will fix the issue but I am going to give that a try.

Highlighted
Hello,
Check your SP logs. You might see this exception:
An exception was thrown while retrieving Apps from Corporate Catalog. Microsoft.SharePoint.SPException: One or more field types are not installed properly. Go to the list settings page to delete these fields. ---> System.Runtime.InteropServices.COMException: One or more field types are not installed properly. Go to the list settings page to delete these fields.

If this is the case then this issue is similar to SharePoint/sp-dev-docs#1016

And you should then apply the language dependent fix as well.
Read https://blogs.technet.microsoft.com/stefan_gossner/2017/11/14/november-2017-cu-for-sharepoint-server...

In short, install the language "dependent" update that comes with the CU, then delete the App Catalog, create the App Catalog again, upload your app, give permissions on the app catalog to the user who is adding the app. And then finally you will see your spfx app in "Add an app" section.

Bye
Highlighted

Hi , 

Recently we have updated with Dec 2018 Cu Updates, but still i am facing same issue not able to see the webpart in "Add an App" page.  the same i have posted in (https://social.technet.microsoft.com/Forums/en-US/4fe9c678-908b-4668-99f1-41877161d42a/sharepoint201...)

 

Please share if you have any updates on this issue.

Highlighted

I've heard that sometimes the app will not show up, if you don't have appropriate language packs installed.