SiteScripts - setRegionalSettings - action failed

%3CLINGO-SUB%20id%3D%22lingo-sub-298651%22%20slang%3D%22en-US%22%3ESiteScripts%20-%20setRegionalSettings%20-%20action%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298651%22%20slang%3D%22en-US%22%3E%3CP%3EHello!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20created%20SiteTemplate%20with%20SiteScript%20and%20everything%20works%20well%20except%20%22setRegionalSettings%22.%20I%20just%20cannot%20get%20it%20to%20work%20with%20my%20locale%20settings.%20Sometimes%20it%20works%20but%20most%20of%20the%20time%20it%20doesn't%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20my%20settings%20are%3C%2FP%3E%3CP%3E%7B%3CBR%20%2F%3E%22verb%22%3A%20%22setRegionalSettings%22%2C%3CBR%20%2F%3E%22timeZone%22%3A%206%2C%20%2F*%20UTC%20%2B%201%20*%2F%3CBR%20%2F%3E%22locale%22%3A%201060%2C%20%2F*%20Slovenian%20*%2F%3CBR%20%2F%3E%22sortOrder%22%3A%2034%2C%20%2F*%20Slovenian%20*%2F%3CBR%20%2F%3E%22hourFormat%22%3A%20%2224%22%3CBR%20%2F%3E%7D%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20any%20log%20of%20errors%20to%20debug%20errors%20with%20SiteScripts%3F%20It%20just%20shows%20%22Action%20Failed%22.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-298651%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESiteDesign%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESiteScript%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298791%22%20slang%3D%22en-US%22%3ERe%3A%20SiteScripts%20-%20setRegionalSettings%20-%20action%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298791%22%20slang%3D%22en-US%22%3EUnfortunately%20there%20is%20not%20a%20way%20to%20debug%20your%20site%20scripts...if%20they%20are%20well%20formed%2C%20then%20you%20can%20only%20apply%20to%20your%20sites.%20There%20are%20tools%20that%20can%20help%20here%20such%20as%3A%20%3CA%20href%3D%22https%3A%2F%2Fwww.sitedesigner.io%2F%23%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.sitedesigner.io%2F%23%2F%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298686%22%20slang%3D%22en-US%22%3ERe%3A%20SiteScripts%20-%20setRegionalSettings%20-%20action%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298686%22%20slang%3D%22en-US%22%3EHi%2C%20I%20did%20and%20it%20works%20for%20the%20provided%20example%20(Croatian)%20but%20also%20there%20are%20some%20problems%20time%20to%20time...I%20will%20create%20an%20issue%20on%20github%20also.%20Thx!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298656%22%20slang%3D%22en-US%22%3ERe%3A%20SiteScripts%20-%20setRegionalSettings%20-%20action%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298656%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Did%20you%20also%20try%20with%20the%20default%2Fother%20timezones%3F%3C%2FP%3E%0A%3CP%3EIf%20so%20i%20would%20suggest%20to%20create%20a%20github%20issue%20%3CA%20href%3D%22https%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-Sites-Core%2Fissues%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgithub.com%2FSharePoint%2FPnP-Sites-Core%2Fissues%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hello!

 

I created SiteTemplate with SiteScript and everything works well except "setRegionalSettings". I just cannot get it to work with my locale settings. Sometimes it works but most of the time it doesn't

 

So my settings are

{
"verb": "setRegionalSettings",
"timeZone": 6, /* UTC + 1 */
"locale": 1060, /* Slovenian */
"sortOrder": 34, /* Slovenian */
"hourFormat": "24"
},

 

Is there any log of errors to debug errors with SiteScripts? It just shows "Action Failed".

3 Replies

Hi Did you also try with the default/other timezones?

If so i would suggest to create a github issue https://github.com/SharePoint/PnP-Sites-Core/issues

 

Hi, I did and it works for the provided example (Croatian) but also there are some problems time to time...I will create an issue on github also. Thx!
Unfortunately there is not a way to debug your site scripts...if they are well formed, then you can only apply to your sites. There are tools that can help here such as: https://www.sitedesigner.io/#/