ShowInDisplayForm Setting in Sharepoint Online

%3CLINGO-SUB%20id%3D%22lingo-sub-2106434%22%20slang%3D%22en-US%22%3EShowInDisplayForm%20Setting%20in%20Sharepoint%20Online%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2106434%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EHi%3CBR%20%2F%3E%3CBR%20%2F%3EMy%20client%20uses%20%3CSTRONG%3EHarmon.ie%3C%2FSTRONG%3E%20extensively%20to%20add%20files%20to%20SharePoint%20from%20their%20mailbox.%20But%20for%20some%20fields%2C%20the%20function%20%22view%20properties%22%20of%20harmon.ie%2C%20does%20not%20show%20any%20fields.%20The%20site%20we%20use%20to%20%22provisioned%22%20from%20a%20template%20site.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EI%20have%20checked%20this%20with%20Harmon.ie%20and%20the%20reason%20is%20because%20Harmon.ie%20takes%20into%20account%20the%20%3CSTRONG%3E%22ShowInDisplayForm%22%3C%2FSTRONG%3E%20properties%20of%20Sharepoint.%20And%20indeed%20I%20have%20found%20this%20property%20set%20to%20%22False%22%20in%20the%20SchemaXml%20of%20these%20fields.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20the%20UI%2C%20this%20property%20is%20not%20configurable%2C%20but%20I%20have%20tried%20setting%20it%20with%20powershell.%20You%20can%20find%20some%20code%20samples%20below.%20For%20some%20fields%2C%20setting%20the%20property%20will%20show%20them%20in%20harmon.ie.%20For%20some%20fields%20it%20automatically%20reverts%20back%20to%20false.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ECode%20snippets%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Ruben_Claeys_MG_0-1611845655084.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F250295i8B1118C37DC25C15%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Ruben_Claeys_MG_0-1611845655084.png%22%20alt%3D%22Ruben_Claeys_MG_0-1611845655084.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3E-%20Does%20anyone%20have%20an%20idea%20how%20to%20set%20the%20%22ShowInDisplayForm%22%20setting%20for%20all%20fields%20in%20a%20sharepoint%20site%3F%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3E%3CSPAN%3EKind%20regards%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ERuben%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi

My client uses Harmon.ie extensively to add files to SharePoint from their mailbox. But for some fields, the function "view properties" of harmon.ie, does not show any fields. The site we use to "provisioned" from a template site. 

I have checked this with Harmon.ie and the reason is because Harmon.ie takes into account the "ShowInDisplayForm" properties of Sharepoint. And indeed I have found this property set to "False" in the SchemaXml of these fields. 

In the UI, this property is not configurable, but I have tried setting it with powershell. You can find some code samples below. For some fields, setting the property will show them in harmon.ie. For some fields it automatically reverts back to false.

 

Code snippets:

Ruben_Claeys_MG_0-1611845655084.png

 

- Does anyone have an idea how to set the "ShowInDisplayForm" setting for all fields in a sharepoint site?

 

Thanks,

Kind regards,

Ruben

 

 

 

0 Replies