SharePoint Site Designs "Choose a design" dropdown not showing up




I have built a custom site design and deployed using as a reference the article at


I created a custom site script using as a reference the deployment steps in this post but was unable to make the “choose a design” dropdown available in my tenant.




If I run the following script, I can see my custom site design there.


$AdminCenterURL = “”

Connect-PnPOnline -URL $AdminCenterURL -UseWebLogin




The JSON file I used was:


  "actions": [
      "subactions": [
          "schemaXml""<Field ID=\"{08d89a66-4634-42b8-9d5a-0c27395a48b3}\" Type=\"Text\" Name=\"TriggerFlowInfo\" DisplayName=\"Trigger Flow Info\" DisplaceOnUpgrade=\"TRUE\" Hidden=\"TRUE\" ReadOnlyEnforced=\"TRUE\" Required=\"FALSE\" SourceID=\"\" StaticName=\"TriggerFlowInfo\" />"
          "name""All Documents",
          "viewFields": [
          "query""<OrderBy><FieldRef Name=\"FileLeafRef\" /></OrderBy>",
And the deploy script was:
$SharePointAdminURL = ""

$ClientId = ""
$ClientSecret = ""
$SiteScriptTitle = "Test Site"
$SiteDesignTitle = "Test Site"
$SiteScriptDescription = "Test Site Template"
$SiteDesignDescription = "Test Site Template"
$CurrentPath = Get-Location
Write-Host "CurrentPath: $CurrentPath"
$SiteScriptPath = "$CurrentPath\TestSite.json"
Write-Host "SiteScriptPath: $SiteScriptPath"
#$SiteScriptPath = "TestSite.json"
$SiteScripJsonContent = Get-Content $SiteScriptPath -Raw
Write-Host "SiteScripJsonContent: $SiteScripJsonContent"
#Connect to Tenant Admin
Connect-PnPOnline -URL $SharePointAdminURL -ClientId $ClientId -ClientSecret $ClientSecret

### Add Site Projecto Site Script
$sitescript = Add-PnPSiteScript -Title $SiteScriptTitle -Description $SiteScriptDescription -Content $SiteScripJsonContent
Add-PnPSiteDesign -Title $SiteDesignTitle -SiteScriptIds $sitescript.Id -Description $SiteDesignDescription -WebTemplate TeamSite
Why doesn't my custom site design gets available?
2 Replies
Site designs were removed from the Site creating flow. They can applied in the "Apply site design" option after the site is created.

All is good except for the PreviewImageURL. Any clue on setting the PreviewImageURL in the site design? Tried with different libraries (SiteAssets in the root site, Asset Library created by me in the root site), the ugly default image is being shown.
Hi Miguel,
I noticed the select site template dropdown missing too, is that confirmed that the "Apply site design" the only way to apply a site template now?