SharePoint Responsive

Not applicable

Good Day Everyone !!

   My client has requested for the responsive design to be applied in their project which is an On-Permise. And I tried using the Pnp Responsive package, but somehow i'm getting the below issue.


--> The Connect-PnpOnline was found in the module 'SharePointPnPPowershell2013', but the module could not be loaded. For more information, run 'Import-Module SharePointPnPPowershell2013'.


I have tried everything and still the above issue persists. Any of you have idea on how to correct this ? Or any other solutions ?


9 Replies
Seems an issue related with PnP PowerShell Module. Can you take a look to the path:
"C:\Program Files\WindowsPowerShell\Modules" and ensure you have the "SharePointPnPPowerShellOnline" folder and check the version folder inside?
If you're in Windows 10, I'd try to remove the "SharePointPnPPowerShellOnline" folder and re-install the module again:
Install-Module SharePointPnPPowerShellOnline

Hi Luis,

  Appreciate your response. I went through the path C:\Program Files\WindowsPowerShell\Modules and found 2 folders.

1. PackageManagement

2. PowerShellGet


And, the Install-Module SharePointPnPPowerShellOnline is for SharePoint O365 only right (Correct me if i'm wrong) ? I'm looking the solution for On-permise. Do you have any idea for On-Permise ? 

I'm getting the error mentioned in the image.

yeah, sorry, there's another module for SP20113 On Premises:
Install-Module SharePointPnPPowerShell2013

However, as you don't have that folder, I'm not sure if that's gonna help.
How did you install PnP PowerShell?? using the installer? I saw your error in the past, as was always related with PS modules, not PnP, and I fixed re-installing PnP PS...

After, getting the error, I used the command Install-Module SharePointPnPPowerShell2013. Installed the supporting files using PS and, i get the same problem after installing this.

The command Connect-PnPOnline seems to be mentioning the O365. Do you know the alternate keyword for On-Permise ? May be like Connect-PnpOnPermise kind of. I have also installed the SharePointPnPPowerShell2013.msi file(FYI). And then executed the .\Enable-SPResponsiveUI.ps1 -TargetSiteurl. Still the same error occurs.

Please take a look at this blog it may help you


i could not find a different way of connecting then you descripted

Thanks much Paul... I will go through the link you provided.
Hi Paul,
i somehow installed the required files. And, i'm able to use the Connect-PnPOnline now.
Also, i have deployed the package in my local site (On-Perm). But, I'm facing another issue now which shows "Cannot make a cache safe URL for "/style library/sp.responsive.ui/sp-responsive-ui.js", file not found. Please verify that the file exists under the layouts directory."

Any idea on this ?

It seems you have a xml reference to a file locally which does not exists are you sure the path is the same and the file is there?

Yes. When i copy and paste the url "http://hvsp10/sites/mysimplesite/style library/sp.responsive.ui/sp-responsive-ui.js" im able to download the js file. Also, i have the xml file placed in the same folder. Please refer the image.