SharePoint Online - List's custom Ribbon Button does not work after search in Google Chrome

%3CLINGO-SUB%20id%3D%22lingo-sub-1602948%22%20slang%3D%22en-US%22%3ESharePoint%20Online%20-%20List's%20custom%20Ribbon%20Button%20does%20not%20work%20after%20search%20in%20Google%20Chrome%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1602948%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20Provider-Hosted%20SharePoint%20Add-In%20deployed%20to%20SharePoint%20online%20by%20using%20the%20organization's%20add-in%20catalog%20(App%20Catalog).%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20Add-In%20(SharePoint%20app)%20contain%20a%20few%20custom%20ribbon%20buttons%20in%20SharePoint%20list.%20If%20user%20didn't%20search%20anything%20from%20the%20list%2C%20this%20ribbon%20button%20will%20work.%20However%2C%20once%20user%20searched%20keywords%20in%20the%20list%20and%20get%20the%20correct%20result%2C%20the%20ribbon%20button%20will%20not%20response.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20noticed%20there%20is%20%22blocked%3Acsp%22%20error%20from%20Google%20Chrome's%20Dev%20tools.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20error%20only%20happen%20in%20Google%20Chrome%2C%20new%20EDGE%20(chromium)%20but%20it%20is%20working%20for%20Internet%20Explorer%20and%20classic%20EDGE%20browser.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20solution%20that%20we%20can%20modify%20%26lt%3Bmeta%20%2F%26gt%3B%20in%20SharePoint%20online%20master%20page%3F%3C%2FP%3E%3CP%3ELink%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdeveloper.mozilla.org%2Fen-US%2Fdocs%2FWeb%2FHTTP%2FCSP%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdeveloper.mozilla.org%2Fen-US%2Fdocs%2FWeb%2FHTTP%2FCSP%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

We have a Provider-Hosted SharePoint Add-In deployed to SharePoint online by using the organization's add-in catalog (App Catalog). 

 

This Add-In (SharePoint app) contain a few custom ribbon buttons in SharePoint list. If user didn't search anything from the list, this ribbon button will work. However, once user searched keywords in the list and get the correct result, the ribbon button will not response. 

 

We noticed there is "blocked:csp" error from Google Chrome's Dev tools. 

 

This error only happen in Google Chrome, new EDGE (chromium) but it is working for Internet Explorer and classic EDGE browser.

 

Any solution that we can modify <meta> in SharePoint online master page?

Link: https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP 

 

0 Replies