SharePoint Online Global Navigation (similar URLs)

%3CLINGO-SUB%20id%3D%22lingo-sub-2101052%22%20slang%3D%22en-US%22%3ESharePoint%20Online%20Global%20Navigation%20(similar%20URLs)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2101052%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22lia-message-subject-wrapper%20lia-component-subject%20lia-component-message-view-widget-subject-with-options%22%3E%3CSPAN%3EHi%2C%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22lia-message-body%20lia-component-message-view-widget-body%20lia-component-body-signature-highlight-escalation%20lia-component-message-view-widget-body-signature-highlight-escalation%22%3E%3CDIV%20class%3D%22lia-message-body-content%22%3E%3CP%3EOn%20my%20hubsite%20I%20created%20node%20%22News%22%20-%20it%20redirects%20to%20https%3A%2F%2F%7Btenant%7D%2Fsites%2FsiteA%2F_layouts%2F15%2Fnews.aspx%20.%3C%2FP%3E%3CP%3EUnder%20that%20node%20I%20created%203%20another%20nodes%20that%20redirects%20to%20the%20same%20page%20but%20on%20another%20sites%20%3A%3C%2FP%3E%3CUL%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2F%257Btenant%257D%2Fsites%2FsiteB%2F_layouts%2F15%2Fnews.aspx%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2F%7Btenant%7D%2Fsites%2FsiteB%2F_layouts%2F15%2Fnews.aspx%3C%2FA%3E%3C%2FLI%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2F%257Btenant%257D%2Fsites%2FsiteC%2F_layouts%2F15%2Fnews.aspx%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2F%7Btenant%7D%2Fsites%2FsiteC%2F_layouts%2F15%2Fnews.aspx%3C%2FA%3E%3C%2FLI%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2F%257Btenant%257D%2Fsites%2FsiteD%2F_layouts%2F15%2Fnews.aspx%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2F%7Btenant%7D%2Fsites%2FsiteD%2F_layouts%2F15%2Fnews.aspx%3C%2FA%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3EWhen%20I%20go%20to%20one%20of%20that%20pages%20and%20from%20there%20try%20to%20go%20to%20another%20the%20content%20doesn't%20change.%20I%20see%20the%20same%20news%20but%20the%20URL%20in%20brower%20changed.%26nbsp%3B%3CBR%20%2F%3EWhen%20I%20click%20twice%20the%20same%20link%20in%20navigation%20I%20am%20redirected%20to%20proper%20site%20and%20content%20changes.%20(one%20click%20to%20change%20url%20in%20browser%2C%20second%20to%20reload%20the%20page)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20you%20know%20how%20can%20I%20fix%20this%20problem%3F%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Occasional Visitor
Hi,

On my hubsite I created node "News" - it redirects to https://{tenant}/sites/siteA/_layouts/15/news.aspx .

Under that node I created 3 another nodes that redirects to the same page but on another sites :

When I go to one of that pages and from there try to go to another the content doesn't change. I see the same news but the URL in brower changed. 
When I click twice the same link in navigation I am redirected to proper site and content changes. (one click to change url in browser, second to reload the page)

 

Do you know how can I fix this problem?

0 Replies