SharePoint list search is not working in Hosted add-in

Copper Contributor

We are using Sharepoint hosted addin and we have a problem with the search function


On our view screen there are 3 items like the picture (This view is deployed on Addin Web)



When we enter "TEST" into the search bar, the results are empty.



That raises us some questions.

1. Is there anyway we can search the AddIn Web?

2. Where is database of the SearchIndex located? (HostWeb or AddinWeb?)

3. Where is Scrawling Data implemented? (HostWeb or AddinWeb?)


(If there are any documents that help with these questions, please send us a reference.)

As the picture below, when entering the search value into the search box on AddinWeb, it will query the Database Search Index (2)


10 Replies



Se here




Try reindex the list: List Settings

Advanced settings -> Reindex List


If there are multiple lists on same site affected you might want to index whole site:

Site Settings -> Search -> Search and Offline Availability

Hi @Joao Livio,


Thanks for the suggestion.

We tried but it seems like there's something going on on MS Server which prevent doing so.


We also post a ticket about this (endpoint not reachable) to MS Support but they were not able to discover anything on their environment.




If nothing is found, and the if is on premises, I would try to recreate the sources in the search admin. But is only happening in the actual add in?
Hi Joao Livio,

You can follow the steps in the official document using the link below to reproduce it.

The search issue happens at step 32.
You are creating a list with a template and a list instance, ok, but if it works for all other lists, that means your custom list is not being crawling.

If don’t work for all others lists also I have a solution because it happened to me.
May we know the solution?
I don't know if applys to your context, but I had a problem in a farm, all lists won't return any value, First I tried to delete the search content sources and recreate but didn't work, I had to remove and install the Search Service again, then create all content sources again the start working.

I really don't know if this is the same problem on your side. If all lists won't return any value, you can give a shot.



I am are using SharePoint-hosted apps. SharePoint is hosting it.


So in that case who should I contact to remove and install Search Service again?


@Joao Livio 

Did you see if this behavior is replicated for all lists not in the add-in? That solution was if something was broken in the farm.

I'll try to reproduce the article and let you know