Sharepoint development framework environment setup. Yeoman crashing, install warnings

%3CLINGO-SUB%20id%3D%22lingo-sub-2108162%22%20slang%3D%22en-US%22%3ESharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2108162%22%20slang%3D%22en-US%22%3E%3CP%3EFollowing%20the%20guide%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fset-up-your-development-environment%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Fdev%2Fspfx%2Fset-up-your-development-environment%3C%2FA%3E%3C%2FP%3E%3CP%3Emade%20sure%20of%20all%20the%20prerequisites%20but%20as%20I%20follow%20the%20steps%20I%20get%20multiple%20warnings%20to%20do%20with%20depreciated%20packages.%20I've%20installed%20node%2010.23.2%20and%20checked%20the%20version%20using%20node%20-v.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20try%20to%20run%20yo%20it%20crashes%20like%20below%20and%20powershell%20becomes%20unresponsive.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'd%20really%20appreciate%20any%20pointers%20as%20to%20what%20I'm%20doing%20wrong%20and%20a%20route%20out%20of%20this.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-bash%22%3E%3CCODE%3EPS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20npm%20install%20gulp%20yo%20%2Fgenerator-sharepoint%20--global%0Anpm%20%3A%20npm%20WARN%20deprecated%20resolve-url%400.2.1%3A%20https%3A%2F%2Fgithub.com%2Flydell%2Fresolve-url%23deprecated%0AAt%20line%3A1%20char%3A1%0A%2B%20npm%20install%20gulp%20yo%20%2Fgenerator-sharepoint%20--global%0A%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(npm%20WARN%20deprec...-url%23deprecated%3AString)%20%5B%5D%2C%20RemoteException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20NativeCommandError%0A%20%0Anpm%20WARN%20deprecated%20urix%400.1.0%3A%20Please%20see%20https%3A%2F%2Fgithub.com%2Flydell%2Furix%23deprecated%0Anpm%20WARN%20deprecated%20chokidar%402.1.8%3A%20Chokidar%202%20will%20break%20on%20node%20v14%2B.%20Upgrade%20to%20chokidar%203%20with%2015x%20less%20%0Adependencies.%0Anpm%20WARN%20deprecated%20fsevents%401.2.13%3A%20fsevents%201%20will%20break%20on%20node%20v14%2B%20and%20could%20be%20using%20insecure%20binaries.%20%0AUpgrade%20to%20fsevents%202.%0Anpm%20WARN%20deprecated%20request%402.88.2%3A%20request%20has%20been%20deprecated%2C%20see%20%0Ahttps%3A%2F%2Fgithub.com%2Frequest%2Frequest%2Fissues%2F3142%0Anpm%20WARN%20deprecated%20har-validator%405.1.5%3A%20this%20library%20is%20no%20longer%20supported%0Anpm%20WARN%20deprecated%20cross-spawn-async%402.2.5%3A%20cross-spawn%20no%20longer%20requires%20a%20build%20toolchain%2C%20use%20it%20instead%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cgulp%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cgulp%5Cbin%5Cgulp.js%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo-complete%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%5Clib%5Ccompletion%0A%5Cindex.js%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%5Clib%5Ccli.js%0A%0A%26gt%3B%20yo%403.1.1%20postinstall%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%0A%26gt%3B%20yodoctor%0A%0A%0AYeoman%20Doctor%0ARunning%20sanity%20checks%20on%20your%20system%0A%0A%C3%A2%CB%86%C5%A1%20No%20.bowerrc%20file%20in%20home%20directory%0A%C3%A2%CB%86%C5%A1%20Global%20configuration%20file%20is%20valid%0A%C3%A2%CB%86%C5%A1%20NODE_PATH%20matches%20the%20npm%20root%0A%C3%A2%CB%86%C5%A1%20No%20.yo-rc.json%20file%20in%20home%20directory%0A%C3%A2%CB%86%C5%A1%20Node.js%20version%0A%C3%A2%CB%86%C5%A1%20npm%20version%0A%C3%A2%CB%86%C5%A1%20yo%20version%0A%0AEverything%20looks%20all%20right!%0Anpm%20WARN%20notsup%20Unsupported%20engine%20for%20got%405.7.1%3A%20wanted%3A%20%7B%22node%22%3A%22%26gt%3B%3D0.10.0%20%26lt%3B7%22%7D%20(current%3A%20%0A%7B%22node%22%3A%2210.23.2%22%2C%22npm%22%3A%226.14.10%22%7D)%0Anpm%20WARN%20notsup%20Not%20compatible%20with%20your%20version%20of%20node%2Fnpm%3A%20got%405.7.1%0Anpm%20WARN%20optional%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20fsevents%40%5E1.2.7%20%0A(node_modules%5Cgulp%5Cnode_modules%5Cchokidar%5Cnode_modules%5Cfsevents)%3A%0Anpm%20WARN%20notsup%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20Unsupported%20platform%20for%20fsevents%401.2.13%3A%20wanted%20%0A%7B%22os%22%3A%22darwin%22%2C%22arch%22%3A%22any%22%7D%20(current%3A%20%7B%22os%22%3A%22win32%22%2C%22arch%22%3A%22x64%22%7D)%0A%2B%20gulp%404.0.2%0A%2B%20yo%403.1.1%0A%2B%20%2Fgenerator-sharepoint%401.11.0%0Aupdated%203%20packages%20in%2025.298s%0A%0APS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20npm%20ls%20-g%20--depth%3D0%20%2Fgenerator-sharepoint%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%0A%60--%20%2Fgenerator-sharepoint%401.11.0%20%0A%0A%0APS%20C%3A%5CWINDOWS%5Csystem32%26gt%3B%20yo%20%2Fsharepoint%0Anode.exe%20%3A%20%0AAt%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo.ps1%3A15%20char%3A3%0A%2B%20%20%20%26amp%3B%20%22node%24exe%22%20%20%22%24basedir%2Fnode_modules%2Fyo%2Flib%2Fcli.js%22%20%24args%0A%2B%20%20%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(%3AString)%20%5B%5D%2C%20RemoteException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20NativeCommandError%0A%20%0A%20%20%20%20%20_-----_%0A%20%20%20%20%7C%20%20%20%20%20%20%20%7C%20%20%20%20.--------------------------.%0A%20%20%20%20%7C--(o)--%7C%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%20%20%20%20%26%2327%3B%5B0mWelcome%20to%20the%26%2327%3B%5B0m%20%20%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%60---------%C3%82%C2%B4%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%26%2327%3B%5B0m%26%2327%3B%5B34mS%26%2327%3B%5B34mh%26%2327%3B%5B34ma%26%2327%3B%5B34mr%26%2327%3B%5B34me%26%2327%3B%5B34mP%26%2327%3B%5B34mo%26%2327%3B%5B34mi%26%2327%3B%5B34mn%26%2327%3B%5B34mt%26%2327%3B%5B34m%20%0A%26%2327%3B%5B34mC%26%2327%3B%5B34ml%26%2327%3B%5B34mi%26%2327%3B%5B34me%26%2327%3B%5B34mn%26%2327%3B%5B34mt%26%2327%3B%5B34m-%26%2327%3B%5B34ms%26%2327%3B%5B34mi%26%2327%3B%5B34md%26%2327%3B%5B34me%26%2327%3B%5B0m%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%20(%20_%C3%82%C2%B4U%60_%20)%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%20%20%26%2327%3B%5B0m%26%2327%3B%5B34mS%26%2327%3B%5B34mo%26%2327%3B%5B34ml%26%2327%3B%5B34mu%26%2327%3B%5B34mt%26%2327%3B%5B34mi%26%2327%3B%5B34mo%26%2327%3B%5B34mn%26%2327%3B%5B34m%20%0A%26%2327%3B%5B34mG%26%2327%3B%5B34me%26%2327%3B%5B34mn%26%2327%3B%5B34me%26%2327%3B%5B34mr%26%2327%3B%5B34ma%26%2327%3B%5B34mt%26%2327%3B%5B34mo%26%2327%3B%5B34mr%26%2327%3B%5B0m%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%20%2F___A___%5C%20%20%20%20%26%2327%3B%5B0m'--------------------------'%0A%20%20%20%20%20%7C%20%20~%20%20%7C%20%20%20%20%20%0A%20%20%20__'.___.'__%20%20%20%0A%20%C3%82%C2%B4%20%20%20%60%20%20%7C%C3%82%C2%B0%20%C3%82%C2%B4%20Y%20%60%20%0ALet's%20create%20a%20new%20SharePoint%20solution.%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110180%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110180%22%20slang%3D%22en-US%22%3EIf%20you%20want%20to%20use%20nvm%2C%20you%20should%20uninstall%20the%20previously%20installed%20Node%20as%20it%20will%20likely%20lead%20to%20issues%20you%E2%80%99ll%20have%20hard%20time%20debugging%20and%20explaining%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110153%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110153%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F640320%22%20target%3D%22_blank%22%3E%40Wildtypitch%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20too%20just%20started%20using%20nodejs!%20thanks%20for%20everything!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110142%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110142%22%20slang%3D%22en-US%22%3EI'd%20uninstall%20to%20be%20sure.%20But%20I'm%20not%20sure%20if%20it's%20necessary.%20NPM%20in%20theory%20handles%20all%20these%20versions%20and%20which%20projects%20use%20which.%20I%20had%20issues%20because%20there%20was%20no%20initial%20file%20created%20to%20store%20this%20info%20in%20my%20NPM.%20Google%20NPM%20beginners%20guide%20to%20understand%20more.%20I'm%20all%20very%20new%20to%20this%20so%20I%20might%20be%20corrected.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110091%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110091%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F640320%22%20target%3D%22_blank%22%3E%40Wildtypitch%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20this%20post%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fstackoverflow.com%2Fquestions%2F20711240%2Fhow-to-completely-remove-node-js-from-windows%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstackoverflow.com%2Fquestions%2F20711240%2Fhow-to-completely-remove-node-js-from-windows%3C%2FA%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20hope%20it%20will%20be%20useful%20to%20you.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110087%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110087%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F640320%22%20target%3D%22_blank%22%3E%40Wildtypitch%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20a%20lot!%20I%20will%20try%20to%20use%26nbsp%3B%3CSPAN%3Envm-windows%2C%20but%20i%20have%20one%20last%20question%20before%20I%20act%3A%20I%20also%20installed%20gulp%20and%20yoman.%20Can%20I%20keep%20these%20tools%20as%20they%20are%20or%20do%20I%20have%20to%20uninstall%20all%20tools%20and%20reinstall%20them%20in%20order%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%20in%20advance!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110031%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110031%22%20slang%3D%22en-US%22%3EI%20think%20you'll%20need%20to%20install%20locally%20not%20globally.%20Or%20use%20a%20manager%20like%20nvm%20from%20powershell%20gallery%20to%20swap%20between%20versions.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2110027%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2110027%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F640320%22%20target%3D%22_blank%22%3E%40Wildtypitch%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20also%20the%20same%20problem%3B%20i%20had%20nodejs%2012.18.2%20on%20my%20pc%20for%20other%20purposes.%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20i%20cannot%20preserve%20my%20previous%20version%3F%20I%20must%20downgrade%3F%3C%2FP%3E%3CP%3EThanks%20in%20advance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109987%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109987%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F853365%22%20target%3D%22_blank%22%3E%40waldek%3C%2FA%3E%3C%2FP%3E%3CP%3EI've%20got%20it%20working%20on%20another%20machine.%20I'll%20completely%20refresh%20my%20main%20one%20at%20another%20time%20but%20all%20those%20warnings%20were%20fine%20FYI.%20Yo%20ran%20smoothly%20with%20a%20freshly%20install%20node%20v10%20via%20NVM%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20help%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109912%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109912%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F853365%22%20target%3D%22_blank%22%3E%40waldek%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20uninstalled%20and%20deleted%20all%20modules%20and%20node.%20Re-installed%20a%2010.x%20version%20a%20gulp%20and%20yo%20with%20the%20same%20warnings.%26nbsp%3B%3C%2FP%3E%3CP%3ERunning%20into%20the%20exact%20same%20problems!%3C%2FP%3E%3CP%3EI%20had%20used%20nvm%20from%20powershell%20galleries%20to%20previously%20install%20node%20but%20have%20since%20removed.%20Maybe%20there's%20relics%20of%20that%20but%20I%20can't%20find%20them%20if%20there%20are.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109846%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109846%22%20slang%3D%22en-US%22%3EThis%20could%20be%20the%20issue%20if%20you've%20installed%20Node%20once%20using%20the%20installer%20and%20then%20another%20time%20using%20something%20like%20nvm.%20Hopefully%20the%20clean%20up%20will%20help.%20Let%20us%20know%20how%20it%20worked%20out%20in%20the%20end!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109834%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109834%22%20slang%3D%22en-US%22%3EThat's%20what%20I'm%20in%20the%20process%20of%20doing%20right%20now.%20It's%20possible%20there%20are%20hidden%20conflicting%20versions%20of%20node.%20So%20I'm%20trying%20to%20remove%20all%20traces%20of%20it%20and%20starting%20again.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109829%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109829%22%20slang%3D%22en-US%22%3EHow%20have%20you%20installed%20node%3F%20Perhaps%20something%20went%20wrong%20there%3F%20As%20a%20last%20resort%2C%20you%20could%20try%20to%20remove%20yo%20and%20gulp%20(npm%20uninstall%20-g%20yo%20gulp)%20and%20then%20uninstall%20Node%20and%20reinstall%20everything%20again%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109786%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109786%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F853365%22%20target%3D%22_blank%22%3E%40waldek%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESadly%20it%20doesn't%20seem%20to%20make%20a%20difference.%20I've%20tried%20in%20a%20project%20folder%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-powershell%22%3E%3CCODE%3EPS%20D%3A%5Csharepoint%5Csp-site-designs-studio-master%26gt%3B%20node%20-%0A%0APS%20D%3A%5Csharepoint%5Csp-site-designs-studio-master%26gt%3B%20node%20-v%0Av10.23.2%0A%0APS%20D%3A%5Csharepoint%5Csp-site-designs-studio-master%26gt%3B%20npm%20-v%0A6.14.10%0A%0APS%20D%3A%5Csharepoint%5Csp-site-designs-studio-master%26gt%3B%20npm%20install%20-g%20yo%20gulp%0Anpm%20%3A%20npm%20WARN%20deprecated%20chokidar%402.1.8%3A%20Chokidar%202%20will%20break%20on%20node%20v14%2B.%20Upgrade%20to%20chokidar%203%20with%2015x%20less%20dependencies.%0AAt%20line%3A1%20char%3A1%0A%2B%20npm%20install%20-g%20yo%20gulp%0A%2B%20~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(npm%20WARN%20deprec...s%20dependencies.%3AString)%20%5B%5D%2C%20RemoteException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20NativeCommandError%0A%20%0Anpm%20WARN%20deprecated%20resolve-url%400.2.1%3A%20https%3A%2F%2Fgithub.com%2Flydell%2Fresolve-url%23deprecated%0Anpm%20WARN%20deprecated%20urix%400.1.0%3A%20Please%20see%20https%3A%2F%2Fgithub.com%2Flydell%2Furix%23deprecated%0Anpm%20WARN%20deprecated%20fsevents%401.2.13%3A%20fsevents%201%20will%20break%20on%20node%20v14%2B%20and%20could%20be%20using%20insecure%20binaries.%20Upgrade%20to%20fsevents%202.%0Anpm%20WARN%20deprecated%20request%402.88.2%3A%20request%20has%20been%20deprecated%2C%20see%20https%3A%2F%2Fgithub.com%2Frequest%2Frequest%2Fissues%2F3142%0Anpm%20WARN%20deprecated%20har-validator%405.1.5%3A%20this%20library%20is%20no%20longer%20supported%0Anpm%20WARN%20deprecated%20cross-spawn-async%402.2.5%3A%20cross-spawn%20no%20longer%20requires%20a%20build%20toolchain%2C%20use%20it%20instead%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cgulp%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cgulp%5Cbin%5Cgulp.js%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%5Clib%5Ccli.js%0AC%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo-complete%20-%26gt%3B%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%5Clib%5Ccompletion%5Cindex.js%0A%0A%26gt%3B%20yo%403.1.1%20postinstall%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cnode_modules%5Cyo%0A%26gt%3B%20yodoctor%0A%0A%0AYeoman%20Doctor%0ARunning%20sanity%20checks%20on%20your%20system%0A%0A%C3%A2%CB%86%C5%A1%20No%20.bowerrc%20file%20in%20home%20directory%0A%C3%A2%CB%86%C5%A1%20Global%20configuration%20file%20is%20valid%0A%C3%A2%CB%86%C5%A1%20NODE_PATH%20matches%20the%20npm%20root%0A%C3%A2%CB%86%C5%A1%20No%20.yo-rc.json%20file%20in%20home%20directory%0A%C3%A2%CB%86%C5%A1%20Node.js%20version%0A%C3%A2%CB%86%C5%A1%20npm%20version%0A%C3%A2%CB%86%C5%A1%20yo%20version%0A%0AEverything%20looks%20all%20right!%0Anpm%20WARN%20optional%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20fsevents%40%5E1.2.7%20(node_modules%5Cgulp%5Cnode_modules%5Cchokidar%5Cnode_modules%5Cfsevents)%3A%0Anpm%20WARN%20notsup%20SKIPPING%20OPTIONAL%20DEPENDENCY%3A%20Unsupported%20platform%20for%20fsevents%401.2.13%3A%20wanted%20%7B%22os%22%3A%22darwin%22%2C%22arch%22%3A%22any%22%7D%20(current%3A%20%7B%22os%22%3A%22win32%22%2C%22arch%22%3A%22x64%22%7D)%0A%2B%20yo%403.1.1%0A%2B%20gulp%404.0.2%0Aupdated%203%20packages%20in%2018.739s%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eall%20the%20same%20warnings%20installing%20gulp%20and%20yo%3C%2FP%3E%3CP%3EWhen%20trying%20to%20create%20the%20project%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3EPS%20D%3A%5Csharepoint%5Csp-site-designs-studio-master%26gt%3B%20yo%20%40microsoft%2Fsharepoint%0Anode.exe%20%3A%20%0AAt%20C%3A%5CUsers%5Cnatha%5CAppData%5CRoaming%5Cnpm%5Cyo.ps1%3A15%20char%3A3%0A%2B%20%20%20%26amp%3B%20%22node%24exe%22%20%20%22%24basedir%2Fnode_modules%2Fyo%2Flib%2Fcli.js%22%20%24args%0A%2B%20%20%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%0A%20%20%20%20%2B%20CategoryInfo%20%20%20%20%20%20%20%20%20%20%3A%20NotSpecified%3A%20(%3AString)%20%5B%5D%2C%20RemoteException%0A%20%20%20%20%2B%20FullyQualifiedErrorId%20%3A%20NativeCommandError%0A%20%0A%20%20%20%20%20_-----_%0A%20%20%20%20%7C%20%20%20%20%20%20%20%7C%20%20%20%20.--------------------------.%0A%20%20%20%20%7C--(o)--%7C%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%20%20%20%20%26%2327%3B%5B0mWelcome%20to%20the%26%2327%3B%5B0m%20%20%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%60---------%C3%82%C2%B4%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%26%2327%3B%5B0m%26%2327%3B%5B34mS%26%2327%3B%5B34mh%26%2327%3B%5B34ma%26%2327%3B%5B34mr%26%2327%3B%5B34me%26%2327%3B%5B34mP%26%2327%3B%5B34mo%26%2327%3B%5B34mi%26%2327%3B%5B34mn%26%2327%3B%5B34mt%26%2327%3B%5B34m%20%26%2327%3B%5B34mC%26%2327%3B%5B34ml%26%2327%3B%5B34mi%26%2327%3B%5B34me%26%2327%3B%5B34mn%26%2327%3B%5B34mt%26%2327%3B%5B34m-%26%2327%3B%5B34ms%26%2327%3B%5B34mi%26%2327%3B%5B34md%26%2327%3B%5B34me%26%2327%3B%5B0m%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%20(%20_%C3%82%C2%B4U%60_%20)%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%20%20%20%20%26%2327%3B%5B0m%26%2327%3B%5B34mS%26%2327%3B%5B34mo%26%2327%3B%5B34ml%26%2327%3B%5B34mu%26%2327%3B%5B34mt%26%2327%3B%5B34mi%26%2327%3B%5B34mo%26%2327%3B%5B34mn%26%2327%3B%5B34m%20%26%2327%3B%5B34mG%26%2327%3B%5B34me%26%2327%3B%5B34mn%26%2327%3B%5B34me%26%2327%3B%5B34mr%26%2327%3B%5B34ma%26%2327%3B%5B34mt%26%2327%3B%5B34mo%26%2327%3B%5B34mr%26%2327%3B%5B0m%20%20%20%20%26%2327%3B%5B0m%7C%26%2327%3B%5B0m%0A%20%20%20%20%2F___A___%5C%20%20%20%20%26%2327%3B%5B0m'--------------------------'%0A%20%20%20%20%20%7C%20%20~%20%20%7C%20%20%20%20%20%0A%20%20%20__'.___.'__%20%20%20%0A%20%C3%82%C2%B4%20%20%20%60%20%20%7C%C3%82%C2%B0%20%C3%82%C2%B4%20Y%20%60%20%0ALet's%20create%20a%20new%20SharePoint%20solution.%3C%2FCODE%3E%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109734%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109734%22%20slang%3D%22en-US%22%3EThanks%20for%20the%20reply.%20Hi%20using%20powershell%20use%20as%20admin%20yes.%20Right%20I%20shouldn't%20be%20doing%20things%20in%20there.%20I'll%20give%20it%20a%20try%20this%20morning.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2109652%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20development%20framework%20environment%20setup.%20Yeoman%20crashing%2C%20install%20warnings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2109652%22%20slang%3D%22en-US%22%3EAre%20you%20running%20PowerShell%20as%20admin%3F%20You%E2%80%99re%20in%20the%20system32%20directory.%20Have%20you%20tried%20creating%20project%20in%20a%20different%20folder%3F%3C%2FLINGO-BODY%3E
Contributor

Following the guide https://docs.microsoft.com/en-us/sharepoint/dev/spfx/set-up-your-development-environment

made sure of all the prerequisites but as I follow the steps I get multiple warnings to do with depreciated packages. I've installed node 10.23.2 and checked the version using node -v.

 

When I try to run yo it crashes like below and powershell becomes unresponsive.

 

I'd really appreciate any pointers as to what I'm doing wrong and a route out of this.

 

Thanks

 

 

PS C:\WINDOWS\system32> npm install gulp yo /generator-sharepoint --global
npm : npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
At line:1 char:1
+ npm install gulp yo /generator-sharepoint --global
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (npm WARN deprec...-url#deprecated:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less 
dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. 
Upgrade to fsevents 2.
npm WARN deprecated request@2.88.2: request has been deprecated, see 
https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
C:\Users\natha\AppData\Roaming\npm\gulp -> C:\Users\natha\AppData\Roaming\npm\node_modules\gulp\bin\gulp.js
C:\Users\natha\AppData\Roaming\npm\yo-complete -> C:\Users\natha\AppData\Roaming\npm\node_modules\yo\lib\completion
\index.js
C:\Users\natha\AppData\Roaming\npm\yo -> C:\Users\natha\AppData\Roaming\npm\node_modules\yo\lib\cli.js

> yo@3.1.1 postinstall C:\Users\natha\AppData\Roaming\npm\node_modules\yo
> yodoctor


Yeoman Doctor
Running sanity checks on your system

√ No .bowerrc file in home directory
√ Global configuration file is valid
√ NODE_PATH matches the npm root
√ No .yo-rc.json file in home directory
√ Node.js version
√ npm version
√ yo version

Everything looks all right!
npm WARN notsup Unsupported engine for got@5.7.1: wanted: {"node":">=0.10.0 <7"} (current: 
{"node":"10.23.2","npm":"6.14.10"})
npm WARN notsup Not compatible with your version of node/npm: got@5.7.1
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 
(node_modules\gulp\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted 
{"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
+ gulp@4.0.2
+ yo@3.1.1
+ /generator-sharepoint@1.11.0
updated 3 packages in 25.298s

PS C:\WINDOWS\system32> npm ls -g --depth=0 /generator-sharepoint
C:\Users\natha\AppData\Roaming\npm
`-- /generator-sharepoint@1.11.0 


PS C:\WINDOWS\system32> yo /sharepoint
node.exe : 
At C:\Users\natha\AppData\Roaming\npm\yo.ps1:15 char:3
+   & "node$exe"  "$basedir/node_modules/yo/lib/cli.js" $args
+   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
     _-----_
    |       |    .--------------------------.
    |--(o)--|    |      Welcome to the      |
   `---------´   |  SharePoint 
Client-side  |
    ( _´U`_ )    |    Solution 
Generator    |
    /___A___\    '--------------------------'
     |  ~  |     
   __'.___.'__   
 ´   `  |° ´ Y ` 
Let's create a new SharePoint solution.

 

 

15 Replies
Are you running PowerShell as admin? You’re in the system32 directory. Have you tried creating project in a different folder?
Thanks for the reply. Hi using powershell use as admin yes. Right I shouldn't be doing things in there. I'll give it a try this morning.

@waldek 

Sadly it doesn't seem to make a difference. I've tried in a project folder 

 

PS D:\sharepoint\sp-site-designs-studio-master> node -

PS D:\sharepoint\sp-site-designs-studio-master> node -v
v10.23.2

PS D:\sharepoint\sp-site-designs-studio-master> npm -v
6.14.10

PS D:\sharepoint\sp-site-designs-studio-master> npm install -g yo gulp
npm : npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
At line:1 char:1
+ npm install -g yo gulp
+ ~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (npm WARN deprec...s dependencies.:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated cross-spawn-async@2.2.5: cross-spawn no longer requires a build toolchain, use it instead
C:\Users\natha\AppData\Roaming\npm\gulp -> C:\Users\natha\AppData\Roaming\npm\node_modules\gulp\bin\gulp.js
C:\Users\natha\AppData\Roaming\npm\yo -> C:\Users\natha\AppData\Roaming\npm\node_modules\yo\lib\cli.js
C:\Users\natha\AppData\Roaming\npm\yo-complete -> C:\Users\natha\AppData\Roaming\npm\node_modules\yo\lib\completion\index.js

> yo@3.1.1 postinstall C:\Users\natha\AppData\Roaming\npm\node_modules\yo
> yodoctor


Yeoman Doctor
Running sanity checks on your system

√ No .bowerrc file in home directory
√ Global configuration file is valid
√ NODE_PATH matches the npm root
√ No .yo-rc.json file in home directory
√ Node.js version
√ npm version
√ yo version

Everything looks all right!
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules\gulp\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
+ yo@3.1.1
+ gulp@4.0.2
updated 3 packages in 18.739s

 

all the same warnings installing gulp and yo

When trying to create the project 

PS D:\sharepoint\sp-site-designs-studio-master> yo @microsoft/sharepoint
node.exe : 
At C:\Users\natha\AppData\Roaming\npm\yo.ps1:15 char:3
+   & "node$exe"  "$basedir/node_modules/yo/lib/cli.js" $args
+   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
     _-----_
    |       |    .--------------------------.
    |--(o)--|    |      Welcome to the      |
   `---------´   |  SharePoint Client-side  |
    ( _´U`_ )    |    Solution Generator    |
    /___A___\    '--------------------------'
     |  ~  |     
   __'.___.'__   
 ´   `  |° ´ Y ` 
Let's create a new SharePoint solution.
How have you installed node? Perhaps something went wrong there? As a last resort, you could try to remove yo and gulp (npm uninstall -g yo gulp) and then uninstall Node and reinstall everything again?
That's what I'm in the process of doing right now. It's possible there are hidden conflicting versions of node. So I'm trying to remove all traces of it and starting again.
This could be the issue if you've installed Node once using the installer and then another time using something like nvm. Hopefully the clean up will help. Let us know how it worked out in the end!

@waldek 

Thanks. 

I've uninstalled and deleted all modules and node. Re-installed a 10.x version a gulp and yo with the same warnings. 

Running into the exact same problems!

I had used nvm from powershell galleries to previously install node but have since removed. Maybe there's relics of that but I can't find them if there are. 

 

Thanks @waldek

I've got it working on another machine. I'll completely refresh my main one at another time but all those warnings were fine FYI. Yo ran smoothly with a freshly install node v10 via NVM

 

Thanks for the help 

@Wildtypitch 

I have also the same problem; i had nodejs 12.18.2 on my pc for other purposes. 

So i cannot preserve my previous version? I must downgrade?

Thanks in advance.

I think you'll need to install locally not globally. Or use a manager like nvm from powershell gallery to swap between versions.

@Wildtypitch 

Thanks a lot! I will try to use nvm-windows, but i have one last question before I act: I also installed gulp and yoman. Can I keep these tools as they are or do I have to uninstall all tools and reinstall them in order?

 

Thanks in advance!

I'd uninstall to be sure. But I'm not sure if it's necessary. NPM in theory handles all these versions and which projects use which. I had issues because there was no initial file created to store this info in my NPM. Google NPM beginners guide to understand more. I'm all very new to this so I might be corrected.

@Wildtypitch 

I too just started using nodejs! thanks for everything!

If you want to use nvm, you should uninstall the previously installed Node as it will likely lead to issues you’ll have hard time debugging and explaining