Sharepoint Designer Publishing Error to Project Online site

%3CLINGO-SUB%20id%3D%22lingo-sub-274337%22%20slang%3D%22en-US%22%3ESharepoint%20Designer%20Publishing%20Error%20to%20Project%20Online%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-274337%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20trying%20to%20publish%20a%20simple%20SharePoint%20Designer%20Workflow%20to%20Project%20Online%20and%20receive%20the%20following%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EErrors%20were%20found%20when%20compiling%20the%20workflow.%20The%20workflow%20files%20were%20saved%20but%20cannot%20be%20run.%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3EMicrosoft.SharePoint.SPPrincipalManagementException%3A%20An%20error%20occurred%20while%20attempting%20to%20execute%20a%20principal%20management%20operation.%26nbsp%3B%20Please%20contact%20your%20administrator.%20---%26gt%3B%20System.ServiceModel.FaultException%601%5BMicrosoft.Online.Administration.WebService.PropertyValidationException%5D%3A%20Invalid%20property%20specified%3C%2FDIV%3E%3CDIV%3EServer%20stack%20trace%3A%3CBR%20%2F%3E%26nbsp%3B%26nbsp%3B%20at%20System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime%20operation%2C%20ProxyRpc%26amp%3B%20rpc)%3CBR%20%2F%3E%26nbsp%3B%26nbsp%3B%20at%20System.ServiceModel.Channels.ServiceChannel.Cal%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EIn%20attempting%20to%20isolate%20the%20problem%20I%20found%20I%20can%20successfully%20publish%20an%20empty%20workflow%20from%20SharePoint%20Designer%202013%20application%20on%20the%20Win%2010%20desktop%20to%20%3CA%20href%3D%22https%3A%2F%2Fqbe.sharepoint.com%2Fsites%2Fpwa%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fqbe.sharepoint.com%2Fsites%2Fpwa%3C%2FA%3E%20but%20receive%20the%20above%20error%20when%20attempting%20to%20publish%20an%20empty%20workflow%20to%20davidmaiden.sharepoint.com%2Fsites%2Fpwa%20from%20the%20same%20desktop%20instance.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EThe%20%3CSPAN%3ESharePoint%20Designer%202013%3C%2FSPAN%3E%20application%20has%20SP1and%20other%20updates%20applied.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EI%20am%20a%20PWA%20site%20admin%20of%20both%20tenancies.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EThere%20is%20only%20one%20minor%20issue%20when%20running%20the%20health%20check%20on%20the%20davidmaiden.sharepoint.com%26nbsp%3B%20site%20relating%20to%20the%20PWA%20landing%20page%20(which%20I%20can't%20clear)%20but%20that's%20it.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EAny%20guidance%20appreciated.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EDavid%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-274337%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E%22Sharepoint%20Designer%22%20%22Publishing%20Error%22%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Hi,

 

I am trying to publish a simple SharePoint Designer Workflow to Project Online and receive the following error:

 

Errors were found when compiling the workflow. The workflow files were saved but cannot be run.

 

Microsoft.SharePoint.SPPrincipalManagementException: An error occurred while attempting to execute a principal management operation.  Please contact your administrator. ---> System.ServiceModel.FaultException`1[Microsoft.Online.Administration.WebService.PropertyValidationException]: Invalid property specified
Server stack trace:
   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
   at System.ServiceModel.Channels.ServiceChannel.Cal
 
In attempting to isolate the problem I found I can successfully publish an empty workflow from SharePoint Designer 2013 application on the Win 10 desktop to https://qbe.sharepoint.com/sites/pwa but receive the above error when attempting to publish an empty workflow to davidmaiden.sharepoint.com/sites/pwa from the same desktop instance.
 
The SharePoint Designer 2013 application has SP1and other updates applied.
 
I am a PWA site admin of both tenancies.
 
There is only one minor issue when running the health check on the davidmaiden.sharepoint.com  site relating to the PWA landing page (which I can't clear) but that's it.
 
Any guidance appreciated.
 
David
0 Replies