Sharepoint: Custom Apps not visible in Site Settings > Your apps page

%3CLINGO-SUB%20id%3D%22lingo-sub-977583%22%20slang%3D%22en-US%22%3ESharepoint%3A%20Custom%20Apps%20not%20visible%20in%20Site%20Settings%20%26gt%3B%20Your%20apps%20page%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-977583%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EWe%20have%20developed%20a%20simple%20app%20for%20SharePoint%20online%20and%20I%20am%20trying%20to%20deploy%20it%20to%20my%20communication%20site.%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EI%20have%20followed%20this%20article%3A%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FUse-the-App-Catalog-to-make-custom-business-apps-available-for-your-SharePoint-Online-environment-0b6ab336-8b83-423f-a06b-bcc52861cba0%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FUse-the-App-Catalog-to-make-custom-business-apps-available-for-your-SharePoint-Online-environment-0b6ab336-8b83-423f-a06b-bcc52861cba0%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%3C%2FA%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EI%20managed%20to%20add%20it%20to%20%22Apps%20for%20SharePoint%22%2C%20however%20when%20I%20go%20to%20%22Your%20apps%22%20I%20do%20not%20see%20it%20in%20the%20section%20%22From%20your%20organization%22%2C%20where%20it%20should%20be%20available%20for%20deploying.%20The%20page%20displays%20%22There%20is%20nothing%20here%20yet%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CSPAN%3ETried%20to%20find%20the%20app%20in%20the%20section%20%22Apps%20You%20can%20Add%22%20but%20still%20and%20I%20am%20not%20able%20to%20see%20the%20app.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CSPAN%3EI%20created%20new%20site%20collection%20and%20I%20managed%20to%20deploy%20the%20app%20without%20any%20issue.%3C%2FSPAN%3E%3CBR%20%2F%3EI%20am%20able%20to%20find%20the%20apps%20in%20a%20different%20tenant.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3ECould%20the%20issue%20be%20related%20to%20missing%20permissions%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

We have developed a simple app for SharePoint online and I am trying to deploy it to my communication site.

I have followed this article:

https://support.office.com/en-us/article/Use-the-App-Catalog-to-make-custom-business-apps-available-...

I managed to add it to "Apps for SharePoint", however when I go to "Your apps" I do not see it in the section "From your organization", where it should be available for deploying. The page displays "There is nothing here yet"


Tried to find the app in the section "Apps You can Add" but still and I am not able to see the app.


I created new site collection and I managed to deploy the app without any issue.
I am able to find the apps in a different tenant. 

Could the issue be related to missing permissions?

0 Replies