SharePoint 2016 - Custom Service 'CompliantWithMinRole' returning False

%3CLINGO-SUB%20id%3D%22lingo-sub-389675%22%20slang%3D%22en-US%22%3ESharePoint%202016%20-%20Custom%20Service%20'CompliantWithMinRole'%20returning%20False%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-389675%22%20slang%3D%22en-US%22%3E%3CP%3EPardon%20me%20if%20this%20is%20the%20incorrect%20place%20to%20ask%20this%20question.%20It's%20been%20quite%20some%20time%20since%20I've%20done%20SharePoint%20development%20for%20on-premises.%20I'm%20working%20on%20creating%20a%20service%20for%20SharePoint%202016%20and%20when%20I%20debug%20and%20look%20at%20'Services%20on%20Server'%2C%20my%20service%20is%20showing%20'No'%20under%20the%20Compliance%20column.%20In%20my%20service%20instance%20code%20I%20have%20overridden%20the%20'ShouldProvision(SPServerRole%20serverRole)'%20method%20and%20provided%20the%20list%20of%20roles%20that%20the%20service%20should%20provision%20on%2C%20but%20still%20no%20luck%20with%20it%20showing%20as%20compliant.%20Is%20there%20something%20more%20than%20just%20overriding%20that%20method%20that%20needs%20to%20be%20done%3F%20Thanks%20in%20advance%20for%20any%20assistance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-389675%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Regular Visitor

Pardon me if this is the incorrect place to ask this question. It's been quite some time since I've done SharePoint development for on-premises. I'm working on creating a service for SharePoint 2016 and when I debug and look at 'Services on Server', my service is showing 'No' under the Compliance column. In my service instance code I have overridden the 'ShouldProvision(SPServerRole serverRole)' method and provided the list of roles that the service should provision on, but still no luck with it showing as compliant. Is there something more than just overriding that method that needs to be done? Thanks in advance for any assistance.

0 Replies